]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- patchlevel 8
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 Summary:        University of Washington Pine mail user agent
6 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
7 Name:           alpine
8 %define         ver             0.99999
9 %define         patchlevel      8
10 Version:        %{ver}.%{patchlevel}
11 Release:        1
12 Epoch:          1
13 License:        Apache License 2.0
14 Group:          Applications/Mail
15 # Main site:
16 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
17 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
18 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
19 # Source0-md5:  9c5a4598feb28d6341c27c74a5770b6c
20 Source1:        pico.desktop
21 Source2:        %{name}.desktop
22 Source3:        %{name}.png
23 Patch0:         %{name}-index_display.patch
24 Patch1:         %{name}-doc.patch
25 Patch2:         %{name}-filter.patch
26 Patch3:         %{name}-quote.patch
27 Patch4:         %{name}-fhs.patch
28 Patch5:         %{name}-segfix.patch
29 Patch6:         %{name}-libc-client.patch
30 Patch7:         %{name}-fixhome.patch
31 Patch8:         %{name}-ssl.patch
32 Patch9:         %{name}-no_1777_warning.patch
33 Patch10:        %{name}-home_etc.patch
34 URL:            http://www.washington.edu/alpine/
35 BuildRequires:  autoconf
36 BuildRequires:  automake
37 BuildRequires:  home-etc-devel
38 BuildRequires:  krb5-devel
39 BuildRequires:  ncurses-devel
40 BuildRequires:  openldap-devel >= 2.4.6
41 BuildRequires:  openssl-devel
42 BuildRequires:  pam-devel
43 # Only for web-frontend:
44 #BuildRequires: tcl-devel
45 Obsoletes:      pine
46 Provides:       pine = 4.98
47 Suggests:       aspell
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         alpineconfdir   /etc/%{name}
51 %define         filterout_ld    -Wl,--as-needed
52
53 %description
54 Alpine -- an Alternatively Licensed Program for Internet News & Email
55 -- is a tool for reading, sending, and managing electronic messages.
56 Alpine is the successor to Pine and was developed by Computing &
57 Communications at the University of Washington. Though originally
58 designed for inexperienced email users, Alpine supports many advanced
59 features, and an ever-growing number of configuration and
60 personal-preference options.
61
62 %description -l pl.UTF-8
63 Alpine, czyli Alternatively Licensed Program for Internet News & Email
64 (alternatywnie licencjonowany program do newsów i poczty internetowej)
65 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
66 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
67 wydział Computing & Communications (Obliczeń i komunikacji) na
68 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
69 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
70 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
71 ciągle rośnie.
72
73 %package -n pico
74 Summary:        Simple text editor in the style of the Pine Composer
75 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
76 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
77 Group:          Applications/Editors
78
79 %description -n pico
80 Pico is a simple, display-oriented text editor based on the Alpine
81 message system composer. As with Pine, commands are displayed at the
82 bottom of the screen, and context-sensitive help is provided. As
83 characters are typed they are immediately inserted into the text.
84
85 %description -n pico -l pl.UTF-8
86 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
87 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
88 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
89 włączane do tekstu.
90
91 %description -n pico -l pt_BR.UTF-8
92 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
93 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
94 e ajuda de acordo com o contexto está disponível.
95
96 %package -n pilot
97 Summary:        Simple file system browser in the style of the Alpine Composer
98 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
99 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
100 Group:          Applications/Shells
101
102 %description -n pilot
103 Pilot is a simple, display-oriented file system browser based on the
104 Alpine message system composer. As with Alpine, commands are displayed at
105 the bottom of the screen, and context-sensitive help is provided.
106
107 %description -n pilot -l pl.UTF-8
108 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
109 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
110 dole ekranu oraz jest dostępna pomoc kontekstowa.
111
112 %description -n pilot -l pt_BR.UTF-8
113 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
114 como no Pine, comandos são apresentados na parte de baixo da tela, e
115 ajuda de acordo com o contexto está disponível.
116
117 %prep
118 %setup -q -n %{name}-%{ver}
119 %patch0 -p1
120 %patch1 -p1
121 %patch2 -p1
122 %patch3 -p1
123 %patch4 -p1
124 %patch5 -p1
125 %patch6 -p1
126 %patch7 -p1
127 %patch8 -p1
128 %patch9 -p1
129 %patch10 -p1
130
131 %build
132 rm -f libtool missing
133 %{__libtoolize}
134 %{__aclocal} -I m4
135 %{__autoconf}
136 %{__autoheader}
137 %{__automake}
138 %configure \
139         --enable-quotas \
140         --without-tcl \
141         --with-smtp-msa=%{_libdir}/sendmail \
142         --with-simple-spellcheck=aspell \
143         --with-interactive-spellcheck=aspell \
144         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
145         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
146         --with-krb5-dir=%{_prefix} \
147         --with-ldap-dir=%{_prefix} \
148         --with-system-mail-directory=/var/mail \
149         --with-passfile=.pine.pwd
150
151 %{__make} \
152         GCCOPTLEVEL="%{rpmcflags}"
153
154 %install
155 rm -rf $RPM_BUILD_ROOT
156 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
157
158 %{__make} install \
159         DESTDIR=$RPM_BUILD_ROOT
160
161 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
162 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
163 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
164
165 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
166
167 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf
168 cat <<EOF > $RPM_BUILD_ROOT%{alpineconfdir}/alpine.conf.fixed
169 #
170 # Alpine system-wide enforced configuration file - customize as needed
171 #
172 # This file holds the system-wide enforced values for alpine configuration
173 # settings. Any values set in it will override values set in the
174 # system-wide default configuration file (%{alpineconfdir}/alpine.conf) and
175 # the user's own configuration file (~/.pinerc).
176 # For more information on the format of this file, read the
177 # comments at the top of %{alpineconfdir}/alpine.conf
178
179 EOF
180
181 %clean
182 rm -rf $RPM_BUILD_ROOT
183
184 %files
185 %defattr(644,root,root,755)
186 %doc README doc/tech-notes.txt
187 %dir %{alpineconfdir}
188 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf
189 %config(noreplace) %verify(not md5 mtime size) %{alpineconfdir}/alpine.conf.fixed
190 %attr(755,root,root) %{_bindir}/%{name}
191 %attr(755,root,root) %{_bindir}/pine
192 %attr(755,root,root) %{_bindir}/rpload
193 %attr(755,root,root) %{_bindir}/rpdump
194 %{_mandir}/man1/%{name}.1*
195 %{_mandir}/man1/rpload.1*
196 %{_mandir}/man1/rpdump.1*
197 %{_desktopdir}/%{name}.desktop
198 %{_pixmapsdir}/%{name}.png
199
200 %files -n pico
201 %defattr(644,root,root,755)
202 %attr(755,root,root) %{_bindir}/pico
203 %{_desktopdir}/pico.desktop
204 %{_mandir}/man1/pico*
205
206 %files -n pilot
207 %defattr(644,root,root,755)
208 %attr(755,root,root) %{_bindir}/pilot
209 %{_mandir}/man1/pilot*
This page took 0.040584 seconds and 4 git commands to generate.