]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- added thread_end patch
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - review patches from pine:
5 #   - home_etc support
6 #   - ....many more
7 Summary:        University of Washington Pine mail user agent
8 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
9 Name:           alpine
10 %define         ver             0.9999
11 %define         patchlevel      18
12 Version:        %{ver}.%{patchlevel}
13 Release:        1
14 Epoch:          1
15 License:        Apache License 2.0
16 Group:          Applications/Mail
17 # Main site:
18 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
20 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21 # Source0-md5:  888ecef4d50e15e4237f7a7a55793f68
22 Source1:        pico.desktop
23 Source2:        %{name}.desktop
24 Source3:        %{name}.png
25 Patch0:         %{name}-thread_end.patch
26 URL:            http://www.washington.edu/alpine
27 BuildRequires:  autoconf
28 BuildRequires:  automake
29 BuildRequires:  krb5-devel
30 BuildRequires:  ncurses-devel
31 BuildRequires:  openldap-devel
32 BuildRequires:  openssl-devel
33 BuildRequires:  pam-devel
34 BuildRequires:  tcl-devel
35 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
36
37 %define         alpineconfdir   /etc/%{name}
38
39 %description
40 Alpine -- an Alternatively Licensed Program for Internet News & Email
41 -- is a tool for reading, sending, and managing electronic messages.
42 Alpine is the successor to Pine and was developed by Computing &
43 Communications at the University of Washington. Though originally
44 designed for inexperienced email users, Alpine supports many advanced
45 features, and an ever-growing number of configuration and
46 personal-preference options.
47
48 %description -l pl.UTF-8
49 Alpine, czyli Alternatively Licensed Program for Internet News & Email
50 (alternatywnie licencjonowany program do newsów i poczty internetowej)
51 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
52 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
53 wydział Computing & Communications (Obliczeń i komunikacji) na
54 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
55 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
56 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
57 ciągle rośnie.
58
59 %package -n pico
60 Summary:        Simple text editor in the style of the Pine Composer
61 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
62 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
63 Group:          Applications/Editors
64
65 %description -n pico
66 Pico is a simple, display-oriented text editor based on the Alpine
67 message system composer. As with Pine, commands are displayed at the
68 bottom of the screen, and context-sensitive help is provided. As
69 characters are typed they are immediately inserted into the text.
70
71 %description -n pico -l pl.UTF-8
72 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
73 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
74 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
75 włączane do tekstu.
76
77 %description -n pico -l pt_BR.UTF-8
78 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
79 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
80 e ajuda de acordo com o contexto está disponível.
81
82 %package -n pilot
83 Summary:        Simple file system browser in the style of the Alpine Composer
84 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
85 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
86 Group:          Applications/Shells
87
88 %description -n pilot
89 Pilot is a simple, display-oriented file system browser based on the
90 Alpine message system composer. As with Alpine, commands are displayed at
91 the bottom of the screen, and context-sensitive help is provided.
92
93 %description -n pilot -l pl.UTF-8
94 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
95 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
96 dole ekranu oraz jest dostępna pomoc kontekstowa.
97
98 %description -n pilot -l pt_BR.UTF-8
99 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
100 como no Pine, comandos são apresentados na parte de baixo da tela, e
101 ajuda de acordo com o contexto está disponível.
102
103 %prep
104 %setup -q -n %{name}-%{ver}
105 %patch0 -p1
106
107 %build
108 %{__autoconf}
109 %{__aclocal} -I m4
110 %{__automake}
111 %configure \
112         --enable-quotas \
113         --with-smtp-msa=%{_libdir}/sendmail \
114         --with-spellcheck-prog=aspell \
115         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
116         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
117         --with-krb5-dir=%{_prefix} \
118         --with-ldap-dir=%{_prefix} \
119         --with-system-mail-directory=/var/mail
120 %{__make}
121
122 %install
123 rm -rf $RPM_BUILD_ROOT
124 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
125
126 %{__make} install \
127         DESTDIR=$RPM_BUILD_ROOT
128
129 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
130 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
131 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
132
133
134 %clean
135 rm -rf $RPM_BUILD_ROOT
136
137 %files
138 %defattr(644,root,root,755)
139 %doc README doc/tech-notes.txt
140 %dir %{alpineconfdir}
141 %attr(755,root,root) %{_bindir}/%{name}
142 %attr(755,root,root) %{_bindir}/rpload
143 %attr(755,root,root) %{_bindir}/rpdump
144 #%attr(755,root,root) %{_bindir}/mailutil
145 #%attr(2755,root,mail) %{_sbindir}/mlock
146 %{_mandir}/man1/%{name}.1*
147 #%{_mandir}/man1/rpload.1*
148 #%{_mandir}/man1/rpdump.1*
149 #%{_mandir}/man1/mailutil.1*
150 %{_desktopdir}/%{name}.desktop
151 %{_pixmapsdir}/%{name}.png
152
153 %files -n pico
154 %defattr(644,root,root,755)
155 %attr(755,root,root) %{_bindir}/pico
156 %{_desktopdir}/pico.desktop
157 %{_mandir}/man1/pico*
158
159 %files -n pilot
160 %defattr(644,root,root,755)
161 %attr(755,root,root) %{_bindir}/pilot
162 %{_mandir}/man1/pilot*
This page took 0.093843 seconds and 4 git commands to generate.