]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
- 0.9999 patchlevel 18, added desktop and icon from pine
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - alpine should obsolete pine, link pine -> alpine should be made
4 # - review patches from pine:
5 #   - home_etc support
6 #   - ....many more
7 Summary:        University of Washington Pine mail user agent
8 Summary(pl.UTF-8):      Klient pocztowy Pine z Uniwersytetu w Waszyngtonie
9 Name:           alpine
10 %define         ver             0.9999
11 %define         patchlevel      18
12 Version:        %{ver}.%{patchlevel}
13 Release:        1
14 Epoch:          1
15 License:        Apache License 2.0
16 Group:          Applications/Mail
17 # Main site:
18 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
19 # Source with applied patches from http://staff.washington.edu/chappa/alpine/ 
20 Source0:        http://staff.washington.edu/chappa/alpine/patches/alpine-%{ver}/%{name}-%{ver}_%{patchlevel}.tar.gz
21 # Source0-md5:  888ecef4d50e15e4237f7a7a55793f68
22 Source1:        pico.desktop
23 Source2:        %{name}.desktop
24 Source3:        %{name}.png
25 URL:            http://www.washington.edu/alpine
26 BuildRequires:  autoconf
27 BuildRequires:  automake
28 BuildRequires:  krb5-devel
29 BuildRequires:  ncurses-devel
30 BuildRequires:  openldap-devel
31 BuildRequires:  openssl-devel
32 BuildRequires:  pam-devel
33 BuildRequires:  tcl-devel
34 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
35
36 %define         alpineconfdir   /etc/%{name}
37
38 %description
39 Alpine -- an Alternatively Licensed Program for Internet News & Email
40 -- is a tool for reading, sending, and managing electronic messages.
41 Alpine is the successor to Pine and was developed by Computing &
42 Communications at the University of Washington. Though originally
43 designed for inexperienced email users, Alpine supports many advanced
44 features, and an ever-growing number of configuration and
45 personal-preference options.
46
47 %description -l pl.UTF-8
48 Alpine, czyli Alternatively Licensed Program for Internet News & Email
49 (alternatywnie licencjonowany program do newsów i poczty internetowej)
50 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
51 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
52 wydział Computing & Communications (Obliczeń i komunikacji) na
53 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
54 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
55 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
56 ciągle rośnie.
57
58 %package -n pico
59 Summary:        Simple text editor in the style of the Pine Composer
60 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
61 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
62 Group:          Applications/Editors
63
64 %description -n pico
65 Pico is a simple, display-oriented text editor based on the Alpine
66 message system composer. As with Pine, commands are displayed at the
67 bottom of the screen, and context-sensitive help is provided. As
68 characters are typed they are immediately inserted into the text.
69
70 %description -n pico -l pl.UTF-8
71 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
72 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
73 dostępna jest pomoc konteksowa. Wpisywane znaki są natychmiast
74 włączane do tekstu.
75
76 %description -n pico -l pt_BR.UTF-8
77 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
78 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
79 e ajuda de acordo com o contexto está disponível.
80
81 %package -n pilot
82 Summary:        Simple file system browser in the style of the Alpine Composer
83 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
84 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
85 Group:          Applications/Shells
86
87 %description -n pilot
88 Pilot is a simple, display-oriented file system browser based on the
89 Alpine message system composer. As with Alpine, commands are displayed at
90 the bottom of the screen, and context-sensitive help is provided.
91
92 %description -n pilot -l pl.UTF-8
93 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
94 stylu compsera pine. Podobnie jak w alpine polecenia sa wyświetlane na
95 dole ekranu oraz jest dostępna pomoc kontekstowa.
96
97 %description -n pilot -l pt_BR.UTF-8
98 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
99 como no Pine, comandos são apresentados na parte de baixo da tela, e
100 ajuda de acordo com o contexto está disponível.
101
102 %prep
103 %setup -q -n %{name}-%{ver}
104
105 %build
106 %{__autoconf}
107 %{__aclocal} -I m4
108 %{__automake}
109 %configure \
110         --enable-quotas \
111         --with-smtp-msa=%{_libdir}/sendmail \
112         --with-spellcheck-prog=aspell \
113         --with-system-pinerc=%{alpineconfdir}/%{name}.conf \
114         --with-system-fixed-pinerc=%{alpineconfdir}/%{name}.conf.fixed \
115         --with-krb5-dir=%{_prefix} \
116         --with-ldap-dir=%{_prefix} \
117         --with-system-mail-directory=/var/mail
118 %{__make}
119
120 %install
121 rm -rf $RPM_BUILD_ROOT
122 install -d $RPM_BUILD_ROOT{%{alpineconfdir},%{_desktopdir},%{_pixmapsdir}}
123
124 %{__make} install \
125         DESTDIR=$RPM_BUILD_ROOT
126
127 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
128 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
129 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
130
131
132 %clean
133 rm -rf $RPM_BUILD_ROOT
134
135 %files
136 %defattr(644,root,root,755)
137 %doc README doc/tech-notes.txt
138 %dir %{alpineconfdir}
139 %attr(755,root,root) %{_bindir}/%{name}
140 %attr(755,root,root) %{_bindir}/rpload
141 %attr(755,root,root) %{_bindir}/rpdump
142 #%attr(755,root,root) %{_bindir}/mailutil
143 #%attr(2755,root,mail) %{_sbindir}/mlock
144 %{_mandir}/man1/%{name}.1*
145 #%{_mandir}/man1/rpload.1*
146 #%{_mandir}/man1/rpdump.1*
147 #%{_mandir}/man1/mailutil.1*
148 %{_desktopdir}/%{name}.desktop
149 %{_pixmapsdir}/%{name}.png
150
151 %files -n pico
152 %defattr(644,root,root,755)
153 %attr(755,root,root) %{_bindir}/pico
154 %{_desktopdir}/pico.desktop
155 %{_mandir}/man1/pico*
156
157 %files -n pilot
158 %defattr(644,root,root,755)
159 %attr(755,root,root) %{_bindir}/pilot
160 %{_mandir}/man1/pilot*
This page took 0.083467 seconds and 4 git commands to generate.