]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
b1bdc181b9eae9fd9c6c65903786616bce646a03
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 Summary:        University of Washington Alpine mail user agent
7 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
8 Name:           alpine
9 Version:        2.11
10 Release:        0.1
11 Epoch:          1
12 License:        Apache v2.0
13 Group:          Applications/Mail
14 # Main site:
15 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
16 # Current source is from: http://patches.freeiz.com/alpine/
17 Source0:        http://patches.freeiz.com/alpine/patches/%{name}-%{version}/%{name}-%{version}.tar.xz
18 # Source0-md5:  d2d9ca3716b9a23e5fa41ddf5ad06b6b
19 Source1:        pico.desktop
20 Source2:        %{name}.desktop
21 Source3:        %{name}.png
22 Patch0:         %{name}-index_display.patch
23 Patch1:         %{name}-doc.patch
24 Patch2:         %{name}-filter.patch
25 Patch3:         %{name}-fhs.patch
26 Patch4:         %{name}-libc-client.patch
27 Patch5:         %{name}-ssl.patch
28 Patch6:         %{name}-no_1777_warning.patch
29 Patch7:         %{name}-home_etc.patch
30 Patch8:         %{name}-RFC1522_MAXW.patch
31 Patch9:         mimedesc.patch
32 Patch11:        format-security.patch
33 URL:            http://www.washington.edu/alpine/
34 BuildRequires:  autoconf
35 BuildRequires:  automake
36 BuildRequires:  home-etc-devel
37 %if "%{pld_release}" != "ac"
38 BuildRequires:  heimdal-devel
39 %endif
40 BuildRequires:  libtool
41 BuildRequires:  ncurses-devel
42 BuildRequires:  openldap-devel
43 BuildRequires:  openssl-devel
44 BuildRequires:  pam-devel
45 # Only for web-frontend:
46 #BuildRequires: tcl-devel
47 Suggests:       aspell
48 Suggests:       ca-certificates
49 Conflicts:      ca-certificates < 20080809-4
50 Provides:       pine = 6.00
51 Obsoletes:      pine
52 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
53
54 %define         alpineconfdir   %{_sysconfdir}/%{name}
55 %define         filterout_ld    -Wl,--as-needed
56
57 %description
58 Alpine -- an Alternatively Licensed Program for Internet News & Email
59 -- is a tool for reading, sending, and managing electronic messages.
60 Alpine is the successor to Pine and was developed by Computing &
61 Communications at the University of Washington. Though originally
62 designed for inexperienced email users, Alpine supports many advanced
63 features, and an ever-growing number of configuration and
64 personal-preference options.
65
66 %description -l pl.UTF-8
67 Alpine, czyli Alternatively Licensed Program for Internet News & Email
68 (alternatywnie licencjonowany program do newsów i poczty internetowej)
69 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
70 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
71 wydział Computing & Communications (Obliczeń i komunikacji) na
72 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
73 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
74 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
75 ciągle rośnie.
76
77 %package -n pico
78 Summary:        Simple text editor in the style of the Pine Composer
79 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
80 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
81 Group:          Applications/Editors
82 Provides:       pico = 6.00
83
84 %description -n pico
85 Pico is a simple, display-oriented text editor based on the Alpine
86 message system composer. As with Pine, commands are displayed at the
87 bottom of the screen, and context-sensitive help is provided. As
88 characters are typed they are immediately inserted into the text.
89
90 %description -n pico -l pl.UTF-8
91 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
92 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
93 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
94 włączane do tekstu.
95
96 %description -n pico -l pt_BR.UTF-8
97 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
98 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
99 e ajuda de acordo com o contexto está disponível.
100
101 %package -n pilot
102 Summary:        Simple file system browser in the style of the Alpine Composer
103 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
104 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
105 Group:          Applications/Shells
106 Provides:       pilot = 6.00
107
108 %description -n pilot
109 Pilot is a simple, display-oriented file system browser based on the
110 Alpine message system composer. As with Alpine, commands are displayed
111 at the bottom of the screen, and context-sensitive help is provided.
112
113 %description -n pilot -l pl.UTF-8
114 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
115 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
116 na dole ekranu oraz jest dostępna pomoc kontekstowa.
117
118 %description -n pilot -l pt_BR.UTF-8
119 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
120 como no Pine, comandos são apresentados na parte de baixo da tela, e
121 ajuda de acordo com o contexto está disponível.
122
123 %prep
124 %setup -q
125 %patch0 -p1
126 %patch1 -p1
127 %patch2 -p1
128 %patch3 -p1
129 %patch4 -p1
130 %patch5 -p1
131 %patch6 -p1
132 %patch7 -p1
133 %patch8 -p1
134 %patch9 -p1
135
136 %build
137 rm -f libtool missing
138 %{__libtoolize}
139 %{__aclocal} -I m4
140 %{__autoconf}
141 %{__autoheader}
142 %{__automake}
143 %configure \
144         --%{?debug:en}%{!?debug:dis}able-debug \
145         --enable-quotas \
146         --without-tcl \
147         --with-smtp-msa=/usr/lib/sendmail \
148         --with-simple-spellcheck=aspell \
149         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
150         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
151         --with-krb5-dir=%{_prefix} \
152         --with-ldap-dir=%{_prefix} \
153         --with-system-mail-directory=/var/mail \
154         --with-c-client-target=slx \
155 %if "%{pld_release}" == "ti"
156         --with-ssl-dir=/var/lib/openssl/certs \
157         --with-ssl-certs-dir=/var/lib/openssl/certs \
158 %else
159         --with-ssl-dir=/etc/openssl/certs \
160         --with-ssl-certs-dir=/etc/certs \
161         --with-ssl-lib-dir=%{_libdir} \
162 %endif
163         --with-passfile=.pine.pwd
164
165 %{__make} \
166         GCCOPTLEVEL="%{rpmcflags}"
167
168 %install
169 rm -rf $RPM_BUILD_ROOT
170 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
171
172 %{__make} install \
173         DESTDIR=$RPM_BUILD_ROOT
174
175 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
176 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
177 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
178
179 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
180
181 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
182 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
183 #
184 # Alpine system-wide enforced configuration file - customize as needed
185 #
186 # This file holds the system-wide enforced values for alpine configuration
187 # settings. Any values set in it will override values set in the
188 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
189 # the user's own configuration file (~/.pinerc).
190 # For more information on the format of this file, read the
191 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
192
193 EOF
194
195 %clean
196 rm -rf $RPM_BUILD_ROOT
197
198 %files
199 %defattr(644,root,root,755)
200 %doc README doc/tech-notes.txt
201 %dir %{_sysconfdir}/%{name}
202 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
203 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
204 %attr(755,root,root) %{_bindir}/%{name}
205 %attr(755,root,root) %{_bindir}/pine
206 %attr(755,root,root) %{_bindir}/rpload
207 %attr(755,root,root) %{_bindir}/rpdump
208 %{_mandir}/man1/%{name}.1*
209 %{_mandir}/man1/rpload.1*
210 %{_mandir}/man1/rpdump.1*
211 %{_desktopdir}/%{name}.desktop
212 %{_pixmapsdir}/%{name}.png
213
214 %files -n pico
215 %defattr(644,root,root,755)
216 %attr(755,root,root) %{_bindir}/pico
217 %{_desktopdir}/pico.desktop
218 %{_mandir}/man1/pico*
219
220 %files -n pilot
221 %defattr(644,root,root,755)
222 %attr(755,root,root) %{_bindir}/pilot
223 %{_mandir}/man1/pilot*
This page took 0.056788 seconds and 3 git commands to generate.