]> git.pld-linux.org Git - packages/alpine.git/blob - alpine.spec
4eb85286d104273370ae91878a6d29fd6f85b819
[packages/alpine.git] / alpine.spec
1 # TODO:
2 # - backport man-pages from pine.spec
3 # - separate package with tcl web-frontend
4 # - fix as-needed
5 # - pico shouldn't link with kerberos, should it?
6 Summary:        University of Washington Alpine mail user agent
7 Summary(pl.UTF-8):      Klient pocztowy Alpine z Uniwersytetu w Waszyngtonie
8 Name:           alpine
9 Version:        2.11
10 Release:        0.1
11 Epoch:          1
12 License:        Apache v2.0
13 Group:          Applications/Mail
14 # Main site:
15 #Source0:       ftp://ftp.cac.washington.edu/alpine/%{name}-%{version}.tar.gz
16 # Current source is from: http://patches.freeiz.com/alpine/
17 Source0:        http://patches.freeiz.com/alpine/patches/%{name}-%{version}/%{name}-%{version}.tar.xz
18 # Source0-md5:  d2d9ca3716b9a23e5fa41ddf5ad06b6b
19 Source1:        pico.desktop
20 Source2:        %{name}.desktop
21 Source3:        %{name}.png
22 Patch0:         %{name}-index_display.patch
23 Patch1:         %{name}-doc.patch
24 Patch2:         %{name}-filter.patch
25 Patch3:         %{name}-fhs.patch
26 Patch4:         %{name}-libc-client.patch
27 Patch5:         %{name}-ssl.patch
28 Patch6:         %{name}-no_1777_warning.patch
29 Patch7:         %{name}-home_etc.patch
30 Patch8:         %{name}-RFC1522_MAXW.patch
31 Patch9:         mimedesc.patch
32 URL:            http://www.washington.edu/alpine/
33 BuildRequires:  autoconf
34 BuildRequires:  automake
35 BuildRequires:  home-etc-devel
36 %if "%{pld_release}" != "ac"
37 BuildRequires:  heimdal-devel
38 %endif
39 BuildRequires:  libtool
40 BuildRequires:  ncurses-devel
41 BuildRequires:  openldap-devel
42 BuildRequires:  openssl-devel
43 BuildRequires:  pam-devel
44 # Only for web-frontend:
45 #BuildRequires: tcl-devel
46 Suggests:       aspell
47 Suggests:       ca-certificates
48 Conflicts:      ca-certificates < 20080809-4
49 Provides:       pine = 6.00
50 Obsoletes:      pine
51 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
52
53 %define         alpineconfdir   %{_sysconfdir}/%{name}
54 %define         filterout_ld    -Wl,--as-needed
55
56 %description
57 Alpine -- an Alternatively Licensed Program for Internet News & Email
58 -- is a tool for reading, sending, and managing electronic messages.
59 Alpine is the successor to Pine and was developed by Computing &
60 Communications at the University of Washington. Though originally
61 designed for inexperienced email users, Alpine supports many advanced
62 features, and an ever-growing number of configuration and
63 personal-preference options.
64
65 %description -l pl.UTF-8
66 Alpine, czyli Alternatively Licensed Program for Internet News & Email
67 (alternatywnie licencjonowany program do newsów i poczty internetowej)
68 to narzędzie do czytania, wysyłania i zarządzania wiadomościami
69 elektronicznymi. Alpine jest następcą Pine'a i został napisany przez
70 wydział Computing & Communications (Obliczeń i komunikacji) na
71 Uniwersytecie w Waszyngtonie. Mimo że Alpine pierwotnie został
72 zaprojektowany dla niedoświadczonych użytkowników poczty, obsługuje
73 wiele zaawansowanych możliwości, a liczba opcji konfiguracyjnych
74 ciągle rośnie.
75
76 %package -n pico
77 Summary:        Simple text editor in the style of the Pine Composer
78 Summary(pl.UTF-8):      Prosty edytor tekstowy w stylu alpine
79 Summary(pt_BR.UTF-8):   Editor de textos para terminal simples e fácil de usar
80 Group:          Applications/Editors
81 Provides:       pico = 6.00
82
83 %description -n pico
84 Pico is a simple, display-oriented text editor based on the Alpine
85 message system composer. As with Pine, commands are displayed at the
86 bottom of the screen, and context-sensitive help is provided. As
87 characters are typed they are immediately inserted into the text.
88
89 %description -n pico -l pl.UTF-8
90 Pico jest prostym, zorientowanym na wyświetlanie edytorem bazującym na
91 alpine. Tak jak w pine komendy są wyświetlane na dole ekranu oraz
92 dostępna jest pomoc kontekstowa. Wpisywane znaki są natychmiast
93 włączane do tekstu.
94
95 %description -n pico -l pt_BR.UTF-8
96 Pico é um editor de texto baseado no compositor de mensagens do Alpine.
97 Assim como no Pine, comandos são mostrados na parte de baixo da tela,
98 e ajuda de acordo com o contexto está disponível.
99
100 %package -n pilot
101 Summary:        Simple file system browser in the style of the Alpine Composer
102 Summary(pl.UTF-8):      Prosta przeglądarka plików w stylu composera alpine
103 Summary(pt_BR.UTF-8):   Navegador de sistemas de arquivos no estilo do compositor do Alpine
104 Group:          Applications/Shells
105 Provides:       pilot = 6.00
106
107 %description -n pilot
108 Pilot is a simple, display-oriented file system browser based on the
109 Alpine message system composer. As with Alpine, commands are displayed
110 at the bottom of the screen, and context-sensitive help is provided.
111
112 %description -n pilot -l pl.UTF-8
113 Pilot jest prostą, zorientowaną na wyświetlanie przeglądarką plików w
114 stylu composera pine. Podobnie jak w alpine polecenia są wyświetlane
115 na dole ekranu oraz jest dostępna pomoc kontekstowa.
116
117 %description -n pilot -l pt_BR.UTF-8
118 Pilot é um navegador de sistemas de arquivos baseado no Pine. Assim
119 como no Pine, comandos são apresentados na parte de baixo da tela, e
120 ajuda de acordo com o contexto está disponível.
121
122 %prep
123 %setup -q
124 %patch0 -p1
125 %patch1 -p1
126 %patch2 -p1
127 %patch3 -p1
128 %patch4 -p1
129 %patch5 -p1
130 %patch6 -p1
131 %patch7 -p1
132 %patch8 -p1
133 %patch9 -p1
134
135 %build
136 rm -f libtool missing
137 %{__libtoolize}
138 %{__aclocal} -I m4
139 %{__autoconf}
140 %{__autoheader}
141 %{__automake}
142 %configure \
143         --%{?debug:en}%{!?debug:dis}able-debug \
144         --enable-quotas \
145         --without-tcl \
146         --with-smtp-msa=/usr/lib/sendmail \
147         --with-simple-spellcheck=aspell \
148         --with-system-pinerc=%{_sysconfdir}/%{name}/%{name}.conf \
149         --with-system-fixed-pinerc=%{_sysconfdir}/%{name}/%{name}.conf.fixed \
150         --with-krb5-dir=%{_prefix} \
151         --with-ldap-dir=%{_prefix} \
152         --with-system-mail-directory=/var/mail \
153         --with-c-client-target=slx \
154 %if "%{pld_release}" == "ti"
155         --with-ssl-dir=/var/lib/openssl/certs \
156         --with-ssl-certs-dir=/var/lib/openssl/certs \
157 %else
158         --with-ssl-dir=/etc/openssl/certs \
159         --with-ssl-certs-dir=/etc/certs \
160         --with-ssl-lib-dir=%{_libdir} \
161 %endif
162         --with-passfile=.pine.pwd
163
164 %{__make} \
165         GCCOPTLEVEL="%{rpmcflags}"
166
167 %install
168 rm -rf $RPM_BUILD_ROOT
169 install -d $RPM_BUILD_ROOT{%{_sysconfdir}/%{name},%{_desktopdir},%{_pixmapsdir}}
170
171 %{__make} install \
172         DESTDIR=$RPM_BUILD_ROOT
173
174 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
175 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
176 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
177
178 ln -s alpine $RPM_BUILD_ROOT%{_bindir}/pine
179
180 $RPM_BUILD_ROOT%{_bindir}/alpine -conf > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf
181 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/%{name}/alpine.conf.fixed
182 #
183 # Alpine system-wide enforced configuration file - customize as needed
184 #
185 # This file holds the system-wide enforced values for alpine configuration
186 # settings. Any values set in it will override values set in the
187 # system-wide default configuration file (%{_sysconfdir}/%{name}/alpine.conf) and
188 # the user's own configuration file (~/.pinerc).
189 # For more information on the format of this file, read the
190 # comments at the top of %{_sysconfdir}/%{name}/alpine.conf
191
192 EOF
193
194 %clean
195 rm -rf $RPM_BUILD_ROOT
196
197 %files
198 %defattr(644,root,root,755)
199 %doc README doc/tech-notes.txt
200 %dir %{_sysconfdir}/%{name}
201 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf
202 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/%{name}/alpine.conf.fixed
203 %attr(755,root,root) %{_bindir}/%{name}
204 %attr(755,root,root) %{_bindir}/pine
205 %attr(755,root,root) %{_bindir}/rpload
206 %attr(755,root,root) %{_bindir}/rpdump
207 %{_mandir}/man1/%{name}.1*
208 %{_mandir}/man1/rpload.1*
209 %{_mandir}/man1/rpdump.1*
210 %{_desktopdir}/%{name}.desktop
211 %{_pixmapsdir}/%{name}.png
212
213 %files -n pico
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_bindir}/pico
216 %{_desktopdir}/pico.desktop
217 %{_mandir}/man1/pico*
218
219 %files -n pilot
220 %defattr(644,root,root,755)
221 %attr(755,root,root) %{_bindir}/pilot
222 %{_mandir}/man1/pilot*
This page took 0.040834 seconds and 3 git commands to generate.