]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro5.spec
- up to 5.0.2.1
[packages/allegro5.git] / allegro5.spec
1 #
2 # TODO: - Handle situations when there are no modules (most bconds turned off)
3 #       - make bconds work again or remove
4 #       - make it usable
5 #
6 # Conditional build:
7 %bcond_without  alsa    # without ALSA modules
8 #%%bcond_without        arts    # without aRts module
9 #%%bcond_without        dga2    # without DGA2 module
10 #%%bcond_without        dbglib  # don't build debug versions of library
11 #%%bcond_without        esd     # without esound module
12 #%%bcond_without        fbcon   # without framebuffer module
13 #%%bcond_without        jack    # without JACK module
14 #%%bcond_without        proflib # don't debug profiling versions of library
15 #%%bcond_without        sse     # build without sse
16 #%%bcond_without        svga    # without svgalib module
17 #%%bcond_without        vga     # without vga module
18 #
19 Summary:        A game programming library
20 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
21 Summary(es.UTF-8):      Una biblioteca de programación de juegos
22 Summary(fr.UTF-8):      Une librairie de programmation de jeux
23 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
24 Summary(pl.UTF-8):      Biblioteka do programowania gier
25 Name:           allegro5
26 Version:        5.0.2.1
27 Release:        0.1
28 License:        Giftware
29 Group:          Libraries
30 Source0:        http://downloads.sourceforge.net/alleg/allegro-%{version}.tar.gz
31 # Source0-md5:  b92276fb9bf47555476d7c1ed39634a9
32 Patch0:         %{name}-info.patch
33 Patch1:         %{name}-examples.patch
34 Patch2:         %{name}-opt.patch
35 Patch3:         %{name}-frame-pointer.patch
36 Patch4:         %{name}-config.patch
37 URL:            http://alleg.sourceforge.net/
38 BuildRequires:  OpenGL-GLU-devel
39 %{?with_alsa:BuildRequires:     alsa-lib-devel}
40 #%%{?with_arts:BuildRequires:   artsc-devel}
41 BuildRequires:  cmake >= 2.6
42 BuildRequires:  curl-devel
43 #%%{?with_esd:BuildRequires:    esound-devel}
44 #%%if %{with jack}
45 #BuildRequires: jack-audio-connection-kit-devel
46 #BuildRequires: physfs-devel
47 #BuildRequires: pkgconfig
48 #%%endif
49 BuildRequires:  rpmbuild(macros) >= 1.600
50 #BuildRequires: sed >= 4.0
51 #%%{?with_svga:BuildRequires:   svgalib-devel}
52 #BuildRequires: texinfo
53 BuildRequires:  xorg-lib-libX11-devel
54 BuildRequires:  xorg-lib-libXcursor-devel
55 BuildRequires:  xorg-lib-libXext-devel
56 BuildRequires:  xorg-lib-libXpm-devel
57 #BuildRequires: xorg-lib-libXxf86dga-devel
58 BuildRequires:  xorg-lib-libXxf86vm-devel
59 Obsoletes:      allegro
60 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
61
62 %description
63 Allegro is a cross-platform library intended for use in computer games
64 and other types of multimedia programming.
65
66 %description -l de.UTF-8
67 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
68 Computerspielen und anderen Formen von Multinediaprogrammierung.
69
70 %description -l es.UTF-8
71 Allegro es una librería multi-plataforma creada para ser usada en la
72 programación de juegos u otro tipo de programación multimedia.
73
74 %description -l fr.UTF-8
75 Allegro est une librairie multi-plateforme destinée à être utilisée
76 dans les jeux vidéo ou d'autres types de programmation multimédia.
77
78 %description -l it.UTF-8
79 Allegro è una libreria multipiattaforma dedicata all'uso nei
80 videogiochi ed in altri tipi di programmazione multimediale.
81
82 %description -l pl.UTF-8
83 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
84 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
85
86 %package devel
87 Summary:        A game programming library - header files
88 Summary(es.UTF-8):      Archivos de inclusión
89 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
90 Group:          Development/Libraries
91 Requires:       %{name} = %{version}-%{release}
92 Obsoletes:      allegro-devel
93
94 %description devel
95 Allegro is a cross-platform library intended for use in computer games
96 and other types of multimedia programming.
97
98 This package contains header files neccessary for compiling
99 applications using allegro library.
100
101 %description devel -l de.UTF-8
102 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
103 Computerspielen und anderen Formen von Multinediaprogrammierung.
104 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
105 verwenden.
106
107 %description devel -l es.UTF-8
108 Allegro es una librería multi-plataforma creada para ser usada en la
109 programación de juegos u otro tipo de programación multimedia. Este
110 paquete es necesario para compilar los programas que usen Allegro.
111
112 %description devel -l fr.UTF-8
113 Allegro est une librairie multi-plateforme destinée à être utilisée
114 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
115 package est nécessaire pour compiler les programmes utilisant Allegro.
116
117 %description devel -l it.UTF-8
118 Allegro è una libreria multipiattaforma dedicata all'uso nei
119 videogiochi ed in altri tipi di programmazione multimediale. Questo
120 pacchetto è necessario per compilare programmi scritti con Allegro.
121
122 %description devel -l pl.UTF-8
123 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
124 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
125
126 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
127 aplikacji wykorzystujących bibliotekę allegro.
128
129 %package debug
130 Summary:        liballd - debug version of shared allegro library
131 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
132 Group:          Development/Libraries
133 Requires:       %{name}-devel = %{version}-%{release}
134 Obsoletes:      allegro-debug
135
136 %description debug
137 liballd - debug version of shared allegro library (contains debugging
138 symbols and other information).
139
140 %description debug -l pl.UTF-8
141 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
142 symbole i inne informacje potrzebne przy odpluskwianiu).
143
144 %package profile
145 Summary:        liballp - profiling version of shared allegro library
146 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}-%{release}
149 Obsoletes:      allegro-profile
150
151 %description profile
152 liballp - profiling version of shared allegro library.
153
154 %description profile -l pl.UTF-8
155 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
156
157 %package svgalib
158 Summary:        A game programming library - svgalib module
159 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
160 Group:          Libraries
161 Requires:       %{name} = %{version}-%{release}
162 Obsoletes:      allegro-svgalib
163
164 %description svgalib
165 Allegro is a cross-platform library intended for use in computer games
166 and other types of multimedia programming.
167
168 This package contains module for use with allegro and svgalib.
169
170 %description svgalib -l pl.UTF-8
171 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
172 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
173
174 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
175
176 %package dga2
177 Summary:        A game programming library - DGA2 module
178 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
179 Group:          Libraries
180 Requires:       %{name} = %{version}-%{release}
181 Obsoletes:      allegro-dga2
182
183 %description dga2
184 Allegro is a cross-platform library intended for use in computer games
185 and other types of multimedia programming.
186
187 This package contains module for use with DGA.
188
189 %description dga2 -l pl.UTF-8
190 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
191 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
192
193 Ten pakiet zawiera moduł do wykorzystania z DGA.
194
195 %package esd
196 Summary:        A game programming library - esound module
197 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
198 Group:          Libraries
199 Requires:       %{name} = %{version}-%{release}
200 Obsoletes:      allegro-esd
201
202 %description esd
203 Allegro is a cross-platform library intended for use in computer games
204 and other types of multimedia programming.
205
206 This package contains a esound module for use with ESound daemon.
207
208 %description esd -l pl.UTF-8
209 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
210 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
211
212 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
213
214 %package arts
215 Summary:        A game programming library - aRts module
216 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
217 Group:          Libraries
218 Requires:       %{name} = %{version}-%{release}
219 Obsoletes:      allegro-arts
220
221 %description arts
222 Allegro is a cross-platform library intended for use in computer games
223 and other types of multimedia programming.
224
225 This package contains a esound module for use with aRts.
226
227 %description arts -l pl.UTF-8
228 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
229 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
230
231 Ten pakiet zawiera moduł do wykorzystania z aRts.
232
233 %package fbcon
234 Summary:        A game programming library - framebuffer module
235 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
236 Group:          Libraries
237 Requires:       %{name} = %{version}-%{release}
238 Obsoletes:      allegro-fbcon
239
240 %description fbcon
241 Allegro is a cross-platform library intended for use in computer games
242 and other types of multimedia programming.
243
244 This package contains a esound module for use with framebuffer.
245
246 %description fbcon -l pl.UTF-8
247 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
248 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
249
250 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
251
252 %package vga
253 Summary:        A game programming library - vga module
254 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
255 Group:          Libraries
256 Requires:       %{name} = %{version}-%{release}
257 Obsoletes:      allegro-vga
258
259 %description vga
260 Allegro is a cross-platform library intended for use in computer games
261 and other types of multimedia programming.
262
263 This package contains a esound module for use with vga.
264
265 %description vga -l pl.UTF-8
266 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
267 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
268
269 Ten pakiet zawiera moduł do wykorzystania z vga.
270
271 %package alsa
272 Summary:        A game programming library - ALSA modules
273 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
274 Group:          Libraries
275 Requires:       %{name} = %{version}-%{release}
276 Obsoletes:      allegro-alsa
277 Obsoletes:      allegro-alsa9
278
279 %description alsa
280 Allegro is a cross-platform library intended for use in computer games
281 and other types of multimedia programming.
282
283 This package contains modules for use with ALSA sound library.
284
285 %description alsa -l pl.UTF-8
286 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
287 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
288
289 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
290 ALSA.
291
292 %package jack
293 Summary:        A game programming library - JACK module
294 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
295 Group:          Libraries
296 Requires:       %{name} = %{version}-%{release}
297 Obsoletes:      allegro-jack
298
299 %description jack
300 Allegro is a cross-platform library intended for use in computer games
301 and other types of multimedia programming.
302
303 This package contains module for use with JACK sound library.
304
305 %description jack -l pl.UTF-8
306 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
307 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
308
309 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
310
311 %package tools
312 Summary:        A game programming library - tools
313 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
314 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
315 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
316 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
317 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
318 Group:          Libraries
319 Requires:       %{name} = %{version}-%{release}
320 Obsoletes:      allegro-tools
321
322 %description tools
323 Allegro is a cross-platform library intended for use in computer games
324 and other types of multimedia programming.
325
326 This package contains tools.
327
328 %description tools -l de.UTF-8
329 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
330 Computerspielen und anderen Formen von Multinediaprogrammierung.
331 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
332 Programmen hilfreich sind.
333
334 %description tools -l es.UTF-8
335 Allegro es una librería multi-plataforma creada para ser usada en la
336 programación de juegos u otro tipo de programación multimedia. Este
337 paquete contiene herramientas adicionales que son útiles para
338 desarrollar programas que usen Allegro.
339
340 %description tools -l fr.UTF-8
341 Allegro est une librairie multi-plateforme destinée à être utilisée
342 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
343 package contient des outils supplémentaires qui sont utiles pour le
344 développement de programmes avec Allegro.
345
346 %description tools -l it.UTF-8
347 Allegro è una libreria multipiattaforma dedicata all'uso nei
348 videogiochi ed in altri tipi di programmazione multimediale. Questo
349 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
350 di programmi con Allegro.
351
352 %description tools -l pl.UTF-8
353 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
354 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
355
356 Ten pakiet zawiera narzędzia.
357
358 %package tests
359 Summary:        A game programming library - test programs
360 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
361 Group:          Development/Libraries
362 Requires:       %{name} = %{version}-%{release}
363 Obsoletes:      allegro-tests
364
365 %description tests
366 This package contains programs for testing allegro library.
367
368 %description tests -l pl.UTF-8
369 Pakiet zawiera programy testujące bibliotekę allegro.
370
371 %package examples
372 Summary:        A game programming library - examples
373 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
374 Group:          Development/Libraries
375 Requires:       %{name} = %{version}-%{release}
376 Obsoletes:      allegro-examples
377
378 %description examples
379 This package contains example programs which demonstrate allegro
380 features.
381
382 %description examples -l pl.UTF-8
383 Pakiet zawiera programy przykładowe demonstrujące możliwości
384 biblioteki allegro.
385
386 %prep
387 %setup -q -n allegro-%{version}
388 #%%patch0 -p1
389 #%%patch1 -p1
390 #%%patch2 -p1
391 #%%patch3 -p1
392 #%%patch4 -p1
393
394 #find include/allegro5 -name '*.h' -print0 | xargs -0 %{__sed} -i -e 's@allegro5/@%{_headers_dir}/include/allegro5@'
395 #%%{__sed} -i -e 's@allegro5/@../@' include/allegro5/internal/alconfig.h
396
397 %build
398 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
399 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
400 #%%configure \
401 #%      %{?with_dbglib:--enable-dbglib} \
402 #%      %{?with_proflib:--enable-proflib} \
403 #%%endif
404 #%      %{!?with_arts:--disable-artsdigi} \
405 #%      %{!?with_dga2:--disable-xwin-dga2} \
406 #%      %{!?with_esd:--disable-esddigi} \
407 #%      %{!?with_fbcon:--disable-fbcon} \
408 #%      %{!?with_jack:--disable-jackdigi} \
409 #%      %{!?with_svga:--disable-svgalib} \
410 #%      %{!?with_vga:--disable-vga} \
411 #%%if !%{with sse}
412 #       --disable-sse \
413 #       --disable-asm \
414 #%%endif
415 #%%ifnarch %{ix86}
416 #       --disable-asm \
417 #       --disable-mmx \
418 #       --disable-sse
419 #%%endif
420 install -d build
421 cd build
422 %cmake .. \
423         -DMANDIR=%{_mandir} \
424         -DINFODIR=%{_infodir}
425
426 %{__make}
427
428 %install
429 rm -rf $RPM_BUILD_ROOT
430 install -d $RPM_BUILD_ROOT%{_bindir}
431
432 %{__make} install -C build \
433         DESTDIR=$RPM_BUILD_ROOT
434
435 #install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
436
437 # install examples and tests
438 find build/examples -maxdepth 1 -perm 755 -name "ex*" -exec install {} $RPM_BUILD_ROOT%{_bindir} \;
439 #find build/tests -maxdepth 1 -perm 755 ! -name CMakeFiles -exec install {} $RPM_BUILD_ROOT
440
441 #mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
442 #mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
443 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
444 #mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
445
446 # help rpm to find reqs for ELF objects
447 #chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
448
449 %clean
450 rm -rf $RPM_BUILD_ROOT
451
452 %post   -p /sbin/ldconfig
453 %postun -p /sbin/ldconfig
454
455 #%%post devel   -p      /sbin/postshell
456 #-/usr/sbin/fix-info-dir -c %{_infodir}
457
458 #%%postun devel -p      /sbin/postshell
459 #-/usr/sbin/fix-info-dir -c %{_infodir}
460
461 %files
462 %defattr(644,root,root,755)
463 %doc CHANGES-5.0.txt README.txt docs/html/refman
464 %attr(755,root,root) %{_libdir}/liballegro.so.*.*.*
465 %attr(755,root,root) %ghost %{_libdir}/liballegro.so.5.0
466
467 %files devel
468 %defattr(644,root,root,755)
469 #%%attr(755,root,root) %{_bindir}/allegro5-config
470 #%%{_libdir}/liballeg_unsharable.a
471 %{_libdir}/liballegro.so
472 %{_includedir}/*
473 #%%{_aclocaldir}/allegro.m4
474 #%%{_mandir}/man3/*
475 #%%{_infodir}/*.info*
476
477 #%%if %{with dbglib}
478 #%%files debug
479 #%%defattr(644,root,root,755)
480 #%%attr(755,root,root) %{_libdir}/liballd-%{version}.so
481 #%%{_libdir}/liballd_unsharable.a
482
483 #%%if %{with proflib}
484 #%%files profile
485 #%%defattr(644,root,root,755)
486 #%%attr(755,root,root) %{_libdir}/liballp-%{version}.so
487 #%%{_libdir}/liballp_unsharable.a
488
489 #%%if %{with svga}
490 #%%files svgalib
491 #%%defattr(644,root,root,755)
492 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
493 #%%endif
494
495 #%%if %{with dga2}
496 #%%files dga2
497 #%%defattr(644,root,root,755)
498 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
499 #%%endif
500
501 #%%if %{with esd}
502 #%%files esd
503 #%%defattr(644,root,root,755)
504 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
505 #%%endif
506
507 #%%if %{with arts}
508 #%%files arts
509 #%%defattr(644,root,root,755)
510 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
511 #%%endif
512
513 #%%if %{with fbcon}
514 #%%files fbcon
515 #%%defattr(644,root,root,755)
516 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
517 #%%endif
518
519 #%%ifarch %{ix86}
520 #%%if %{with vga}
521 #%%files vga
522 #%%defattr(644,root,root,755)
523 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
524 #%%endif
525 #%%endif
526
527 #%%if %{with alsa}
528 #%%files alsa
529 #%%defattr(644,root,root,755)
530 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
531 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
532 #%%endif
533
534 #%%if %{with jack}
535 #%%files jack
536 #%%defattr(644,root,root,755)
537 #%%attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
538 #%%endif
539
540 #%%files tools
541 #%%defattr(644,root,root,755)
542 #%%attr(755,root,root) %{_bindir}/colormap
543 #%%attr(755,root,root) %{_bindir}/exedat
544 #%%attr(755,root,root) %{_bindir}/pack
545 #%%attr(755,root,root) %{_bindir}/rgbmap
546 #%%attr(755,root,root) %{_bindir}/textconv
547 #%attr(755,root,root) %{_bindir}/xkeymap
548 #%%attr(755,root,root) %{_bindir}/xf2pcx
549 #%%attr(755,root,root) %{_bindir}/dat
550 #%%attr(755,root,root) %{_bindir}/dat2c
551 #%%attr(755,root,root) %{_bindir}/dat2s
552 #%%attr(755,root,root) %{_bindir}/grabber
553 #%%attr(755,root,root) %{_bindir}/pat2dat
554 #%%attr(755,root,root) %{_bindir}/setup-allegro
555
556 #%%files tests
557 #%%defattr(644,root,root,755)
558 #%%attr(755,root,root) %{_bindir}/afinfo
559 #%%attr(755,root,root) %{_bindir}/akaitest
560 #%%attr(755,root,root) %{_bindir}/cpptest
561 #%%attr(755,root,root) %{_bindir}/demo-allegro
562 #%%attr(755,root,root) %{_bindir}/digitest
563 #%%attr(755,root,root) %{_bindir}/filetest
564 #%%attr(755,root,root) %{_bindir}/gfxinfo
565 #%%attr(755,root,root) %{_bindir}/mathtest
566 #%%attr(755,root,root) %{_bindir}/miditest
567 #%%attr(755,root,root) %{_bindir}/play-allegro
568 #%%attr(755,root,root) %{_bindir}/playfli
569 #%%attr(755,root,root) %{_bindir}/test-allegro
570 #%%attr(755,root,root) %{_bindir}/vesainfo
571
572 %files examples
573 %defattr(644,root,root,755)
574 %attr(755,root,root) %{_bindir}/ex_acodec
575 %attr(755,root,root) %{_bindir}/ex_acodec_multi
576 %attr(755,root,root) %{_bindir}/ex_audio_props
577 %attr(755,root,root) %{_bindir}/ex_audio_simple
578 %attr(755,root,root) %{_bindir}/ex_bitmap
579 %attr(755,root,root) %{_bindir}/ex_bitmap_flip
580 %attr(755,root,root) %{_bindir}/ex_bitmap_target
581 %attr(755,root,root) %{_bindir}/ex_blend
582 %attr(755,root,root) %{_bindir}/ex_blend2
583 %attr(755,root,root) %{_bindir}/ex_blend_bench
584 %attr(755,root,root) %{_bindir}/ex_blend_test
585 %attr(755,root,root) %{_bindir}/ex_blit
586 %attr(755,root,root) %{_bindir}/ex_clip
587 %attr(755,root,root) %{_bindir}/ex_color
588 %attr(755,root,root) %{_bindir}/ex_config
589 %attr(755,root,root) %{_bindir}/ex_convert
590 %attr(755,root,root) %{_bindir}/ex_dir
591 %attr(755,root,root) %{_bindir}/ex_disable_screensaver
592 %attr(755,root,root) %{_bindir}/ex_display_options
593 %attr(755,root,root) %{_bindir}/ex_draw
594 %attr(755,root,root) %{_bindir}/ex_draw_bitmap
595 %attr(755,root,root) %{_bindir}/ex_drawpixels
596 %attr(755,root,root) %{_bindir}/ex_dualies
597 %attr(755,root,root) %{_bindir}/ex_expose
598 %attr(755,root,root) %{_bindir}/ex_filter
599 %attr(755,root,root) %{_bindir}/ex_font
600 %attr(755,root,root) %{_bindir}/ex_fs_resize
601 %attr(755,root,root) %{_bindir}/ex_fs_window
602 %attr(755,root,root) %{_bindir}/ex_get_path
603 %attr(755,root,root) %{_bindir}/ex_gldepth
604 %attr(755,root,root) %{_bindir}/ex_glext
605 %attr(755,root,root) %{_bindir}/ex_haiku
606 %attr(755,root,root) %{_bindir}/ex_icon
607 %attr(755,root,root) %{_bindir}/ex_joystick_events
608 %attr(755,root,root) %{_bindir}/ex_joystick_hotplugging
609 %attr(755,root,root) %{_bindir}/ex_font_justify
610 %attr(755,root,root) %{_bindir}/ex_kcm_direct
611 %attr(755,root,root) %{_bindir}/ex_keyboard_events
612 %attr(755,root,root) %{_bindir}/ex_keyboard_focus
613 %attr(755,root,root) %{_bindir}/ex_lines
614 %attr(755,root,root) %{_bindir}/ex_lockbitmap
615 %attr(755,root,root) %{_bindir}/ex_logo
616 %attr(755,root,root) %{_bindir}/ex_membmp
617 %attr(755,root,root) %{_bindir}/ex_memfile
618 %attr(755,root,root) %{_bindir}/ex_mixer_chain
619 %attr(755,root,root) %{_bindir}/ex_mixer_pp
620 %attr(755,root,root) %{_bindir}/ex_monitorinfo
621 %attr(755,root,root) %{_bindir}/ex_mouse
622 %attr(755,root,root) %{_bindir}/ex_mouse_cursor
623 %attr(755,root,root) %{_bindir}/ex_mouse_events
624 %attr(755,root,root) %{_bindir}/ex_mouse_focus
625 %attr(755,root,root) %{_bindir}/ex_multisample
626 %attr(755,root,root) %{_bindir}/ex_multiwin
627 %attr(755,root,root) %{_bindir}/ex_native_filechooser
628 %attr(755,root,root) %{_bindir}/ex_nodisplay
629 %attr(755,root,root) %{_bindir}/ex_noframe
630 %attr(755,root,root) %{_bindir}/ex_opengl
631 %attr(755,root,root) %{_bindir}/ex_opengl_pixel_shader
632 %attr(755,root,root) %{_bindir}/ex_path
633 %attr(755,root,root) %{_bindir}/ex_path_test
634 %attr(755,root,root) %{_bindir}/ex_pixelformat
635 %attr(755,root,root) %{_bindir}/ex_premulalpha
636 %attr(755,root,root) %{_bindir}/ex_prim
637 %attr(755,root,root) %{_bindir}/ex_resize
638 %attr(755,root,root) %{_bindir}/ex_resize2
639 %attr(755,root,root) %{_bindir}/ex_rotate
640 %attr(755,root,root) %{_bindir}/ex_saw
641 %attr(755,root,root) %{_bindir}/ex_scale
642 %attr(755,root,root) %{_bindir}/ex_stream_file
643 %attr(755,root,root) %{_bindir}/ex_stream_seek
644 %attr(755,root,root) %{_bindir}/ex_subbitmap
645 %attr(755,root,root) %{_bindir}/ex_synth
646 %attr(755,root,root) %{_bindir}/ex_threads
647 %attr(755,root,root) %{_bindir}/ex_threads2
648 %attr(755,root,root) %{_bindir}/ex_timedwait
649 %attr(755,root,root) %{_bindir}/ex_timer
650 %attr(755,root,root) %{_bindir}/ex_transform
651 %attr(755,root,root) %{_bindir}/ex_ttf
652 %attr(755,root,root) %{_bindir}/ex_user_events
653 %attr(755,root,root) %{_bindir}/ex_utf8
654 %attr(755,root,root) %{_bindir}/ex_vsync
655 %attr(755,root,root) %{_bindir}/ex_warp_mouse
656 %attr(755,root,root) %{_bindir}/ex_windows
657 %attr(755,root,root) %{_bindir}/ex_winfull
This page took 0.089277 seconds and 3 git commands to generate.