]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro.spec
- updated to 4.2.0
[packages/allegro5.git] / allegro.spec
1 #
2 # TODO: Handle situations when there are no modules (most bconds turned off)
3 #
4 # Conditional build:
5 %bcond_without  alsa    # without ALSA modules
6 %bcond_without  arts    # without aRts module
7 %bcond_without  dga2    # without DGA2 module
8 %bcond_without  dbglib  # don't build debug versions of library
9 %bcond_without  esd     # without esound module
10 %bcond_without  fbcon   # without framebuffer module
11 %bcond_without  jack    # without JACK module
12 %bcond_without  proflib # don't debug profiling versions of library
13 %bcond_without  sse     # build without sse
14 %bcond_without  static  # don't build static versions of library
15 %bcond_without  svga    # without svgalib module
16 %bcond_without  vga     # without vga module
17 #
18 Summary:        A game programming library
19 Summary(de):    Eine Bibliothek zur Programmierung von Spielen
20 Summary(es):    Una biblioteca de programación de juegos
21 Summary(fr):    Une librairie de programmation de jeux
22 Summary(it):    Una libreria per la programmazione di videogiochi
23 Summary(pl):    Biblioteka do programowania gier
24 Name:           allegro
25 Version:        4.2.0
26 Release:        1
27 License:        Giftware
28 Group:          Libraries
29 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30 # Source0-md5:  a8b2c85c58b16345fe735f72763f3a6e
31 Patch0:         %{name}-info.patch
32 Patch1:         %{name}-examples.patch
33 Patch2:         %{name}-opt.patch
34 Patch3:         %{name}-ldflags.patch
35 Patch4:         %{name}-frame-pointer.patch
36 URL:            http://alleg.sourceforge.net/
37 BuildRequires:  X11-devel
38 %{?with_alsa:BuildRequires:     alsa-lib-devel}
39 %{?with_arts:BuildRequires:     artsc-devel}
40 BuildRequires:  autoconf >= 2.53
41 BuildRequires:  automake
42 %{?with_esd:BuildRequires:      esound-devel}
43 %if %{with jack}
44 BuildRequires:  jack-audio-connection-kit-devel
45 BuildRequires:  pkgconfig
46 %endif
47 %{?with_svga:BuildRequires:     svgalib-devel}
48 BuildRequires:  texinfo
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Allegro is a cross-platform library intended for use in computer games
53 and other types of multimedia programming.
54
55 %description -l de
56 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
57 Computerspielen und anderen Formen von Multinediaprogrammierung.
58
59 %description -l es
60 Allegro es una librería multi-plataforma creada para ser usada en la
61 programación de juegos u otro tipo de programación multimedia.
62
63 %description -l fr
64 Allegro est une librairie multi-plateforme destinée à être utilisée
65 dans les jeux vidéo ou d'autres types de programmation multimédia.
66
67 %description -l it
68 Allegro è una libreria multipiattaforma dedicata all'uso nei
69 videogiochi ed in altri tipi di programmazione multimediale.
70
71 %description -l pl
72 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
73 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
74
75 %package devel
76 Summary:        A game programming library - header files
77 Summary(es):    Archivos de inclusión
78 Summary(pl):    Biblioteka do programowania gier - pliki nag³ówkowe
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description devel
83 Allegro is a cross-platform library intended for use in computer games
84 and other types of multimedia programming.
85
86 This package contains header files neccessary for compiling
87 applications using allegro library.
88
89 %description devel -l de
90 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
91 Computerspielen und anderen Formen von Multinediaprogrammierung.
92 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
93 verwenden.
94
95 %description devel -l es
96 Allegro es una librería multi-plataforma creada para ser usada en la
97 programación de juegos u otro tipo de programación multimedia. Este
98 paquete es necesario para compilar los programas que usen Allegro.
99
100 %description devel -l fr
101 Allegro est une librairie multi-plateforme destinée à être utilisée
102 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
103 package est nécessaire pour compiler les programmes utilisant Allegro.
104
105 %description devel -l it
106 Allegro è una libreria multipiattaforma dedicata all'uso nei
107 videogiochi ed in altri tipi di programmazione multimediale. Questo
108 pacchetto è necessario per compilare programmi scritti con Allegro.
109
110 %description devel -l pl
111 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
112 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
113
114 Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
115 aplikacji wykorzystuj±cych bibliotekê allegro.
116
117 %package static
118 Summary:        A game programming library - static libraries
119 Summary(pl):    Biblioteka do programowania gier - biblioteki statyczne
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Allegro is a cross-platform library intended for use in computer games
125 and other types of multimedia programming.
126
127 This package contains static libraries for linking with allegro
128 applications.
129
130 %description static -l pl
131 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
132 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
133
134 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
135 wykorzystuj±cymi allegro.
136
137 %package debug
138 Summary:        liballd - debug version of shared allegro library
139 Summary(pl):    liballd - wersja debug dzielonej biblioteki allegro
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description debug
144 liballd - debug version of shared allegro library (contains debugging
145 symbols and other information).
146
147 %description debug -l pl
148 liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
149 symbole i inne informacje potrzebne przy odpluskwianiu).
150
151 %package debug-static
152 Summary:        liballd - debug version of static allegro library
153 Summary(pl):    liballd - wersja debug statycznej biblioteki allegro
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156
157 %description debug-static
158 liballd - debug version of static allegro library (contains debugging
159 symbols and other information).
160
161 %description debug-static -l pl
162 liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
163 symbole i inne informacje potrzebne przy odpluskwianiu).
164
165 %package profile
166 Summary:        liballp - profiling version of shared allegro library
167 Summary(pl):    liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170
171 %description profile
172 liballp - profiling version of shared allegro library.
173
174 %description profile -l pl
175 liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
176
177 %package profile-static
178 Summary:        liballp - profiling version of static allegro library
179 Summary(pl):    liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description profile-static
184 liballp - profiling version of static allegro library.
185
186 %description profile-static -l pl
187 liballp - wersja statycznej biblioteki allegro s³u¿±ca do
188 profilowania.
189
190 %package svgalib
191 Summary:        A game programming library - svgalib module
192 Summary(pl):    Biblioteka do programowania gier - modu³ dla svgalib
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195
196 %description svgalib
197 Allegro is a cross-platform library intended for use in computer games
198 and other types of multimedia programming.
199
200 This package contains module for use with allegro and svgalib.
201
202 %description svgalib -l pl
203 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
204 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
205
206 Ten pakiet zawiera modu³ do wykorzystania allegro z svgalibem.
207
208 %package dga2
209 Summary:        A game programming library - DGA2 module
210 Summary(pl):    Biblioteka do programowania gier - modu³ dla DGA2
211 Group:          Libraries
212 Requires:       %{name} = %{version}-%{release}
213
214 %description dga2
215 Allegro is a cross-platform library intended for use in computer games
216 and other types of multimedia programming.
217
218 This package contains module for use with DGA.
219
220 %description dga2 -l pl
221 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
222 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
223
224 Ten pakiet zawiera modu³ do wykorzystania z DGA.
225
226 %package esd
227 Summary:        A game programming library - esound module
228 Summary(pl):    Biblioteka do programowania gier - modu³ dla esound
229 Group:          Libraries
230 Requires:       %{name} = %{version}-%{release}
231
232 %description esd
233 Allegro is a cross-platform library intended for use in computer games
234 and other types of multimedia programming.
235
236 This package contains a esound module for use with ESound daemon.
237
238 %description esd -l pl
239 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
240 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
241
242 Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
243
244 %package arts
245 Summary:        A game programming library - aRts module
246 Summary(pl):    Biblioteka do programowania gier - modu³ dla aRts
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249
250 %description arts
251 Allegro is a cross-platform library intended for use in computer games
252 and other types of multimedia programming.
253
254 This package contains a esound module for use with aRts.
255
256 %description arts -l pl
257 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
258 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
259
260 Ten pakiet zawiera modu³ do wykorzystania z aRts.
261
262 %package fbcon
263 Summary:        A game programming library - framebuffer module
264 Summary(pl):    Biblioteka do programowania gier - modu³ dla framebuffera
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267
268 %description fbcon
269 Allegro is a cross-platform library intended for use in computer games
270 and other types of multimedia programming.
271
272 This package contains a esound module for use with framebuffer.
273
274 %description fbcon -l pl
275 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
276 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
277
278 Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
279
280 %package vga
281 Summary:        A game programming library - vga module
282 Summary(pl):    Biblioteka do programowania gier - modu³ dla vga
283 Group:          Libraries
284 Requires:       %{name} = %{version}-%{release}
285
286 %description vga
287 Allegro is a cross-platform library intended for use in computer games
288 and other types of multimedia programming.
289
290 This package contains a esound module for use with vga.
291
292 %description vga -l pl
293 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
294 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
295
296 Ten pakiet zawiera modu³ do wykorzystania z vga.
297
298 %package alsa
299 Summary:        A game programming library - ALSA modules
300 Summary(pl):    Biblioteka do programowania gier - modu³y dla ALSA
301 Group:          Libraries
302 Requires:       %{name} = %{version}-%{release}
303 Obsoletes:      allegro-alsa9
304
305 %description alsa
306 Allegro is a cross-platform library intended for use in computer games
307 and other types of multimedia programming.
308
309 This package contains modules for use with ALSA sound library.
310
311 %description alsa -l pl
312 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
313 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
314
315 Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
316 ALSA.
317
318 %package jack
319 Summary:        A game programming library - JACK module
320 Summary(pl):    Biblioteka do programowania gier - modu³ dla JACK-a
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description jack
325 Allegro is a cross-platform library intended for use in computer games
326 and other types of multimedia programming.
327
328 This package contains module for use with JACK sound library.
329
330 %description jack -l pl
331 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
332 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
333
334 Ten pakiet zawiera modu³ do wykorzystania z bibliotek± d¼wiêkow± JACK.
335
336 %package tools
337 Summary:        A game programming library - tools
338 Summary(de):    Zusätzliche Hilfprogramme für die Allegro Bibliothek
339 Summary(es):    Herramientas adicionales para la librería de programación Allegro
340 Summary(fr):    Outils supplémentaires pour la librairie de programmation Allegro
341 Summary(it):    Programmi di utilità aggiuntivi per la libreria Allegro
342 Summary(pl):    Biblioteka do programowania gier - narzêdzia
343 Group:          Libraries
344 Requires:       %{name} = %{version}-%{release}
345
346 %description tools
347 Allegro is a cross-platform library intended for use in computer games
348 and other types of multimedia programming.
349
350 This package contains tools.
351
352 %description tools -l de
353 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
354 Computerspielen und anderen Formen von Multinediaprogrammierung.
355 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
356 Programmen hilfreich sind.
357
358 %description tools -l es
359 Allegro es una librería multi-plataforma creada para ser usada en la
360 programación de juegos u otro tipo de programación multimedia. Este
361 paquete contiene herramientas adicionales que son útiles para
362 desarrollar programas que usen Allegro.
363
364 %description tools -l fr
365 Allegro est une librairie multi-plateforme destinée à être utilisée
366 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
367 package contient des outils supplémentaires qui sont utiles pour le
368 développement de programmes avec Allegro.
369
370 %description tools -l it
371 Allegro è una libreria multipiattaforma dedicata all'uso nei
372 videogiochi ed in altri tipi di programmazione multimediale. Questo
373 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
374 di programmi con Allegro.
375
376 %description tools -l pl
377 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
378 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
379
380 Ten pakiet zawiera narzêdzia.
381
382 %package tests
383 Summary:        A game programming library - test programs
384 Summary(pl):    Biblioteka do programowania gier - programy testuj±ce
385 Group:          Development/Libraries
386 Requires:       %{name} = %{version}-%{release}
387
388 %description tests
389 This package contains programs for testing allegro library.
390
391 %description tests -l pl
392 Pakiet zawiera programy testuj±ce bibliotekê allegro.
393
394 %package examples
395 Summary:        A game programming library - examples
396 Summary(pl):    Biblioteka do programowania gier - programy przyk³adowe
397 Group:          Development/Libraries
398 Requires:       %{name} = %{version}-%{release}
399
400 %description examples
401 This package contains example programs which demonstrate allegro
402 features.
403
404 %description examples -l pl
405 Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
406 biblioteki allegro.
407
408 %prep
409 %setup -q
410 %patch0 -p1
411 %patch1 -p1
412 %patch2 -p1
413 %patch3 -p1
414 %patch4 -p1
415
416 %build
417 %{__aclocal}
418 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
419 %{__autoconf}
420 TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
421 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
422 %configure \
423         %{?with_static:--enable-static} \
424         %{?with_dbglib:--enable-dbglib} \
425         %{?with_proflib:--enable-proflib} \
426 %if %{without alsa}
427         --disable-alsadigi \
428         --disable-alsamidi \
429 %endif
430         %{!?with_arts:--disable-artsdigi} \
431         %{!?with_dga2:--disable-xwin-dga2} \
432         %{!?with_esd:--disable-esddigi} \
433         %{!?with_fbcon:--disable-fbcon} \
434         %{!?with_jack:--disable-jackdigi} \
435         %{!?with_svga:--disable-svgalib} \
436         %{!?with_vga:--disable-vga} \
437 %if %{without sse}
438         --disable-sse \
439         --disable-asm \
440 %endif
441 %ifnarch %{ix86}
442         --disable-asm \
443         --disable-mmx \
444         --disable-sse
445 %endif
446
447 %{__make} \
448         MAKEINFO=makeinfo
449
450 %install
451 rm -rf $RPM_BUILD_ROOT
452
453 %{__make} install install-man install-info install-lib \
454         DESTDIR=$RPM_BUILD_ROOT
455
456 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.2
457
458 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
459 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
460 mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
461 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
462
463 # help rpm to find reqs for ELF objects
464 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
465
466 %clean
467 rm -rf $RPM_BUILD_ROOT
468
469 %post   -p /sbin/ldconfig
470 %postun -p /sbin/ldconfig
471
472 %post devel
473 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
474
475 %postun devel
476 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
477
478 %files
479 %defattr(644,root,root,755)
480 %doc AUTHORS CHANGES THANKS readme.txt
481 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
482 %dir %{_libdir}/allegro
483 %dir %{_libdir}/allegro/4.2
484 %{_libdir}/allegro/4.2/modules.lst
485
486 %files devel
487 %defattr(644,root,root,755)
488 %attr(755,root,root) %{_bindir}/allegro-config
489 %{_libdir}/liballeg_unsharable.a
490 %{_includedir}/*
491 %{_aclocaldir}/allegro.m4
492 %{_mandir}/man3/*
493 %{_infodir}/*.info*
494
495 %if %{with static}
496 %files static
497 %defattr(644,root,root,755)
498 %{_libdir}/liballeg.a
499 %endif
500
501 %if %{with dbglib}
502 %files debug
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
505 %{_libdir}/liballd_unsharable.a
506
507 %if %{with static}
508 %files debug-static
509 %defattr(644,root,root,755)
510 %{_libdir}/liballd.a
511 %endif
512 %endif
513
514 %if %{with proflib}
515 %files profile
516 %defattr(644,root,root,755)
517 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
518 %{_libdir}/liballp_unsharable.a
519
520 %if %{with static}
521 %files profile-static
522 %defattr(644,root,root,755)
523 %{_libdir}/liballp.a
524 %endif
525 %endif
526
527 %if %{with svga}
528 %files svgalib
529 %defattr(644,root,root,755)
530 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-svgalib.so
531 %endif
532
533 %if %{with dga2}
534 %files dga2
535 %defattr(644,root,root,755)
536 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-dga2.so
537 %endif
538
539 %if %{with esd}
540 %files esd
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-esddigi.so
543 %endif
544
545 %if %{with arts}
546 %files arts
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-artsdigi.so
549 %endif
550
551 %if %{with fbcon}
552 %files fbcon
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-fbcon.so
555 %endif
556
557 %ifarch %{ix86}
558 %if %{with vga}
559 %files vga
560 %defattr(644,root,root,755)
561 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-vga.so
562 %endif
563 %endif
564
565 %if %{with alsa}
566 %files alsa
567 %defattr(644,root,root,755)
568 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-alsadigi.so
569 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-alsamidi.so
570 %endif
571
572 %if %{with jack}
573 %files jack
574 %defattr(644,root,root,755)
575 %attr(755,root,root) %{_libdir}/allegro/4.2/alleg-jackdigi.so
576 %endif
577
578 %files tools
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_bindir}/colormap
581 %attr(755,root,root) %{_bindir}/exedat
582 %attr(755,root,root) %{_bindir}/pack
583 %attr(755,root,root) %{_bindir}/rgbmap
584 %attr(755,root,root) %{_bindir}/textconv
585 %attr(755,root,root) %{_bindir}/xkeymap
586 %attr(755,root,root) %{_bindir}/xf2pcx
587 %attr(755,root,root) %{_bindir}/dat
588 %attr(755,root,root) %{_bindir}/dat2c
589 %attr(755,root,root) %{_bindir}/dat2s
590 %attr(755,root,root) %{_bindir}/grabber
591 %attr(755,root,root) %{_bindir}/pat2dat
592 %attr(755,root,root) %{_bindir}/setup-allegro
593
594 %files tests
595 %defattr(644,root,root,755)
596 %attr(755,root,root) %{_bindir}/afinfo
597 %attr(755,root,root) %{_bindir}/akaitest
598 %attr(755,root,root) %{_bindir}/cpptest
599 %attr(755,root,root) %{_bindir}/demo-allegro
600 %attr(755,root,root) %{_bindir}/digitest
601 %attr(755,root,root) %{_bindir}/filetest
602 %attr(755,root,root) %{_bindir}/gfxinfo
603 %attr(755,root,root) %{_bindir}/mathtest
604 %attr(755,root,root) %{_bindir}/miditest
605 %attr(755,root,root) %{_bindir}/play-allegro
606 %attr(755,root,root) %{_bindir}/playfli
607 %attr(755,root,root) %{_bindir}/test-allegro
608 %attr(755,root,root) %{_bindir}/vesainfo
609
610 %files examples
611 %defattr(644,root,root,755)
612 %attr(755,root,root) %{_bindir}/ex12bit
613 %attr(755,root,root) %{_bindir}/ex3buf
614 %attr(755,root,root) %{_bindir}/ex3d
615 %attr(755,root,root) %{_bindir}/exaccel
616 %attr(755,root,root) %{_bindir}/exalpha
617 %attr(755,root,root) %{_bindir}/exbitmap
618 %attr(755,root,root) %{_bindir}/exblend
619 %attr(755,root,root) %{_bindir}/excamera
620 %attr(755,root,root) %{_bindir}/excolmap
621 %attr(755,root,root) %{_bindir}/exconfig
622 %attr(755,root,root) %{_bindir}/excustom
623 %attr(755,root,root) %{_bindir}/exdata
624 %attr(755,root,root) %{_bindir}/exdbuf
625 %attr(755,root,root) %{_bindir}/exexedat
626 %attr(755,root,root) %{_bindir}/exfixed
627 %attr(755,root,root) %{_bindir}/exflame
628 %attr(755,root,root) %{_bindir}/exflip
629 %attr(755,root,root) %{_bindir}/exfont
630 %attr(755,root,root) %{_bindir}/exgui
631 %attr(755,root,root) %{_bindir}/exhello
632 %attr(755,root,root) %{_bindir}/exjoy
633 %attr(755,root,root) %{_bindir}/exkeys
634 %attr(755,root,root) %{_bindir}/exlights
635 %attr(755,root,root) %{_bindir}/exmem
636 %attr(755,root,root) %{_bindir}/exmidi
637 %attr(755,root,root) %{_bindir}/exmouse
638 %attr(755,root,root) %{_bindir}/expackf
639 %attr(755,root,root) %{_bindir}/expal
640 %attr(755,root,root) %{_bindir}/expat
641 %attr(755,root,root) %{_bindir}/exquat
642 %attr(755,root,root) %{_bindir}/exrgbhsv
643 %attr(755,root,root) %{_bindir}/exsample
644 %attr(755,root,root) %{_bindir}/exsyscur
645 %attr(755,root,root) %{_bindir}/exscale
646 %attr(755,root,root) %{_bindir}/exscn3d
647 %attr(755,root,root) %{_bindir}/exscroll
648 %attr(755,root,root) %{_bindir}/exshade
649 %attr(755,root,root) %{_bindir}/exspline
650 %attr(755,root,root) %{_bindir}/exsprite
651 %attr(755,root,root) %{_bindir}/exstars
652 %attr(755,root,root) %{_bindir}/exstream
653 %attr(755,root,root) %{_bindir}/exswitch
654 %attr(755,root,root) %{_bindir}/extimer
655 %attr(755,root,root) %{_bindir}/extrans
656 %attr(755,root,root) %{_bindir}/extruec
657 %attr(755,root,root) %{_bindir}/exunicod
658 %attr(755,root,root) %{_bindir}/exupdate
659 %attr(755,root,root) %{_bindir}/exxfade
660 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.083443 seconds and 4 git commands to generate.