]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro.spec
b0eef5ee1cb44bb7284c02ae553207be96b29ac0
[packages/allegro5.git] / allegro.spec
1 #
2 # TODO: Handle situations when there are no modules (most bconds turned off)
3 #
4 # Conditional build:
5 %bcond_without  alsa    # without ALSA modules
6 %bcond_without  arts    # without aRts module
7 %bcond_without  dga2    # without DGA2 module
8 %bcond_without  dbglib  # don't build debug versions of library
9 %bcond_without  esd     # without esound module
10 %bcond_without  fbcon   # without framebuffer module
11 %bcond_without  jack    # without JACK module
12 %bcond_without  proflib # don't debug profiling versions of library
13 %bcond_without  sse     # build without sse
14 %bcond_without  static  # don't build static versions of library
15 %bcond_without  svga    # without svgalib module
16 %bcond_without  vga     # without vga module
17 #
18 Summary:        A game programming library
19 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
20 Summary(es.UTF-8):      Una biblioteca de programación de juegos
21 Summary(fr.UTF-8):      Une librairie de programmation de jeux
22 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
23 Summary(pl.UTF-8):      Biblioteka do programowania gier
24 Name:           allegro
25 Version:        4.2.1
26 Release:        1
27 License:        Giftware
28 Group:          Libraries
29 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30 # Source0-md5:  0a09d0144ee8652fb8fa00f6cbb324fe
31 Patch0:         %{name}-info.patch
32 Patch1:         %{name}-examples.patch
33 Patch2:         %{name}-opt.patch
34 Patch3:         %{name}-ldflags.patch
35 Patch4:         %{name}-frame-pointer.patch
36 Patch5:         %{name}-config.patch
37 URL:            http://alleg.sourceforge.net/
38 BuildRequires:  XFree86-devel
39 %{?with_alsa:BuildRequires:     alsa-lib-devel}
40 %{?with_arts:BuildRequires:     artsc-devel}
41 BuildRequires:  autoconf >= 2.53
42 BuildRequires:  automake
43 %{?with_esd:BuildRequires:      esound-devel}
44 %if %{with jack}
45 BuildRequires:  jack-audio-connection-kit-devel
46 BuildRequires:  pkgconfig
47 %endif
48 %{?with_svga:BuildRequires:     svgalib-devel}
49 BuildRequires:  texinfo
50 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
51
52 %description
53 Allegro is a cross-platform library intended for use in computer games
54 and other types of multimedia programming.
55
56 %description -l de.UTF-8
57 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
58 Computerspielen und anderen Formen von Multinediaprogrammierung.
59
60 %description -l es.UTF-8
61 Allegro es una librería multi-plataforma creada para ser usada en la
62 programación de juegos u otro tipo de programación multimedia.
63
64 %description -l fr.UTF-8
65 Allegro est une librairie multi-plateforme destinée à être utilisée
66 dans les jeux vidéo ou d'autres types de programmation multimédia.
67
68 %description -l it.UTF-8
69 Allegro è una libreria multipiattaforma dedicata all'uso nei
70 videogiochi ed in altri tipi di programmazione multimediale.
71
72 %description -l pl.UTF-8
73 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
74 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
75
76 %package devel
77 Summary:        A game programming library - header files
78 Summary(es.UTF-8):      Archivos de inclusión
79 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
80 Group:          Development/Libraries
81 Requires:       %{name} = %{version}-%{release}
82
83 %description devel
84 Allegro is a cross-platform library intended for use in computer games
85 and other types of multimedia programming.
86
87 This package contains header files neccessary for compiling
88 applications using allegro library.
89
90 %description devel -l de.UTF-8
91 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
92 Computerspielen und anderen Formen von Multinediaprogrammierung.
93 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
94 verwenden.
95
96 %description devel -l es.UTF-8
97 Allegro es una librería multi-plataforma creada para ser usada en la
98 programación de juegos u otro tipo de programación multimedia. Este
99 paquete es necesario para compilar los programas que usen Allegro.
100
101 %description devel -l fr.UTF-8
102 Allegro est une librairie multi-plateforme destinée à être utilisée
103 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
104 package est nécessaire pour compiler les programmes utilisant Allegro.
105
106 %description devel -l it.UTF-8
107 Allegro è una libreria multipiattaforma dedicata all'uso nei
108 videogiochi ed in altri tipi di programmazione multimediale. Questo
109 pacchetto è necessario per compilare programmi scritti con Allegro.
110
111 %description devel -l pl.UTF-8
112 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
113 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
114
115 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
116 aplikacji wykorzystujących bibliotekę allegro.
117
118 %package static
119 Summary:        A game programming library - static libraries
120 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
121 Group:          Development/Libraries
122 Requires:       %{name}-devel = %{version}-%{release}
123
124 %description static
125 Allegro is a cross-platform library intended for use in computer games
126 and other types of multimedia programming.
127
128 This package contains static libraries for linking with allegro
129 applications.
130
131 %description static -l pl.UTF-8
132 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
133 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
134
135 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
136 wykorzystującymi allegro.
137
138 %package debug
139 Summary:        liballd - debug version of shared allegro library
140 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
141 Group:          Development/Libraries
142 Requires:       %{name}-devel = %{version}-%{release}
143
144 %description debug
145 liballd - debug version of shared allegro library (contains debugging
146 symbols and other information).
147
148 %description debug -l pl.UTF-8
149 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
150 symbole i inne informacje potrzebne przy odpluskwianiu).
151
152 %package debug-static
153 Summary:        liballd - debug version of static allegro library
154 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
155 Group:          Development/Libraries
156 Requires:       %{name}-devel = %{version}-%{release}
157
158 %description debug-static
159 liballd - debug version of static allegro library (contains debugging
160 symbols and other information).
161
162 %description debug-static -l pl.UTF-8
163 liballd - wersja debug statycznej biblioteki allegro (zawierająca
164 symbole i inne informacje potrzebne przy odpluskwianiu).
165
166 %package profile
167 Summary:        liballp - profiling version of shared allegro library
168 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
169 Group:          Development/Libraries
170 Requires:       %{name}-devel = %{version}-%{release}
171
172 %description profile
173 liballp - profiling version of shared allegro library.
174
175 %description profile -l pl.UTF-8
176 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
177
178 %package profile-static
179 Summary:        liballp - profiling version of static allegro library
180 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
181 Group:          Development/Libraries
182 Requires:       %{name}-devel = %{version}-%{release}
183
184 %description profile-static
185 liballp - profiling version of static allegro library.
186
187 %description profile-static -l pl.UTF-8
188 liballp - wersja statycznej biblioteki allegro służąca do
189 profilowania.
190
191 %package svgalib
192 Summary:        A game programming library - svgalib module
193 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
194 Group:          Libraries
195 Requires:       %{name} = %{version}-%{release}
196
197 %description svgalib
198 Allegro is a cross-platform library intended for use in computer games
199 and other types of multimedia programming.
200
201 This package contains module for use with allegro and svgalib.
202
203 %description svgalib -l pl.UTF-8
204 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
205 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
206
207 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
208
209 %package dga2
210 Summary:        A game programming library - DGA2 module
211 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
212 Group:          Libraries
213 Requires:       %{name} = %{version}-%{release}
214
215 %description dga2
216 Allegro is a cross-platform library intended for use in computer games
217 and other types of multimedia programming.
218
219 This package contains module for use with DGA.
220
221 %description dga2 -l pl.UTF-8
222 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
223 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
224
225 Ten pakiet zawiera moduł do wykorzystania z DGA.
226
227 %package esd
228 Summary:        A game programming library - esound module
229 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
230 Group:          Libraries
231 Requires:       %{name} = %{version}-%{release}
232
233 %description esd
234 Allegro is a cross-platform library intended for use in computer games
235 and other types of multimedia programming.
236
237 This package contains a esound module for use with ESound daemon.
238
239 %description esd -l pl.UTF-8
240 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
241 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
242
243 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
244
245 %package arts
246 Summary:        A game programming library - aRts module
247 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
248 Group:          Libraries
249 Requires:       %{name} = %{version}-%{release}
250
251 %description arts
252 Allegro is a cross-platform library intended for use in computer games
253 and other types of multimedia programming.
254
255 This package contains a esound module for use with aRts.
256
257 %description arts -l pl.UTF-8
258 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
259 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
260
261 Ten pakiet zawiera moduł do wykorzystania z aRts.
262
263 %package fbcon
264 Summary:        A game programming library - framebuffer module
265 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
266 Group:          Libraries
267 Requires:       %{name} = %{version}-%{release}
268
269 %description fbcon
270 Allegro is a cross-platform library intended for use in computer games
271 and other types of multimedia programming.
272
273 This package contains a esound module for use with framebuffer.
274
275 %description fbcon -l pl.UTF-8
276 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
277 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
278
279 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
280
281 %package vga
282 Summary:        A game programming library - vga module
283 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
284 Group:          Libraries
285 Requires:       %{name} = %{version}-%{release}
286
287 %description vga
288 Allegro is a cross-platform library intended for use in computer games
289 and other types of multimedia programming.
290
291 This package contains a esound module for use with vga.
292
293 %description vga -l pl.UTF-8
294 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
295 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
296
297 Ten pakiet zawiera moduł do wykorzystania z vga.
298
299 %package alsa
300 Summary:        A game programming library - ALSA modules
301 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
302 Group:          Libraries
303 Requires:       %{name} = %{version}-%{release}
304 Obsoletes:      allegro-alsa9
305
306 %description alsa
307 Allegro is a cross-platform library intended for use in computer games
308 and other types of multimedia programming.
309
310 This package contains modules for use with ALSA sound library.
311
312 %description alsa -l pl.UTF-8
313 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
314 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
315
316 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
317 ALSA.
318
319 %package jack
320 Summary:        A game programming library - JACK module
321 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
322 Group:          Libraries
323 Requires:       %{name} = %{version}-%{release}
324
325 %description jack
326 Allegro is a cross-platform library intended for use in computer games
327 and other types of multimedia programming.
328
329 This package contains module for use with JACK sound library.
330
331 %description jack -l pl.UTF-8
332 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
333 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
334
335 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
336
337 %package tools
338 Summary:        A game programming library - tools
339 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
340 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
341 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
342 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
343 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
344 Group:          Libraries
345 Requires:       %{name} = %{version}-%{release}
346
347 %description tools
348 Allegro is a cross-platform library intended for use in computer games
349 and other types of multimedia programming.
350
351 This package contains tools.
352
353 %description tools -l de.UTF-8
354 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
355 Computerspielen und anderen Formen von Multinediaprogrammierung.
356 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
357 Programmen hilfreich sind.
358
359 %description tools -l es.UTF-8
360 Allegro es una librería multi-plataforma creada para ser usada en la
361 programación de juegos u otro tipo de programación multimedia. Este
362 paquete contiene herramientas adicionales que son útiles para
363 desarrollar programas que usen Allegro.
364
365 %description tools -l fr.UTF-8
366 Allegro est une librairie multi-plateforme destinée à être utilisée
367 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
368 package contient des outils supplémentaires qui sont utiles pour le
369 développement de programmes avec Allegro.
370
371 %description tools -l it.UTF-8
372 Allegro è una libreria multipiattaforma dedicata all'uso nei
373 videogiochi ed in altri tipi di programmazione multimediale. Questo
374 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
375 di programmi con Allegro.
376
377 %description tools -l pl.UTF-8
378 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
379 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
380
381 Ten pakiet zawiera narzędzia.
382
383 %package tests
384 Summary:        A game programming library - test programs
385 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
386 Group:          Development/Libraries
387 Requires:       %{name} = %{version}-%{release}
388
389 %description tests
390 This package contains programs for testing allegro library.
391
392 %description tests -l pl.UTF-8
393 Pakiet zawiera programy testujące bibliotekę allegro.
394
395 %package examples
396 Summary:        A game programming library - examples
397 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
398 Group:          Development/Libraries
399 Requires:       %{name} = %{version}-%{release}
400
401 %description examples
402 This package contains example programs which demonstrate allegro
403 features.
404
405 %description examples -l pl.UTF-8
406 Pakiet zawiera programy przykładowe demonstrujące możliwości
407 biblioteki allegro.
408
409 %prep
410 %setup -q
411 %patch0 -p1
412 %patch1 -p1
413 %patch2 -p1
414 %patch3 -p1
415 %patch4 -p1
416 %patch5 -p1
417
418 %build
419 %{__aclocal}
420 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
421 %{__autoconf}
422 TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
423 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
424 %configure \
425         %{?with_static:--enable-static} \
426         %{?with_dbglib:--enable-dbglib} \
427         %{?with_proflib:--enable-proflib} \
428 %if !%{with alsa}
429         --disable-alsadigi \
430         --disable-alsamidi \
431 %endif
432         %{!?with_arts:--disable-artsdigi} \
433         %{!?with_dga2:--disable-xwin-dga2} \
434         %{!?with_esd:--disable-esddigi} \
435         %{!?with_fbcon:--disable-fbcon} \
436         %{!?with_jack:--disable-jackdigi} \
437         %{!?with_svga:--disable-svgalib} \
438         %{!?with_vga:--disable-vga} \
439 %if !%{with sse}
440         --disable-sse \
441         --disable-asm \
442 %endif
443 %ifnarch %{ix86}
444         --disable-asm \
445         --disable-mmx \
446         --disable-sse
447 %endif
448
449 %{__make} \
450         MAKEINFO=makeinfo
451
452 %install
453 rm -rf $RPM_BUILD_ROOT
454
455 %{__make} install install-man install-info install-lib \
456         DESTDIR=$RPM_BUILD_ROOT
457
458 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
459
460 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
461 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
462 mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
463 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
464
465 # help rpm to find reqs for ELF objects
466 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
467
468 %clean
469 rm -rf $RPM_BUILD_ROOT
470
471 %post   -p /sbin/ldconfig
472 %postun -p /sbin/ldconfig
473
474 %post devel
475 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
476
477 %postun devel
478 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
479
480 %files
481 %defattr(644,root,root,755)
482 %doc AUTHORS CHANGES THANKS readme.txt
483 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
484 %dir %{_libdir}/allegro
485 %dir %{_libdir}/allegro/%{version}
486 %{_libdir}/allegro/%{version}/modules.lst
487
488 %files devel
489 %defattr(644,root,root,755)
490 %attr(755,root,root) %{_bindir}/allegro-config
491 %{_libdir}/liballeg_unsharable.a
492 %{_includedir}/*
493 %{_aclocaldir}/allegro.m4
494 %{_mandir}/man3/*
495 %{_infodir}/*.info*
496
497 %if %{with static}
498 %files static
499 %defattr(644,root,root,755)
500 %{_libdir}/liballeg.a
501 %endif
502
503 %if %{with dbglib}
504 %files debug
505 %defattr(644,root,root,755)
506 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
507 %{_libdir}/liballd_unsharable.a
508
509 %if %{with static}
510 %files debug-static
511 %defattr(644,root,root,755)
512 %{_libdir}/liballd.a
513 %endif
514 %endif
515
516 %if %{with proflib}
517 %files profile
518 %defattr(644,root,root,755)
519 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
520 %{_libdir}/liballp_unsharable.a
521
522 %if %{with static}
523 %files profile-static
524 %defattr(644,root,root,755)
525 %{_libdir}/liballp.a
526 %endif
527 %endif
528
529 %if %{with svga}
530 %files svgalib
531 %defattr(644,root,root,755)
532 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
533 %endif
534
535 %if %{with dga2}
536 %files dga2
537 %defattr(644,root,root,755)
538 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
539 %endif
540
541 %if %{with esd}
542 %files esd
543 %defattr(644,root,root,755)
544 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
545 %endif
546
547 %if %{with arts}
548 %files arts
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
551 %endif
552
553 %if %{with fbcon}
554 %files fbcon
555 %defattr(644,root,root,755)
556 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
557 %endif
558
559 %ifarch %{ix86}
560 %if %{with vga}
561 %files vga
562 %defattr(644,root,root,755)
563 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
564 %endif
565 %endif
566
567 %if %{with alsa}
568 %files alsa
569 %defattr(644,root,root,755)
570 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
571 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
572 %endif
573
574 %if %{with jack}
575 %files jack
576 %defattr(644,root,root,755)
577 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
578 %endif
579
580 %files tools
581 %defattr(644,root,root,755)
582 %attr(755,root,root) %{_bindir}/colormap
583 %attr(755,root,root) %{_bindir}/exedat
584 %attr(755,root,root) %{_bindir}/pack
585 %attr(755,root,root) %{_bindir}/rgbmap
586 %attr(755,root,root) %{_bindir}/textconv
587 %attr(755,root,root) %{_bindir}/xkeymap
588 %attr(755,root,root) %{_bindir}/xf2pcx
589 %attr(755,root,root) %{_bindir}/dat
590 %attr(755,root,root) %{_bindir}/dat2c
591 %attr(755,root,root) %{_bindir}/dat2s
592 %attr(755,root,root) %{_bindir}/grabber
593 %attr(755,root,root) %{_bindir}/pat2dat
594 %attr(755,root,root) %{_bindir}/setup-allegro
595
596 %files tests
597 %defattr(644,root,root,755)
598 %attr(755,root,root) %{_bindir}/afinfo
599 %attr(755,root,root) %{_bindir}/akaitest
600 %attr(755,root,root) %{_bindir}/cpptest
601 %attr(755,root,root) %{_bindir}/demo-allegro
602 %attr(755,root,root) %{_bindir}/digitest
603 %attr(755,root,root) %{_bindir}/filetest
604 %attr(755,root,root) %{_bindir}/gfxinfo
605 %attr(755,root,root) %{_bindir}/mathtest
606 %attr(755,root,root) %{_bindir}/miditest
607 %attr(755,root,root) %{_bindir}/play-allegro
608 %attr(755,root,root) %{_bindir}/playfli
609 %attr(755,root,root) %{_bindir}/test-allegro
610 %attr(755,root,root) %{_bindir}/vesainfo
611
612 %files examples
613 %defattr(644,root,root,755)
614 %attr(755,root,root) %{_bindir}/ex12bit
615 %attr(755,root,root) %{_bindir}/ex3buf
616 %attr(755,root,root) %{_bindir}/ex3d
617 %attr(755,root,root) %{_bindir}/exaccel
618 %attr(755,root,root) %{_bindir}/exalpha
619 %attr(755,root,root) %{_bindir}/exbitmap
620 %attr(755,root,root) %{_bindir}/exblend
621 %attr(755,root,root) %{_bindir}/excamera
622 %attr(755,root,root) %{_bindir}/excolmap
623 %attr(755,root,root) %{_bindir}/exconfig
624 %attr(755,root,root) %{_bindir}/excustom
625 %attr(755,root,root) %{_bindir}/exdata
626 %attr(755,root,root) %{_bindir}/exdbuf
627 %attr(755,root,root) %{_bindir}/exexedat
628 %attr(755,root,root) %{_bindir}/exfixed
629 %attr(755,root,root) %{_bindir}/exflame
630 %attr(755,root,root) %{_bindir}/exflip
631 %attr(755,root,root) %{_bindir}/exfont
632 %attr(755,root,root) %{_bindir}/exgui
633 %attr(755,root,root) %{_bindir}/exhello
634 %attr(755,root,root) %{_bindir}/exjoy
635 %attr(755,root,root) %{_bindir}/exkeys
636 %attr(755,root,root) %{_bindir}/exlights
637 %attr(755,root,root) %{_bindir}/exmem
638 %attr(755,root,root) %{_bindir}/exmidi
639 %attr(755,root,root) %{_bindir}/exmouse
640 %attr(755,root,root) %{_bindir}/expackf
641 %attr(755,root,root) %{_bindir}/expal
642 %attr(755,root,root) %{_bindir}/expat
643 %attr(755,root,root) %{_bindir}/exquat
644 %attr(755,root,root) %{_bindir}/exrgbhsv
645 %attr(755,root,root) %{_bindir}/exsample
646 %attr(755,root,root) %{_bindir}/exsyscur
647 %attr(755,root,root) %{_bindir}/exscale
648 %attr(755,root,root) %{_bindir}/exscn3d
649 %attr(755,root,root) %{_bindir}/exscroll
650 %attr(755,root,root) %{_bindir}/exshade
651 %attr(755,root,root) %{_bindir}/exspline
652 %attr(755,root,root) %{_bindir}/exsprite
653 %attr(755,root,root) %{_bindir}/exstars
654 %attr(755,root,root) %{_bindir}/exstream
655 %attr(755,root,root) %{_bindir}/exswitch
656 %attr(755,root,root) %{_bindir}/extimer
657 %attr(755,root,root) %{_bindir}/extrans
658 %attr(755,root,root) %{_bindir}/extruec
659 %attr(755,root,root) %{_bindir}/exunicod
660 %attr(755,root,root) %{_bindir}/exupdate
661 %attr(755,root,root) %{_bindir}/exxfade
662 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.075814 seconds and 2 git commands to generate.