]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro.spec
- updated to 4.1.13
[packages/allegro5.git] / allegro.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA modules
4 %bcond_without  arts    # without aRts module
5 %bcond_without  dbglib  # don't build debug versions of library
6 %bcond_without  proflib # don't debug profiling versions of library
7 %bcond_without  svga    # without svgalib module
8 %bcond_without  sse     # build without sse (valgrind doesn't support it yet)
9 #
10 %ifnarch %{ix86} alpha
11 %undefine       with_svga
12 %endif
13 Summary:        A game programming library
14 Summary(de):    Eine Bibliothek zur Programmierung von Spielen
15 Summary(es):    Una libreria de programacion de juegos
16 Summary(fr):    Une librairie de programmation de jeux
17 Summary(it):    Una libreria per la programmazione di videogiochi
18 Summary(pl):    Biblioteka do programowania gier
19 Name:           allegro
20 Version:        4.1.13
21 Release:        1
22 License:        Giftware
23 Group:          Libraries
24 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
25 # Source0-md5:  2a96046717cfe2ea6159cf76e11bf622
26 Patch0:         %{name}-info.patch
27 Patch1:         %{name}-examples.patch
28 Patch2:         %{name}-opt.patch
29 Patch3:         %{name}-ldflags.patch
30 Patch4:         %{name}-frame-pointer.patch
31 Patch5:         %{name}-alsa-1_0.patch
32 URL:            http://alleg.sourceforge.net/
33 BuildRequires:  XFree86-devel
34 %{?with_alsa:BuildRequires:     alsa-lib-devel}
35 %{?with_arts:BuildRequires:     arts-devel}
36 BuildRequires:  autoconf
37 BuildRequires:  automake
38 BuildRequires:  esound-devel
39 %{?with_svga:BuildRequires:     svgalib-devel}
40 BuildRequires:  texinfo
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %description
44 Allegro is a cross-platform library intended for use in computer games
45 and other types of multimedia programming.
46
47 %description -l de
48 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
49 Computerspielen und anderen Formen von Multinediaprogrammierung.
50
51 %description -l es
52 Allegro es una librería multi-plataforma creada para ser usada en la
53 programación de juegos u otro tipo de programación multimedia.
54
55 %description -l fr
56 Allegro est une librairie multi-plateforme destinée à être utilisée dans
57 les jeux vidéo ou d'autres types de programmation multimédia.
58
59 %description -l it
60 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
61 ed in altri tipi di programmazione multimediale.
62
63 %description -l pl
64 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
65 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
66
67 %package devel
68 Summary:        A game programming library - header files
69 Summary(pl):    Biblioteka do programowania gier - pliki nag³ówkowe
70 Group:          Development/Libraries
71 Requires:       %{name} = %{version}-%{release}
72
73 %description devel
74 Allegro is a cross-platform library intended for use in computer games
75 and other types of multimedia programming.
76
77 This package contains header files neccessary for compiling
78 applications using allegro library.
79
80 %description devel -l de
81 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
82 Computerspielen und anderen Formen von Multinediaprogrammierung.
83 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
84 verwenden.
85
86 %description devel -l es
87 Allegro es una librería multi-plataforma creada para ser usada en la
88 programación de juegos u otro tipo de programación multimedia. Este
89 paquete es necesario para compilar los programas que usen Allegro.
90
91 %description devel -l fr
92 Allegro est une librairie multi-plateforme destinée à être utilisée dans
93 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
94 est nécessaire pour compiler les programmes utilisant Allegro.
95
96 %description devel -l it
97 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
98 ed in altri tipi di programmazione multimediale. Questo pacchetto è
99 necessario per compilare programmi scritti con Allegro.
100
101 %description devel -l pl
102 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
103 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
104
105 Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
106 aplikacji wykorzystuj±cych bibliotekê allegro.
107
108 %package static
109 Summary:        A game programming library - static libraries
110 Summary(pl):    Biblioteka do programowania gier - biblioteki statyczne
111 Group:          Development/Libraries
112 Requires:       %{name}-devel = %{version}-%{release}
113
114 %description static
115 Allegro is a cross-platform library intended for use in computer games
116 and other types of multimedia programming.
117
118 This package contains static libraries for linking with allegro
119 applications.
120
121 %description static -l pl
122 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
123 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
124
125 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
126 wykorzystuj±cymi allegro.
127
128 %package debug
129 Summary:        liballd - debug version of shared allegro library
130 Summary(pl):    liballd - wersja debug dzielonej biblioteki allegro
131 Group:          Development/Libraries
132 Requires:       %{name}-devel = %{version}-%{release}
133
134 %description debug
135 liballd - debug version of shared allegro library (contains debugging
136 symbols and other information).
137
138 %description debug -l pl
139 liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
140 symbole i inne informacje potrzebne przy odpluskwianiu).
141
142 %package debug-static
143 Summary:        liballd - debug version of static allegro library
144 Summary(pl):    liballd - wersja debug statycznej biblioteki allegro
145 Group:          Development/Libraries
146 Requires:       %{name}-devel = %{version}-%{release}
147
148 %description debug-static
149 liballd - debug version of static allegro library (contains debugging
150 symbols and other information).
151
152 %description debug-static -l pl
153 liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
154 symbole i inne informacje potrzebne przy odpluskwianiu).
155
156 %package profile
157 Summary:        liballp - profiling version of shared allegro library
158 Summary(pl):    liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
159 Group:          Development/Libraries
160 Requires:       %{name}-devel = %{version}-%{release}
161
162 %description profile
163 liballp - profiling version of shared allegro library.
164
165 %description profile -l pl
166 liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
167
168 %package profile-static
169 Summary:        liballp - profiling version of static allegro library
170 Summary(pl):    liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
171 Group:          Development/Libraries
172 Requires:       %{name}-devel = %{version}-%{release}
173
174 %description profile-static
175 liballp - profiling version of static allegro library.
176
177 %description debug-static -l pl
178 liballp - wersja statycznej biblioteki allegro s³u¿±ca do
179 profilowania.
180
181 %package svgalib
182 Summary:        A game programming library - svgalib module
183 Summary(pl):    Biblioteka do programowania gier - modu³ dla svgalib
184 Group:          Libraries
185 PreReq:         %{name} = %{version}-%{release}
186
187 %description svgalib
188 Allegro is a cross-platform library intended for use in computer games
189 and other types of multimedia programming.
190
191 This package contains module for use with allegro and svgalib.
192
193 %description svgalib -l pl
194 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
195 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
196
197 Ten pakiet zawiera modu³ do wykorzystania allegro z svgalibem.
198
199 %package dga2
200 Summary:        A game programming library - DGA2 module
201 Summary(pl):    Biblioteka do programowania gier - modu³ dla DGA2
202 Group:          Libraries
203 PreReq:         %{name} = %{version}-%{release}
204
205 %description dga2
206 Allegro is a cross-platform library intended for use in computer games
207 and other types of multimedia programming.
208
209 This package contains module for use with DGA.
210
211 %description dga2 -l pl
212 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
213 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
214
215 Ten pakiet zawiera modu³ do wykorzystania z DGA.
216
217 %package esd
218 Summary:        A game programming library - esound module
219 Summary(pl):    Biblioteka do programowania gier - modu³ dla esound
220 Group:          Libraries
221 PreReq:         %{name} = %{version}-%{release}
222
223 %description esd
224 Allegro is a cross-platform library intended for use in computer games
225 and other types of multimedia programming.
226
227 This package contains a esound module for use with ESound daemon.
228
229 %description esd -l pl
230 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
231 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
232
233 Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
234
235 %package arts
236 Summary:        A game programming library - aRts module
237 Summary(pl):    Biblioteka do programowania gier - modu³ dla aRts
238 Group:          Libraries
239 PreReq:         %{name} = %{version}-%{release}
240
241 %description arts
242 Allegro is a cross-platform library intended for use in computer games
243 and other types of multimedia programming.
244
245 This package contains a esound module for use with aRts.
246
247 %description arts -l pl
248 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
249 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
250
251 Ten pakiet zawiera modu³ do wykorzystania z aRts.
252
253 %package fbcon
254 Summary:        A game programming library - framebuffer module
255 Summary(pl):    Biblioteka do programowania gier - modu³ dla framebuffera
256 Group:          Libraries
257 PreReq:         %{name} = %{version}-%{release}
258
259 %description fbcon
260 Allegro is a cross-platform library intended for use in computer games
261 and other types of multimedia programming.
262
263 This package contains a esound module for use with framebuffer.
264
265 %description fbcon -l pl
266 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
267 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
268
269 Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
270
271 %package vga
272 Summary:        A game programming library - vga module
273 Summary(pl):    Biblioteka do programowania gier - modu³ dla vga
274 Group:          Libraries
275 PreReq:         %{name} = %{version}-%{release}
276
277 %description vga
278 Allegro is a cross-platform library intended for use in computer games
279 and other types of multimedia programming.
280
281 This package contains a esound module for use with vga.
282
283 %description vga -l pl
284 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
285 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
286
287 Ten pakiet zawiera modu³ do wykorzystania z vga.
288
289 %package alsa
290 Summary:        A game programming library - ALSA modules
291 Summary(pl):    Biblioteka do programowania gier - modu³y dla ALSA
292 Group:          Libraries
293 PreReq:         %{name} = %{version}-%{release}
294 Obsoletes:      allegro-alsa9
295
296 %description alsa
297 Allegro is a cross-platform library intended for use in computer games
298 and other types of multimedia programming.
299
300 This package contains modules for use with ALSA sound library.
301
302 %description alsa -l pl
303 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
304 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
305
306 Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
307 ALSA.
308
309 %package tools
310 Summary:        A game programming library - tools
311 Summary(de):    Zusätzliche Hilfprogramme für die Allegro Bibliothek
312 Summary(es):    Herramientas adicionales para la librería de programación Allegro
313 Summary(fr):    Outils supplémentaires pour la librairie de programmation Allegro
314 Summary(it):    Programmi di utilità aggiuntivi per la libreria Allegro
315 Summary(pl):    Biblioteka do programowania gier - narzêdzia
316 Group:          Libraries
317 PreReq:         %{name} = %{version}-%{release}
318
319 %description tools
320 Allegro is a cross-platform library intended for use in computer games
321 and other types of multimedia programming.
322
323 This package contains tools.
324
325 %description tools -l de
326 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
327 Computerspielen und anderen Formen von Multinediaprogrammierung.
328 Dieses Paket enthält Programme, die für die Entwicklung von
329 Allegro Programmen hilfreich sind.
330
331 %description tools -l es
332 Allegro es una librería multi-plataforma creada para ser usada en la
333 programación de juegos u otro tipo de programación multimedia. Este
334 paquete contiene herramientas adicionales que son útiles para
335 desarrollar programas que usen Allegro.
336
337 %description tools -l fr
338 Allegro est une librairie multi-plateforme destinée à être utilisée dans
339 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
340 contient des outils supplémentaires qui sont utiles pour le développement
341 de programmes avec Allegro.
342
343 %description tools -l it
344 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
345 ed in altri tipi di programmazione multimediale. Questo pacchetto
346 contiene programmi di utilità aggiuntivi utili allo sviluppo di programmi
347 con Allegro.
348
349 %description tools -l pl
350 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
351 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
352
353 Ten pakiet zawiera narzêdzia.
354
355 %package tests
356 Summary:        A game programming library - test programs
357 Summary(pl):    Biblioteka do programowania gier - programy testuj±ce
358 Group:          Development/Libraries
359 Requires:       %{name} = %{version}-%{release}
360
361 %description tests
362 This package contains programs for testing allegro library.
363
364 %description tests -l pl
365 Pakiet zawiera programy testuj±ce bibliotekê allegro.
366
367 %package examples
368 Summary:        A game programming library - examples
369 Summary(pl):    Biblioteka do programowania gier - programy przyk³adowe
370 Group:          Development/Libraries
371 Requires:       %{name} = %{version}-%{release}
372
373 %description examples
374 This package contains example programs which demonstrate allegro
375 features.
376
377 %description examples -l pl
378 Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
379 biblioteki allegro.
380
381 %prep
382 %setup -q
383 %patch0 -p1
384 %patch1 -p1
385 %patch2 -p1
386 %patch3 -p1
387 %patch4 -p1
388 %patch5 -p1
389
390 %build
391 %{__aclocal}
392 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
393 %{__autoconf}
394 TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
395 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
396 %configure \
397         --enable-static \
398         %{!?with_svga:--disable-svgalib} \
399         %{?with_dbglib:--enable-dbglib} \
400         %{?with_proflib:--enable-proflib} \
401         %{!?with_arts:--disable-artsdigi} \
402         %{!?with_sse:--disable-sse} \
403         %{!?with_sse:--disable-asm} \
404 %ifnarch %{ix86}
405         --disable-asm \
406         --disable-mmx \
407         --disable-sse
408 %endif
409
410 %{__make} \
411         MAKEINFO=makeinfo
412
413 %install
414 rm -rf $RPM_BUILD_ROOT
415
416 %{__make} install install-man install-info install-lib \
417         DESTDIR=$RPM_BUILD_ROOT
418
419 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.1
420
421 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
422 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
423 mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
424 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
425
426 # help rpm to find reqs for ELF objects
427 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
428
429 %clean
430 rm -rf $RPM_BUILD_ROOT
431
432 %post   -p /sbin/ldconfig
433 %postun -p /sbin/ldconfig
434
435 %files
436 %defattr(644,root,root,755)
437 %doc AUTHORS CHANGES THANKS
438 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
439 %dir %{_libdir}/allegro
440 %dir %{_libdir}/allegro/4.1
441 %{_libdir}/allegro/4.1/modules.lst
442
443 %files devel
444 %defattr(644,root,root,755)
445 %attr(755,root,root) %{_bindir}/allegro-config
446 %{_libdir}/liballeg_unsharable.a
447 %{_includedir}/*
448 %{_mandir}/man3/*
449 %{_infodir}/*.info*
450
451 %files static
452 %defattr(644,root,root,755)
453 %{_libdir}/liballeg.a
454
455 %if %{with dbglib}
456 %files debug
457 %defattr(644,root,root,755)
458 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
459 %{_libdir}/liballd_unsharable.a
460
461 %files debug-static
462 %defattr(644,root,root,755)
463 %{_libdir}/liballd.a
464 %endif
465
466 %if %{with proflib}
467 %files profile
468 %defattr(644,root,root,755)
469 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
470 %{_libdir}/liballp_unsharable.a
471
472 %files profile-static
473 %defattr(644,root,root,755)
474 %{_libdir}/liballp.a
475 %endif
476
477 %if %{with svga}
478 %files svgalib
479 %defattr(644,root,root,755)
480 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-svgalib.so
481 %endif
482
483 %files dga2
484 %defattr(644,root,root,755)
485 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-dga2.so
486
487 %files esd
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-esddigi.so
490
491 %if %{with arts}
492 %files arts
493 %defattr(644,root,root,755)
494 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-artsdigi.so
495 %endif
496
497 %files fbcon
498 %defattr(644,root,root,755)
499 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-fbcon.so
500
501 %ifarch %{ix86}
502 %files vga
503 %defattr(644,root,root,755)
504 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-vga.so
505 %endif
506
507 %if %{with alsa}
508 %files alsa
509 %defattr(644,root,root,755)
510 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsadigi.so
511 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsamidi.so
512 %endif
513
514 %files tools
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_bindir}/colormap
517 %attr(755,root,root) %{_bindir}/exedat
518 %attr(755,root,root) %{_bindir}/pack
519 %attr(755,root,root) %{_bindir}/rgbmap
520 %attr(755,root,root) %{_bindir}/textconv
521 %attr(755,root,root) %{_bindir}/dat
522 %attr(755,root,root) %{_bindir}/dat2c
523 %attr(755,root,root) %{_bindir}/dat2s
524 %attr(755,root,root) %{_bindir}/grabber
525 %attr(755,root,root) %{_bindir}/pat2dat
526 %attr(755,root,root) %{_bindir}/setup-allegro
527 %attr(755,root,root) %{_bindir}/keyconf
528
529 %files tests
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_bindir}/afinfo
532 %attr(755,root,root) %{_bindir}/akaitest
533 %attr(755,root,root) %{_bindir}/demo-allegro
534 %attr(755,root,root) %{_bindir}/digitest
535 %attr(755,root,root) %{_bindir}/filetest
536 %attr(755,root,root) %{_bindir}/gfxinfo
537 %attr(755,root,root) %{_bindir}/mathtest
538 %attr(755,root,root) %{_bindir}/miditest
539 %attr(755,root,root) %{_bindir}/play-allegro
540 %attr(755,root,root) %{_bindir}/playfli
541 %attr(755,root,root) %{_bindir}/test-allegro
542 %attr(755,root,root) %{_bindir}/vesainfo
543
544 %files examples
545 %defattr(644,root,root,755)
546 %attr(755,root,root) %{_bindir}/ex12bit
547 %attr(755,root,root) %{_bindir}/ex3buf
548 %attr(755,root,root) %{_bindir}/ex3d
549 %attr(755,root,root) %{_bindir}/exaccel
550 %attr(755,root,root) %{_bindir}/exalpha
551 %attr(755,root,root) %{_bindir}/exbitmap
552 %attr(755,root,root) %{_bindir}/exblend
553 %attr(755,root,root) %{_bindir}/excamera
554 %attr(755,root,root) %{_bindir}/excolmap
555 %attr(755,root,root) %{_bindir}/exconfig
556 %attr(755,root,root) %{_bindir}/excustom
557 %attr(755,root,root) %{_bindir}/exdata
558 %attr(755,root,root) %{_bindir}/exdbuf
559 %attr(755,root,root) %{_bindir}/exdodgy
560 %attr(755,root,root) %{_bindir}/exexedat
561 %attr(755,root,root) %{_bindir}/exfixed
562 %attr(755,root,root) %{_bindir}/exflame
563 %attr(755,root,root) %{_bindir}/exflip
564 %attr(755,root,root) %{_bindir}/exgui
565 %attr(755,root,root) %{_bindir}/exhello
566 %attr(755,root,root) %{_bindir}/exjoy
567 %attr(755,root,root) %{_bindir}/exkeys
568 %attr(755,root,root) %{_bindir}/exlights
569 %attr(755,root,root) %{_bindir}/exmem
570 %attr(755,root,root) %{_bindir}/exmidi
571 %attr(755,root,root) %{_bindir}/exmouse
572 %attr(755,root,root) %{_bindir}/expal
573 %attr(755,root,root) %{_bindir}/expat
574 %attr(755,root,root) %{_bindir}/exquat
575 %attr(755,root,root) %{_bindir}/exrgbhsv
576 %attr(755,root,root) %{_bindir}/exsample
577 %attr(755,root,root) %{_bindir}/exscale
578 %attr(755,root,root) %{_bindir}/exscn3d
579 %attr(755,root,root) %{_bindir}/exscroll
580 %attr(755,root,root) %{_bindir}/exshade
581 %attr(755,root,root) %{_bindir}/exspline
582 %attr(755,root,root) %{_bindir}/exsprite
583 %attr(755,root,root) %{_bindir}/exstars
584 %attr(755,root,root) %{_bindir}/exstream
585 %attr(755,root,root) %{_bindir}/exswitch
586 %attr(755,root,root) %{_bindir}/extimer
587 %attr(755,root,root) %{_bindir}/extrans
588 %attr(755,root,root) %{_bindir}/extruec
589 %attr(755,root,root) %{_bindir}/exunicod
590 %attr(755,root,root) %{_bindir}/exupdate
591 %attr(755,root,root) %{_bindir}/exxfade
592 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.131642 seconds and 3 git commands to generate.