]> git.pld-linux.org Git - packages/allegro5.git/blob - allegro.spec
- ugh, fixed
[packages/allegro5.git] / allegro.spec
1 #
2 # Conditional build:
3 %bcond_without  alsa    # without ALSA modules
4 %bcond_without  arts    # without aRts module
5 %bcond_without  dbglib  # don't build debug versions of library
6 %bcond_without  proflib # don't debug profiling versions of library
7 %bcond_without  svga    # without svgalib module
8 %bcond_without  sse     # build without sse (valgrind doesn't support it yet)
9 #
10 # still needed??? let's check...
11 #%%undefine     with_arts
12 %ifnarch %{ix86} alpha
13 %undefine       with_svga
14 %endif
15 Summary:        A game programming library
16 Summary(de):    Eine Bibliothek zur Programmierung von Spielen
17 Summary(es):    Una libreria de programacion de juegos
18 Summary(fr):    Une librairie de programmation de jeux
19 Summary(it):    Una libreria per la programmazione di videogiochi
20 Summary(pl):    Biblioteka do programowania gier
21 Name:           allegro
22 Version:        4.1.12
23 Release:        1
24 License:        Giftware
25 Group:          Libraries
26 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
27 # Source0-md5:  93c215aab32b086dcfd8a74c1d383abc
28 Patch0:         %{name}-info.patch
29 Patch1:         %{name}-examples.patch
30 #Patch2:                %{name}-alsa9.patch
31 Patch2:         %{name}-opt.patch
32 Patch3:         %{name}-ldflags.patch
33 Patch4:         %{name}-frame-pointer.patch
34 URL:            http://alleg.sourceforge.net/
35 BuildRequires:  XFree86-devel
36 %{?with_alsa:BuildRequires:     alsa-lib-devel}
37 %{?with_arts:BuildRequires:     arts-devel}
38 BuildRequires:  autoconf
39 BuildRequires:  automake
40 BuildRequires:  esound-devel
41 %{?with_svga:BuildRequires:     svgalib-devel}
42 BuildRequires:  texinfo
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %description
46 Allegro is a cross-platform library intended for use in computer games
47 and other types of multimedia programming.
48
49 %description -l de
50 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
51 Computerspielen und anderen Formen von Multinediaprogrammierung.
52
53 %description -l es
54 Allegro es una librería multi-plataforma creada para ser usada en la
55 programación de juegos u otro tipo de programación multimedia.
56
57 %description -l fr
58 Allegro est une librairie multi-plateforme destinée à être utilisée dans
59 les jeux vidéo ou d'autres types de programmation multimédia.
60
61 %description -l it
62 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
63 ed in altri tipi di programmazione multimediale.
64
65 %description -l pl
66 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
67 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
68
69 %package devel
70 Summary:        A game programming library - header files
71 Summary(pl):    Biblioteka do programowania gier - pliki nag³ówkowe
72 Group:          Development/Libraries
73 Requires:       %{name} = %{version}
74
75 %description devel
76 Allegro is a cross-platform library intended for use in computer games
77 and other types of multimedia programming.
78
79 This package contains header files neccessary for compiling
80 applications using allegro library.
81
82 %description devel -l de
83 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
84 Computerspielen und anderen Formen von Multinediaprogrammierung.
85 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
86 verwenden.
87
88 %description devel -l es
89 Allegro es una librería multi-plataforma creada para ser usada en la
90 programación de juegos u otro tipo de programación multimedia. Este
91 paquete es necesario para compilar los programas que usen Allegro.
92
93 %description devel -l fr
94 Allegro est une librairie multi-plateforme destinée à être utilisée dans
95 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
96 est nécessaire pour compiler les programmes utilisant Allegro.
97
98 %description devel -l it
99 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
100 ed in altri tipi di programmazione multimediale. Questo pacchetto è
101 necessario per compilare programmi scritti con Allegro.
102
103 %description devel -l pl
104 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
105 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
106
107 Ten pakiet zawiera pliki nag³ówkowe niezbêdne do kompilowania
108 aplikacji wykorzystuj±cych bibliotekê allegro.
109
110 %package static
111 Summary:        A game programming library - static libraries
112 Summary(pl):    Biblioteka do programowania gier - biblioteki statyczne
113 Group:          Development/Libraries
114 Requires:       %{name}-devel = %{version}
115
116 %description static
117 Allegro is a cross-platform library intended for use in computer games
118 and other types of multimedia programming.
119
120 This package contains static libraries for linking with allegro
121 applications.
122
123 %description static -l pl
124 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
125 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
126
127 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
128 wykorzystuj±cymi allegro.
129
130 %package debug
131 Summary:        liballd - debug version of shared allegro library
132 Summary(pl):    liballd - wersja debug dzielonej biblioteki allegro
133 Group:          Development/Libraries
134 Requires:       %{name}-devel = %{version}
135
136 %description debug
137 liballd - debug version of shared allegro library (contains debugging
138 symbols and other information).
139
140 %description debug -l pl
141 liballd - wersja debug dzielonej biblioteki allegro (zawieraj±ca
142 symbole i inne informacje potrzebne przy odpluskwianiu).
143
144 %package debug-static
145 Summary:        liballd - debug version of static allegro library
146 Summary(pl):    liballd - wersja debug statycznej biblioteki allegro
147 Group:          Development/Libraries
148 Requires:       %{name}-devel = %{version}
149
150 %description debug-static
151 liballd - debug version of static allegro library (contains debugging
152 symbols and other information).
153
154 %description debug-static -l pl
155 liballd - wersja debug statycznej biblioteki allegro (zawieraj±ca
156 symbole i inne informacje potrzebne przy odpluskwianiu).
157
158 %package profile
159 Summary:        liballp - profiling version of shared allegro library
160 Summary(pl):    liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania
161 Group:          Development/Libraries
162 Requires:       %{name}-devel = %{version}
163
164 %description profile
165 liballp - profiling version of shared allegro library.
166
167 %description profile -l pl
168 liballp - wersja dzielonej biblioteki allegro s³u¿±ca do profilowania.
169
170 %package profile-static
171 Summary:        liballp - profiling version of static allegro library
172 Summary(pl):    liballp - wersja statycznej biblioteki allegro s³u¿±ca do profilowania
173 Group:          Development/Libraries
174 Requires:       %{name}-devel = %{version}
175
176 %description profile-static
177 liballp - profiling version of static allegro library.
178
179 %description debug-static -l pl
180 liballp - wersja statycznej biblioteki allegro s³u¿±ca do
181 profilowania.
182
183 %package svgalib
184 Summary:        A game programming library - svgalib module
185 Summary(pl):    Biblioteka do programowania gier - modu³ dla svgalib
186 Group:          Libraries
187 PreReq:         %{name} = %{version}
188
189 %description svgalib
190 Allegro is a cross-platform library intended for use in computer games
191 and other types of multimedia programming.
192
193 This package contains module for use with allegro and svgalib.
194
195 %description svgalib -l pl
196 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
197 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
198
199 Ten pakiet zawiera modu³ do wykorzystania allegro z svgalibem.
200
201 %package dga2
202 Summary:        A game programming library - DGA2 module
203 Summary(pl):    Biblioteka do programowania gier - modu³ dla DGA2
204 Group:          Libraries
205 PreReq:         %{name} = %{version}
206
207 %description dga2
208 Allegro is a cross-platform library intended for use in computer games
209 and other types of multimedia programming.
210
211 This package contains module for use with DGA.
212
213 %description dga2 -l pl
214 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
215 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
216
217 Ten pakiet zawiera modu³ do wykorzystania z DGA.
218
219 %package esd
220 Summary:        A game programming library - esound module
221 Summary(pl):    Biblioteka do programowania gier - modu³ dla esound
222 Group:          Libraries
223 PreReq:         %{name} = %{version}
224
225 %description esd
226 Allegro is a cross-platform library intended for use in computer games
227 and other types of multimedia programming.
228
229 This package contains a esound module for use with ESound daemon.
230
231 %description esd -l pl
232 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
233 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
234
235 Ten pakiet zawiera modu³ do wykorzystania z demonem ESound.
236
237 %package arts
238 Summary:        A game programming library - aRts module
239 Summary(pl):    Biblioteka do programowania gier - modu³ dla aRts
240 Group:          Libraries
241 PreReq:         %{name} = %{version}
242
243 %description arts
244 Allegro is a cross-platform library intended for use in computer games
245 and other types of multimedia programming.
246
247 This package contains a esound module for use with aRts.
248
249 %description arts -l pl
250 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
251 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
252
253 Ten pakiet zawiera modu³ do wykorzystania z aRts.
254
255 %package fbcon
256 Summary:        A game programming library - framebuffer module
257 Summary(pl):    Biblioteka do programowania gier - modu³ dla framebuffera
258 Group:          Libraries
259 PreReq:         %{name} = %{version}
260
261 %description fbcon
262 Allegro is a cross-platform library intended for use in computer games
263 and other types of multimedia programming.
264
265 This package contains a esound module for use with framebuffer.
266
267 %description fbcon -l pl
268 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
269 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
270
271 Ten pakiet zawiera modu³ do wykorzystania z framebufferem.
272
273 %package vga
274 Summary:        A game programming library - vga module
275 Summary(pl):    Biblioteka do programowania gier - modu³ dla vga
276 Group:          Libraries
277 PreReq:         %{name} = %{version}
278
279 %description vga
280 Allegro is a cross-platform library intended for use in computer games
281 and other types of multimedia programming.
282
283 This package contains a esound module for use with vga.
284
285 %description vga -l pl
286 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
287 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
288
289 Ten pakiet zawiera modu³ do wykorzystania z vga.
290
291 %package alsa
292 Summary:        A game programming library - ALSA modules
293 Summary(pl):    Biblioteka do programowania gier - modu³y dla ALSA
294 Group:          Libraries
295 PreReq:         %{name} = %{version}
296 Obsoletes:      allegro-alsa9
297
298 %description alsa
299 Allegro is a cross-platform library intended for use in computer games
300 and other types of multimedia programming.
301
302 This package contains modules for use with ALSA sound library.
303
304 %description alsa -l pl
305 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
306 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
307
308 Ten pakiet zawiera modu³y do wykorzystania z bibliotek± d¼wiêkow±
309 ALSA.
310
311 %package tools
312 Summary:        A game programming library - tools
313 Summary(de):    Zusätzliche Hilfprogramme für die Allegro Bibliothek
314 Summary(es):    Herramientas adicionales para la librería de programación Allegro
315 Summary(fr):    Outils supplémentaires pour la librairie de programmation Allegro
316 Summary(it):    Programmi di utilità aggiuntivi per la libreria Allegro
317 Summary(pl):    Biblioteka do programowania gier - narzêdzia
318 Group:          Libraries
319 PreReq:         %{name} = %{version}
320
321 %description tools
322 Allegro is a cross-platform library intended for use in computer games
323 and other types of multimedia programming.
324
325 This package contains tools.
326
327 %description tools -l de
328 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
329 Computerspielen und anderen Formen von Multinediaprogrammierung.
330 Dieses Paket enthält Programme, die für die Entwicklung von
331 Allegro Programmen hilfreich sind.
332
333 %description tools -l es
334 Allegro es una librería multi-plataforma creada para ser usada en la
335 programación de juegos u otro tipo de programación multimedia. Este
336 paquete contiene herramientas adicionales que son útiles para
337 desarrollar programas que usen Allegro.
338
339 %description tools -l fr
340 Allegro est une librairie multi-plateforme destinée à être utilisée dans
341 les jeux vidéo ou d'autres types de programmation multimédia. Ce package
342 contient des outils supplémentaires qui sont utiles pour le développement
343 de programmes avec Allegro.
344
345 %description tools -l it
346 Allegro è una libreria multipiattaforma dedicata all'uso nei videogiochi
347 ed in altri tipi di programmazione multimediale. Questo pacchetto
348 contiene programmi di utilità aggiuntivi utili allo sviluppo di programmi
349 con Allegro.
350
351 %description tools -l pl
352 Allegro jest przeno¶n± bibliotek± przeznaczon± do wykorzystania w
353 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
354
355 Ten pakiet zawiera narzêdzia.
356
357 %package tests
358 Summary:        A game programming library - test programs
359 Summary(pl):    Biblioteka do programowania gier - programy testuj±ce
360 Group:          Development/Libraries
361 Requires:       %{name} = %{version}
362
363 %description tests
364 This package contains programs for testing allegro library.
365
366 %description tests -l pl
367 Pakiet zawiera programy testuj±ce bibliotekê allegro.
368
369 %package examples
370 Summary:        A game programming library - examples
371 Summary(pl):    Biblioteka do programowania gier - programy przyk³adowe
372 Group:          Development/Libraries
373 Requires:       %{name} = %{version}
374
375 %description examples
376 This package contains example programs which demonstrate allegro
377 features.
378
379 %description examples -l pl
380 Pakiet zawiera programy przyk³adowe demonstruj±ce mo¿liwo¶ci
381 biblioteki allegro.
382
383 %prep
384 %setup -q
385 %patch0 -p1
386 %patch1 -p1
387 %patch2 -p1
388 %patch3 -p1
389 %patch4 -p1
390
391 %build
392 %{__aclocal}
393 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
394 %{__autoconf}
395 TARGET_ARCH="%{rpmcflags} %{?with_arts:-I/usr/include/artsc}" export TARGET_ARCH
396 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
397 %configure \
398         --enable-static \
399         %{!?with_svga:--disable-svgalib} \
400         %{?with_dbglib:--enable-dbglib} \
401         %{?with_proflib:--enable-proflib} \
402         %{!?with_arts:--disable-artsdigi} \
403         %{!?with_sse:--disable-sse} \
404         %{!?with_sse:--disable-asm} \
405 %ifnarch %{ix86}
406         --disable-asm \
407         --disable-mmx \
408         --disable-sse
409 %endif
410 # shouldn't be needed, let's check
411 #%ifnarch %{ix86}
412 #       --disable-vga \
413 #       --disable-linux
414 #%endif
415
416 %{__make} \
417         MAKEINFO=makeinfo
418
419 %install
420 rm -rf $RPM_BUILD_ROOT
421
422 %{__make} install install-man install-info install-lib \
423         DESTDIR=$RPM_BUILD_ROOT
424
425 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/4.1
426
427 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
428 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
429 mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
430 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
431
432 # help rpm to find reqs for ELF objects
433 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
434
435 %clean
436 rm -rf $RPM_BUILD_ROOT
437
438 %post   -p /sbin/ldconfig
439 %postun -p /sbin/ldconfig
440
441 %files
442 %defattr(644,root,root,755)
443 %doc AUTHORS CHANGES THANKS
444 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
445 %dir %{_libdir}/allegro
446 %dir %{_libdir}/allegro/4.1
447 %{_libdir}/allegro/4.1/modules.lst
448
449 %files devel
450 %defattr(644,root,root,755)
451 %attr(755,root,root) %{_bindir}/allegro-config
452 %{_libdir}/liballeg_unsharable.a
453 %{_includedir}/*
454 %{_mandir}/man3/*
455 %{_infodir}/*.info*
456
457 %files static
458 %defattr(644,root,root,755)
459 %{_libdir}/liballeg.a
460
461 %if %{with dbglib}
462 %files debug
463 %defattr(644,root,root,755)
464 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
465 %{_libdir}/liballd_unsharable.a
466
467 %files debug-static
468 %defattr(644,root,root,755)
469 %{_libdir}/liballd.a
470 %endif
471
472 %if %{with proflib}
473 %files profile
474 %defattr(644,root,root,755)
475 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
476 %{_libdir}/liballp_unsharable.a
477
478 %files profile-static
479 %defattr(644,root,root,755)
480 %{_libdir}/liballp.a
481 %endif
482
483 %if %{with svga}
484 %files svgalib
485 %defattr(644,root,root,755)
486 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-svgalib.so
487 %endif
488
489 %files dga2
490 %defattr(644,root,root,755)
491 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-dga2.so
492
493 %files esd
494 %defattr(644,root,root,755)
495 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-esddigi.so
496
497 %if %{with arts}
498 %files arts
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-artsdigi.so
501 %endif
502
503 %files fbcon
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-fbcon.so
506
507 %files vga
508 %defattr(644,root,root,755)
509 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-vga.so
510
511 %if %{with alsa}
512 %files alsa
513 %defattr(644,root,root,755)
514 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsadigi.so
515 %attr(755,root,root) %{_libdir}/allegro/4.1/alleg-alsamidi.so
516 %endif
517
518 %files tools
519 %defattr(644,root,root,755)
520 %attr(755,root,root) %{_bindir}/colormap
521 %attr(755,root,root) %{_bindir}/exedat
522 %attr(755,root,root) %{_bindir}/pack
523 %attr(755,root,root) %{_bindir}/rgbmap
524 %attr(755,root,root) %{_bindir}/textconv
525 %attr(755,root,root) %{_bindir}/dat
526 %attr(755,root,root) %{_bindir}/dat2c
527 %attr(755,root,root) %{_bindir}/dat2s
528 %attr(755,root,root) %{_bindir}/grabber
529 %attr(755,root,root) %{_bindir}/pat2dat
530 %attr(755,root,root) %{_bindir}/setup-allegro
531 %attr(755,root,root) %{_bindir}/keyconf
532
533 %files tests
534 %defattr(644,root,root,755)
535 %attr(755,root,root) %{_bindir}/afinfo
536 %attr(755,root,root) %{_bindir}/akaitest
537 %attr(755,root,root) %{_bindir}/demo-allegro
538 %attr(755,root,root) %{_bindir}/digitest
539 %attr(755,root,root) %{_bindir}/filetest
540 %attr(755,root,root) %{_bindir}/gfxinfo
541 %attr(755,root,root) %{_bindir}/mathtest
542 %attr(755,root,root) %{_bindir}/miditest
543 %attr(755,root,root) %{_bindir}/play-allegro
544 %attr(755,root,root) %{_bindir}/playfli
545 %attr(755,root,root) %{_bindir}/test-allegro
546 %attr(755,root,root) %{_bindir}/vesainfo
547
548 %files examples
549 %defattr(644,root,root,755)
550 %attr(755,root,root) %{_bindir}/ex12bit
551 %attr(755,root,root) %{_bindir}/ex3buf
552 %attr(755,root,root) %{_bindir}/ex3d
553 %attr(755,root,root) %{_bindir}/exaccel
554 %attr(755,root,root) %{_bindir}/exalpha
555 %attr(755,root,root) %{_bindir}/exbitmap
556 %attr(755,root,root) %{_bindir}/exblend
557 %attr(755,root,root) %{_bindir}/excamera
558 %attr(755,root,root) %{_bindir}/excolmap
559 %attr(755,root,root) %{_bindir}/exconfig
560 %attr(755,root,root) %{_bindir}/excustom
561 %attr(755,root,root) %{_bindir}/exdata
562 %attr(755,root,root) %{_bindir}/exdbuf
563 %attr(755,root,root) %{_bindir}/exdodgy
564 %attr(755,root,root) %{_bindir}/exexedat
565 %attr(755,root,root) %{_bindir}/exfixed
566 %attr(755,root,root) %{_bindir}/exflame
567 %attr(755,root,root) %{_bindir}/exflip
568 %attr(755,root,root) %{_bindir}/exgui
569 %attr(755,root,root) %{_bindir}/exhello
570 %attr(755,root,root) %{_bindir}/exjoy
571 %attr(755,root,root) %{_bindir}/exkeys
572 %attr(755,root,root) %{_bindir}/exlights
573 %attr(755,root,root) %{_bindir}/exmem
574 %attr(755,root,root) %{_bindir}/exmidi
575 %attr(755,root,root) %{_bindir}/exmouse
576 %attr(755,root,root) %{_bindir}/expal
577 %attr(755,root,root) %{_bindir}/expat
578 %attr(755,root,root) %{_bindir}/exquat
579 %attr(755,root,root) %{_bindir}/exrgbhsv
580 %attr(755,root,root) %{_bindir}/exsample
581 %attr(755,root,root) %{_bindir}/exscale
582 %attr(755,root,root) %{_bindir}/exscn3d
583 %attr(755,root,root) %{_bindir}/exscroll
584 %attr(755,root,root) %{_bindir}/exshade
585 %attr(755,root,root) %{_bindir}/exspline
586 %attr(755,root,root) %{_bindir}/exsprite
587 %attr(755,root,root) %{_bindir}/exstars
588 %attr(755,root,root) %{_bindir}/exstream
589 %attr(755,root,root) %{_bindir}/exswitch
590 %attr(755,root,root) %{_bindir}/extimer
591 %attr(755,root,root) %{_bindir}/extrans
592 %attr(755,root,root) %{_bindir}/extruec
593 %attr(755,root,root) %{_bindir}/exunicod
594 %attr(755,root,root) %{_bindir}/exupdate
595 %attr(755,root,root) %{_bindir}/exxfade
596 %attr(755,root,root) %{_bindir}/exzbuf
This page took 2.61849 seconds and 3 git commands to generate.