]> git.pld-linux.org Git - packages/allegro.git/blob - allegro.spec
e044320dacb2d6306fae9ab44c58d87d46e6cc09
[packages/allegro.git] / allegro.spec
1 #
2 # TODO: Handle situations when there are no modules (most bconds turned off)
3 #
4 # Conditional build:
5 %bcond_without  alsa    # without ALSA modules
6 %bcond_without  arts    # without aRts module
7 %bcond_without  dga2    # without DGA2 module
8 %bcond_without  dbglib  # don't build debug versions of library
9 %bcond_without  esd     # without esound module
10 %bcond_without  fbcon   # without framebuffer module
11 %bcond_without  jack    # without JACK module
12 %bcond_without  proflib # don't debug profiling versions of library
13 %bcond_without  sse     # build without sse
14 %bcond_without  static  # don't build static versions of library
15 %bcond_without  svga    # without svgalib module
16 %bcond_without  vga     # without vga module
17 #
18 Summary:        A game programming library
19 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
20 Summary(es.UTF-8):      Una biblioteca de programación de juegos
21 Summary(fr.UTF-8):      Une librairie de programmation de jeux
22 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
23 Summary(pl.UTF-8):      Biblioteka do programowania gier
24 Name:           allegro
25 Version:        4.3.0
26 Release:        1
27 License:        Giftware
28 Group:          Libraries
29 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30 # Source0-md5:  0746b948ecd63cab806026cf3b452e20
31 Patch0:         %{name}-info.patch
32 Patch1:         %{name}-examples.patch
33 Patch2:         %{name}-opt.patch
34 Patch3:         %{name}-ldflags.patch
35 Patch4:         %{name}-frame-pointer.patch
36 Patch5:         %{name}-config.patch
37 URL:            http://alleg.sourceforge.net/
38 %{?with_alsa:BuildRequires:     alsa-lib-devel}
39 %{?with_arts:BuildRequires:     artsc-devel}
40 BuildRequires:  autoconf >= 2.53
41 BuildRequires:  automake
42 %{?with_esd:BuildRequires:      esound-devel}
43 %if %{with jack}
44 BuildRequires:  jack-audio-connection-kit-devel
45 BuildRequires:  pkgconfig
46 %endif
47 %{?with_svga:BuildRequires:     svgalib-devel}
48 BuildRequires:  texinfo
49 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
50
51 %description
52 Allegro is a cross-platform library intended for use in computer games
53 and other types of multimedia programming.
54
55 %description -l de.UTF-8
56 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
57 Computerspielen und anderen Formen von Multinediaprogrammierung.
58
59 %description -l es.UTF-8
60 Allegro es una librería multi-plataforma creada para ser usada en la
61 programación de juegos u otro tipo de programación multimedia.
62
63 %description -l fr.UTF-8
64 Allegro est une librairie multi-plateforme destinée à être utilisée
65 dans les jeux vidéo ou d'autres types de programmation multimédia.
66
67 %description -l it.UTF-8
68 Allegro è una libreria multipiattaforma dedicata all'uso nei
69 videogiochi ed in altri tipi di programmazione multimediale.
70
71 %description -l pl.UTF-8
72 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
73 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
74
75 %package devel
76 Summary:        A game programming library - header files
77 Summary(es.UTF-8):      Archivos de inclusión
78 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
79 Group:          Development/Libraries
80 Requires:       %{name} = %{version}-%{release}
81
82 %description devel
83 Allegro is a cross-platform library intended for use in computer games
84 and other types of multimedia programming.
85
86 This package contains header files neccessary for compiling
87 applications using allegro library.
88
89 %description devel -l de.UTF-8
90 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
91 Computerspielen und anderen Formen von Multinediaprogrammierung.
92 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
93 verwenden.
94
95 %description devel -l es.UTF-8
96 Allegro es una librería multi-plataforma creada para ser usada en la
97 programación de juegos u otro tipo de programación multimedia. Este
98 paquete es necesario para compilar los programas que usen Allegro.
99
100 %description devel -l fr.UTF-8
101 Allegro est une librairie multi-plateforme destinée à être utilisée
102 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
103 package est nécessaire pour compiler les programmes utilisant Allegro.
104
105 %description devel -l it.UTF-8
106 Allegro è una libreria multipiattaforma dedicata all'uso nei
107 videogiochi ed in altri tipi di programmazione multimediale. Questo
108 pacchetto è necessario per compilare programmi scritti con Allegro.
109
110 %description devel -l pl.UTF-8
111 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
112 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
113
114 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
115 aplikacji wykorzystujących bibliotekę allegro.
116
117 %package static
118 Summary:        A game programming library - static libraries
119 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
120 Group:          Development/Libraries
121 Requires:       %{name}-devel = %{version}-%{release}
122
123 %description static
124 Allegro is a cross-platform library intended for use in computer games
125 and other types of multimedia programming.
126
127 This package contains static libraries for linking with allegro
128 applications.
129
130 %description static -l pl.UTF-8
131 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
132 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
133
134 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
135 wykorzystującymi allegro.
136
137 %package debug
138 Summary:        liballd - debug version of shared allegro library
139 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
140 Group:          Development/Libraries
141 Requires:       %{name}-devel = %{version}-%{release}
142
143 %description debug
144 liballd - debug version of shared allegro library (contains debugging
145 symbols and other information).
146
147 %description debug -l pl.UTF-8
148 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
149 symbole i inne informacje potrzebne przy odpluskwianiu).
150
151 %package debug-static
152 Summary:        liballd - debug version of static allegro library
153 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
154 Group:          Development/Libraries
155 Requires:       %{name}-devel = %{version}-%{release}
156
157 %description debug-static
158 liballd - debug version of static allegro library (contains debugging
159 symbols and other information).
160
161 %description debug-static -l pl.UTF-8
162 liballd - wersja debug statycznej biblioteki allegro (zawierająca
163 symbole i inne informacje potrzebne przy odpluskwianiu).
164
165 %package profile
166 Summary:        liballp - profiling version of shared allegro library
167 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
168 Group:          Development/Libraries
169 Requires:       %{name}-devel = %{version}-%{release}
170
171 %description profile
172 liballp - profiling version of shared allegro library.
173
174 %description profile -l pl.UTF-8
175 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
176
177 %package profile-static
178 Summary:        liballp - profiling version of static allegro library
179 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
180 Group:          Development/Libraries
181 Requires:       %{name}-devel = %{version}-%{release}
182
183 %description profile-static
184 liballp - profiling version of static allegro library.
185
186 %description profile-static -l pl.UTF-8
187 liballp - wersja statycznej biblioteki allegro służąca do
188 profilowania.
189
190 %package svgalib
191 Summary:        A game programming library - svgalib module
192 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
193 Group:          Libraries
194 Requires:       %{name} = %{version}-%{release}
195
196 %description svgalib
197 Allegro is a cross-platform library intended for use in computer games
198 and other types of multimedia programming.
199
200 This package contains module for use with allegro and svgalib.
201
202 %description svgalib -l pl.UTF-8
203 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
204 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
205
206 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
207
208 %package dga2
209 Summary:        A game programming library - DGA2 module
210 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
211 Group:          Libraries
212 Requires:       %{name} = %{version}-%{release}
213
214 %description dga2
215 Allegro is a cross-platform library intended for use in computer games
216 and other types of multimedia programming.
217
218 This package contains module for use with DGA.
219
220 %description dga2 -l pl.UTF-8
221 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
222 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
223
224 Ten pakiet zawiera moduł do wykorzystania z DGA.
225
226 %package esd
227 Summary:        A game programming library - esound module
228 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
229 Group:          Libraries
230 Requires:       %{name} = %{version}-%{release}
231
232 %description esd
233 Allegro is a cross-platform library intended for use in computer games
234 and other types of multimedia programming.
235
236 This package contains a esound module for use with ESound daemon.
237
238 %description esd -l pl.UTF-8
239 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
240 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
241
242 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
243
244 %package arts
245 Summary:        A game programming library - aRts module
246 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
247 Group:          Libraries
248 Requires:       %{name} = %{version}-%{release}
249
250 %description arts
251 Allegro is a cross-platform library intended for use in computer games
252 and other types of multimedia programming.
253
254 This package contains a esound module for use with aRts.
255
256 %description arts -l pl.UTF-8
257 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
258 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
259
260 Ten pakiet zawiera moduł do wykorzystania z aRts.
261
262 %package fbcon
263 Summary:        A game programming library - framebuffer module
264 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
265 Group:          Libraries
266 Requires:       %{name} = %{version}-%{release}
267
268 %description fbcon
269 Allegro is a cross-platform library intended for use in computer games
270 and other types of multimedia programming.
271
272 This package contains a esound module for use with framebuffer.
273
274 %description fbcon -l pl.UTF-8
275 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
276 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
277
278 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
279
280 %package vga
281 Summary:        A game programming library - vga module
282 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
283 Group:          Libraries
284 Requires:       %{name} = %{version}-%{release}
285
286 %description vga
287 Allegro is a cross-platform library intended for use in computer games
288 and other types of multimedia programming.
289
290 This package contains a esound module for use with vga.
291
292 %description vga -l pl.UTF-8
293 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
294 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
295
296 Ten pakiet zawiera moduł do wykorzystania z vga.
297
298 %package alsa
299 Summary:        A game programming library - ALSA modules
300 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
301 Group:          Libraries
302 Requires:       %{name} = %{version}-%{release}
303 Obsoletes:      allegro-alsa9
304
305 %description alsa
306 Allegro is a cross-platform library intended for use in computer games
307 and other types of multimedia programming.
308
309 This package contains modules for use with ALSA sound library.
310
311 %description alsa -l pl.UTF-8
312 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
313 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
314
315 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
316 ALSA.
317
318 %package jack
319 Summary:        A game programming library - JACK module
320 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
321 Group:          Libraries
322 Requires:       %{name} = %{version}-%{release}
323
324 %description jack
325 Allegro is a cross-platform library intended for use in computer games
326 and other types of multimedia programming.
327
328 This package contains module for use with JACK sound library.
329
330 %description jack -l pl.UTF-8
331 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
332 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
333
334 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
335
336 %package tools
337 Summary:        A game programming library - tools
338 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
339 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
340 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
341 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
342 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
343 Group:          Libraries
344 Requires:       %{name} = %{version}-%{release}
345
346 %description tools
347 Allegro is a cross-platform library intended for use in computer games
348 and other types of multimedia programming.
349
350 This package contains tools.
351
352 %description tools -l de.UTF-8
353 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
354 Computerspielen und anderen Formen von Multinediaprogrammierung.
355 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
356 Programmen hilfreich sind.
357
358 %description tools -l es.UTF-8
359 Allegro es una librería multi-plataforma creada para ser usada en la
360 programación de juegos u otro tipo de programación multimedia. Este
361 paquete contiene herramientas adicionales que son útiles para
362 desarrollar programas que usen Allegro.
363
364 %description tools -l fr.UTF-8
365 Allegro est une librairie multi-plateforme destinée à être utilisée
366 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
367 package contient des outils supplémentaires qui sont utiles pour le
368 développement de programmes avec Allegro.
369
370 %description tools -l it.UTF-8
371 Allegro è una libreria multipiattaforma dedicata all'uso nei
372 videogiochi ed in altri tipi di programmazione multimediale. Questo
373 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
374 di programmi con Allegro.
375
376 %description tools -l pl.UTF-8
377 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
378 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
379
380 Ten pakiet zawiera narzędzia.
381
382 %package tests
383 Summary:        A game programming library - test programs
384 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
385 Group:          Development/Libraries
386 Requires:       %{name} = %{version}-%{release}
387
388 %description tests
389 This package contains programs for testing allegro library.
390
391 %description tests -l pl.UTF-8
392 Pakiet zawiera programy testujące bibliotekę allegro.
393
394 %package examples
395 Summary:        A game programming library - examples
396 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
397 Group:          Development/Libraries
398 Requires:       %{name} = %{version}-%{release}
399
400 %description examples
401 This package contains example programs which demonstrate allegro
402 features.
403
404 %description examples -l pl.UTF-8
405 Pakiet zawiera programy przykładowe demonstrujące możliwości
406 biblioteki allegro.
407
408 %prep
409 %setup -q
410 %patch0 -p1
411 %patch1 -p1
412 %patch2 -p1
413 %patch3 -p1
414 %patch4 -p1
415 %patch5 -p1
416
417 %build
418 %{__aclocal}
419 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
420 %{__autoconf}
421 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
422 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
423 %configure \
424         %{?with_static:--enable-static} \
425         %{?with_dbglib:--enable-dbglib} \
426         %{?with_proflib:--enable-proflib} \
427 %if !%{with alsa}
428         --disable-alsadigi \
429         --disable-alsamidi \
430 %endif
431         %{!?with_arts:--disable-artsdigi} \
432         %{!?with_dga2:--disable-xwin-dga2} \
433         %{!?with_esd:--disable-esddigi} \
434         %{!?with_fbcon:--disable-fbcon} \
435         %{!?with_jack:--disable-jackdigi} \
436         %{!?with_svga:--disable-svgalib} \
437         %{!?with_vga:--disable-vga} \
438 %if !%{with sse}
439         --disable-sse \
440         --disable-asm \
441 %endif
442 %ifnarch %{ix86}
443         --disable-asm \
444         --disable-mmx \
445         --disable-sse
446 %endif
447
448 %{__make} \
449         MAKEINFO=makeinfo
450
451 %install
452 rm -rf $RPM_BUILD_ROOT
453
454 %{__make} install install-man install-info install-lib \
455         DESTDIR=$RPM_BUILD_ROOT
456
457 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
458
459 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
460 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
461 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
462 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
463
464 # help rpm to find reqs for ELF objects
465 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
466
467 %clean
468 rm -rf $RPM_BUILD_ROOT
469
470 %post   -p /sbin/ldconfig
471 %postun -p /sbin/ldconfig
472
473 %post devel
474 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
475
476 %postun devel
477 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
478
479 %files
480 %defattr(644,root,root,755)
481 %doc AUTHORS CHANGES THANKS readme.txt
482 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
483 %dir %{_libdir}/allegro
484 %dir %{_libdir}/allegro/%{version}
485 %{_libdir}/allegro/%{version}/modules.lst
486
487 %files devel
488 %defattr(644,root,root,755)
489 %attr(755,root,root) %{_bindir}/allegro-config
490 %{_libdir}/liballeg_unsharable.a
491 %{_includedir}/*
492 %{_aclocaldir}/allegro.m4
493 %{_mandir}/man3/*
494 %{_infodir}/*.info*
495
496 %if %{with static}
497 %files static
498 %defattr(644,root,root,755)
499 %{_libdir}/liballeg.a
500 %endif
501
502 %if %{with dbglib}
503 %files debug
504 %defattr(644,root,root,755)
505 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
506 %{_libdir}/liballd_unsharable.a
507
508 %if %{with static}
509 %files debug-static
510 %defattr(644,root,root,755)
511 %{_libdir}/liballd.a
512 %endif
513 %endif
514
515 %if %{with proflib}
516 %files profile
517 %defattr(644,root,root,755)
518 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
519 %{_libdir}/liballp_unsharable.a
520
521 %if %{with static}
522 %files profile-static
523 %defattr(644,root,root,755)
524 %{_libdir}/liballp.a
525 %endif
526 %endif
527
528 %if %{with svga}
529 %files svgalib
530 %defattr(644,root,root,755)
531 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
532 %endif
533
534 %if %{with dga2}
535 %files dga2
536 %defattr(644,root,root,755)
537 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
538 %endif
539
540 %if %{with esd}
541 %files esd
542 %defattr(644,root,root,755)
543 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
544 %endif
545
546 %if %{with arts}
547 %files arts
548 %defattr(644,root,root,755)
549 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
550 %endif
551
552 %if %{with fbcon}
553 %files fbcon
554 %defattr(644,root,root,755)
555 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
556 %endif
557
558 %ifarch %{ix86}
559 %if %{with vga}
560 %files vga
561 %defattr(644,root,root,755)
562 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
563 %endif
564 %endif
565
566 %if %{with alsa}
567 %files alsa
568 %defattr(644,root,root,755)
569 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
570 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
571 %endif
572
573 %if %{with jack}
574 %files jack
575 %defattr(644,root,root,755)
576 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
577 %endif
578
579 %files tools
580 %defattr(644,root,root,755)
581 %attr(755,root,root) %{_bindir}/colormap
582 %attr(755,root,root) %{_bindir}/exedat
583 %attr(755,root,root) %{_bindir}/pack
584 %attr(755,root,root) %{_bindir}/rgbmap
585 %attr(755,root,root) %{_bindir}/textconv
586 #%attr(755,root,root) %{_bindir}/xkeymap
587 %attr(755,root,root) %{_bindir}/xf2pcx
588 %attr(755,root,root) %{_bindir}/dat
589 %attr(755,root,root) %{_bindir}/dat2c
590 %attr(755,root,root) %{_bindir}/dat2s
591 %attr(755,root,root) %{_bindir}/grabber
592 %attr(755,root,root) %{_bindir}/pat2dat
593 #%attr(755,root,root) %{_bindir}/setup-allegro
594
595 %files tests
596 %defattr(644,root,root,755)
597 %attr(755,root,root) %{_bindir}/afinfo
598 %attr(755,root,root) %{_bindir}/akaitest
599 %attr(755,root,root) %{_bindir}/cpptest
600 %attr(755,root,root) %{_bindir}/demo-allegro
601 %attr(755,root,root) %{_bindir}/digitest
602 %attr(755,root,root) %{_bindir}/filetest
603 %attr(755,root,root) %{_bindir}/gfxinfo
604 %attr(755,root,root) %{_bindir}/mathtest
605 %attr(755,root,root) %{_bindir}/miditest
606 %attr(755,root,root) %{_bindir}/play-allegro
607 %attr(755,root,root) %{_bindir}/playfli
608 %attr(755,root,root) %{_bindir}/test-allegro
609 %attr(755,root,root) %{_bindir}/vesainfo
610
611 %files examples
612 %defattr(644,root,root,755)
613 %attr(755,root,root) %{_bindir}/ex12bit
614 %attr(755,root,root) %{_bindir}/ex3buf
615 %attr(755,root,root) %{_bindir}/ex3d
616 %attr(755,root,root) %{_bindir}/exaccel
617 %attr(755,root,root) %{_bindir}/exalpha
618 %attr(755,root,root) %{_bindir}/exbitmap
619 %attr(755,root,root) %{_bindir}/exblend
620 %attr(755,root,root) %{_bindir}/excamera
621 %attr(755,root,root) %{_bindir}/excolmap
622 %attr(755,root,root) %{_bindir}/exconfig
623 %attr(755,root,root) %{_bindir}/excustom
624 %attr(755,root,root) %{_bindir}/exdata
625 %attr(755,root,root) %{_bindir}/exdbuf
626 %attr(755,root,root) %{_bindir}/exexedat
627 %attr(755,root,root) %{_bindir}/exfixed
628 %attr(755,root,root) %{_bindir}/exflame
629 %attr(755,root,root) %{_bindir}/exflip
630 %attr(755,root,root) %{_bindir}/exfont
631 %attr(755,root,root) %{_bindir}/exgui
632 %attr(755,root,root) %{_bindir}/exhello
633 %attr(755,root,root) %{_bindir}/exjoy
634 %attr(755,root,root) %{_bindir}/exkeys
635 %attr(755,root,root) %{_bindir}/exlights
636 %attr(755,root,root) %{_bindir}/exmem
637 %attr(755,root,root) %{_bindir}/exmidi
638 %attr(755,root,root) %{_bindir}/exmouse
639 %attr(755,root,root) %{_bindir}/expackf
640 %attr(755,root,root) %{_bindir}/expal
641 %attr(755,root,root) %{_bindir}/expat
642 %attr(755,root,root) %{_bindir}/exquat
643 %attr(755,root,root) %{_bindir}/exrgbhsv
644 %attr(755,root,root) %{_bindir}/exsample
645 %attr(755,root,root) %{_bindir}/exsyscur
646 %attr(755,root,root) %{_bindir}/exscale
647 %attr(755,root,root) %{_bindir}/exscn3d
648 %attr(755,root,root) %{_bindir}/exscroll
649 %attr(755,root,root) %{_bindir}/exshade
650 %attr(755,root,root) %{_bindir}/exspline
651 %attr(755,root,root) %{_bindir}/exsprite
652 %attr(755,root,root) %{_bindir}/exstars
653 %attr(755,root,root) %{_bindir}/exstream
654 %attr(755,root,root) %{_bindir}/exswitch
655 %attr(755,root,root) %{_bindir}/extimer
656 %attr(755,root,root) %{_bindir}/extrans
657 %attr(755,root,root) %{_bindir}/extruec
658 %attr(755,root,root) %{_bindir}/exunicod
659 %attr(755,root,root) %{_bindir}/exupdate
660 %attr(755,root,root) %{_bindir}/exxfade
661 %attr(755,root,root) %{_bindir}/exzbuf
This page took 0.135459 seconds and 2 git commands to generate.