]> git.pld-linux.org Git - packages/allegro.git/blob - allegro.spec
- 4.3.1
[packages/allegro.git] / allegro.spec
1 #
2 # TODO: Handle situations when there are no modules (most bconds turned off)
3 #
4 # Conditional build:
5 %bcond_without  alsa    # without ALSA modules
6 %bcond_without  arts    # without aRts module
7 %bcond_without  dga2    # without DGA2 module
8 %bcond_without  dbglib  # don't build debug versions of library
9 %bcond_without  esd     # without esound module
10 %bcond_without  fbcon   # without framebuffer module
11 %bcond_without  jack    # without JACK module
12 %bcond_without  proflib # don't debug profiling versions of library
13 %bcond_without  sse     # build without sse
14 %bcond_without  static  # don't build static versions of library
15 %bcond_without  svga    # without svgalib module
16 %bcond_without  vga     # without vga module
17 #
18 Summary:        A game programming library
19 Summary(de.UTF-8):      Eine Bibliothek zur Programmierung von Spielen
20 Summary(es.UTF-8):      Una biblioteca de programación de juegos
21 Summary(fr.UTF-8):      Une librairie de programmation de jeux
22 Summary(it.UTF-8):      Una libreria per la programmazione di videogiochi
23 Summary(pl.UTF-8):      Biblioteka do programowania gier
24 Name:           allegro
25 Version:        4.3.1
26 Release:        1
27 License:        Giftware
28 Group:          Libraries
29 Source0:        http://dl.sourceforge.net/alleg/%{name}-%{version}.tar.gz
30 # Source0-md5:  672fbeffb6a5d42600f2ba32b864fe73
31 Patch0:         %{name}-info.patch
32 Patch1:         %{name}-examples.patch
33 Patch2:         %{name}-opt.patch
34 Patch3:         %{name}-ldflags.patch
35 Patch4:         %{name}-frame-pointer.patch
36 Patch5:         %{name}-config.patch
37 URL:            http://alleg.sourceforge.net/
38 %{?with_alsa:BuildRequires:     alsa-lib-devel}
39 %{?with_arts:BuildRequires:     artsc-devel}
40 BuildRequires:  autoconf >= 2.53
41 BuildRequires:  automake
42 %{?with_esd:BuildRequires:      esound-devel}
43 %if %{with jack}
44 BuildRequires:  jack-audio-connection-kit-devel
45 BuildRequires:  pkgconfig
46 %endif
47 %{?with_svga:BuildRequires:     svgalib-devel}
48 BuildRequires:  texinfo
49 BuildRequires:  xorg-lib-libX11-devel
50 BuildRequires:  xorg-lib-libXcursor-devel
51 BuildRequires:  xorg-lib-libXext-devel
52 BuildRequires:  xorg-lib-libXpm-devel
53 BuildRequires:  xorg-lib-libXxf86dga-devel
54 BuildRequires:  xorg-lib-libXxf86vm-devel
55 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
56
57 %description
58 Allegro is a cross-platform library intended for use in computer games
59 and other types of multimedia programming.
60
61 %description -l de.UTF-8
62 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
63 Computerspielen und anderen Formen von Multinediaprogrammierung.
64
65 %description -l es.UTF-8
66 Allegro es una librería multi-plataforma creada para ser usada en la
67 programación de juegos u otro tipo de programación multimedia.
68
69 %description -l fr.UTF-8
70 Allegro est une librairie multi-plateforme destinée à être utilisée
71 dans les jeux vidéo ou d'autres types de programmation multimédia.
72
73 %description -l it.UTF-8
74 Allegro è una libreria multipiattaforma dedicata all'uso nei
75 videogiochi ed in altri tipi di programmazione multimediale.
76
77 %description -l pl.UTF-8
78 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
79 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
80
81 %package devel
82 Summary:        A game programming library - header files
83 Summary(es.UTF-8):      Archivos de inclusión
84 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
85 Group:          Development/Libraries
86 Requires:       %{name} = %{version}-%{release}
87
88 %description devel
89 Allegro is a cross-platform library intended for use in computer games
90 and other types of multimedia programming.
91
92 This package contains header files neccessary for compiling
93 applications using allegro library.
94
95 %description devel -l de.UTF-8
96 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
97 Computerspielen und anderen Formen von Multinediaprogrammierung.
98 Dieses Paket wird benötigt, um Programme zu bauen, die Allegro
99 verwenden.
100
101 %description devel -l es.UTF-8
102 Allegro es una librería multi-plataforma creada para ser usada en la
103 programación de juegos u otro tipo de programación multimedia. Este
104 paquete es necesario para compilar los programas que usen Allegro.
105
106 %description devel -l fr.UTF-8
107 Allegro est une librairie multi-plateforme destinée à être utilisée
108 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
109 package est nécessaire pour compiler les programmes utilisant Allegro.
110
111 %description devel -l it.UTF-8
112 Allegro è una libreria multipiattaforma dedicata all'uso nei
113 videogiochi ed in altri tipi di programmazione multimediale. Questo
114 pacchetto è necessario per compilare programmi scritti con Allegro.
115
116 %description devel -l pl.UTF-8
117 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
118 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
119
120 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
121 aplikacji wykorzystujących bibliotekę allegro.
122
123 %package static
124 Summary:        A game programming library - static libraries
125 Summary(pl.UTF-8):      Biblioteka do programowania gier - biblioteki statyczne
126 Group:          Development/Libraries
127 Requires:       %{name}-devel = %{version}-%{release}
128 Requires:       xorg-lib-libX11-devel
129 Requires:       xorg-lib-libXcursor-devel
130 Requires:       xorg-lib-libXext-devel
131 Requires:       xorg-lib-libXpm-devel
132 Requires:       xorg-lib-libXxf86vm-devel
133
134 %description static
135 Allegro is a cross-platform library intended for use in computer games
136 and other types of multimedia programming.
137
138 This package contains static libraries for linking with allegro
139 applications.
140
141 %description static -l pl.UTF-8
142 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
143 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
144
145 Ten pakiet zawiera biblioteki statyczne do konsolidacji z aplikacjami
146 wykorzystującymi allegro.
147
148 %package debug
149 Summary:        liballd - debug version of shared allegro library
150 Summary(pl.UTF-8):      liballd - wersja debug dzielonej biblioteki allegro
151 Group:          Development/Libraries
152 Requires:       %{name}-devel = %{version}-%{release}
153
154 %description debug
155 liballd - debug version of shared allegro library (contains debugging
156 symbols and other information).
157
158 %description debug -l pl.UTF-8
159 liballd - wersja debug dzielonej biblioteki allegro (zawierająca
160 symbole i inne informacje potrzebne przy odpluskwianiu).
161
162 %package debug-static
163 Summary:        liballd - debug version of static allegro library
164 Summary(pl.UTF-8):      liballd - wersja debug statycznej biblioteki allegro
165 Group:          Development/Libraries
166 Requires:       %{name}-devel = %{version}-%{release}
167
168 %description debug-static
169 liballd - debug version of static allegro library (contains debugging
170 symbols and other information).
171
172 %description debug-static -l pl.UTF-8
173 liballd - wersja debug statycznej biblioteki allegro (zawierająca
174 symbole i inne informacje potrzebne przy odpluskwianiu).
175
176 %package profile
177 Summary:        liballp - profiling version of shared allegro library
178 Summary(pl.UTF-8):      liballp - wersja dzielonej biblioteki allegro służąca do profilowania
179 Group:          Development/Libraries
180 Requires:       %{name}-devel = %{version}-%{release}
181
182 %description profile
183 liballp - profiling version of shared allegro library.
184
185 %description profile -l pl.UTF-8
186 liballp - wersja dzielonej biblioteki allegro służąca do profilowania.
187
188 %package profile-static
189 Summary:        liballp - profiling version of static allegro library
190 Summary(pl.UTF-8):      liballp - wersja statycznej biblioteki allegro służąca do profilowania
191 Group:          Development/Libraries
192 Requires:       %{name}-devel = %{version}-%{release}
193
194 %description profile-static
195 liballp - profiling version of static allegro library.
196
197 %description profile-static -l pl.UTF-8
198 liballp - wersja statycznej biblioteki allegro służąca do
199 profilowania.
200
201 %package svgalib
202 Summary:        A game programming library - svgalib module
203 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla svgalib
204 Group:          Libraries
205 Requires:       %{name} = %{version}-%{release}
206
207 %description svgalib
208 Allegro is a cross-platform library intended for use in computer games
209 and other types of multimedia programming.
210
211 This package contains module for use with allegro and svgalib.
212
213 %description svgalib -l pl.UTF-8
214 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
215 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
216
217 Ten pakiet zawiera moduł do wykorzystania allegro z svgalibem.
218
219 %package dga2
220 Summary:        A game programming library - DGA2 module
221 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla DGA2
222 Group:          Libraries
223 Requires:       %{name} = %{version}-%{release}
224
225 %description dga2
226 Allegro is a cross-platform library intended for use in computer games
227 and other types of multimedia programming.
228
229 This package contains module for use with DGA.
230
231 %description dga2 -l pl.UTF-8
232 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
233 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
234
235 Ten pakiet zawiera moduł do wykorzystania z DGA.
236
237 %package esd
238 Summary:        A game programming library - esound module
239 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla esound
240 Group:          Libraries
241 Requires:       %{name} = %{version}-%{release}
242
243 %description esd
244 Allegro is a cross-platform library intended for use in computer games
245 and other types of multimedia programming.
246
247 This package contains a esound module for use with ESound daemon.
248
249 %description esd -l pl.UTF-8
250 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
251 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
252
253 Ten pakiet zawiera moduł do wykorzystania z demonem ESound.
254
255 %package arts
256 Summary:        A game programming library - aRts module
257 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla aRts
258 Group:          Libraries
259 Requires:       %{name} = %{version}-%{release}
260
261 %description arts
262 Allegro is a cross-platform library intended for use in computer games
263 and other types of multimedia programming.
264
265 This package contains a esound module for use with aRts.
266
267 %description arts -l pl.UTF-8
268 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
269 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
270
271 Ten pakiet zawiera moduł do wykorzystania z aRts.
272
273 %package fbcon
274 Summary:        A game programming library - framebuffer module
275 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla framebuffera
276 Group:          Libraries
277 Requires:       %{name} = %{version}-%{release}
278
279 %description fbcon
280 Allegro is a cross-platform library intended for use in computer games
281 and other types of multimedia programming.
282
283 This package contains a esound module for use with framebuffer.
284
285 %description fbcon -l pl.UTF-8
286 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
287 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
288
289 Ten pakiet zawiera moduł do wykorzystania z framebufferem.
290
291 %package vga
292 Summary:        A game programming library - vga module
293 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla vga
294 Group:          Libraries
295 Requires:       %{name} = %{version}-%{release}
296
297 %description vga
298 Allegro is a cross-platform library intended for use in computer games
299 and other types of multimedia programming.
300
301 This package contains a esound module for use with vga.
302
303 %description vga -l pl.UTF-8
304 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
305 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
306
307 Ten pakiet zawiera moduł do wykorzystania z vga.
308
309 %package alsa
310 Summary:        A game programming library - ALSA modules
311 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduły dla ALSA
312 Group:          Libraries
313 Requires:       %{name} = %{version}-%{release}
314 Obsoletes:      allegro-alsa9
315
316 %description alsa
317 Allegro is a cross-platform library intended for use in computer games
318 and other types of multimedia programming.
319
320 This package contains modules for use with ALSA sound library.
321
322 %description alsa -l pl.UTF-8
323 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
324 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
325
326 Ten pakiet zawiera moduły do wykorzystania z biblioteką dźwiękową
327 ALSA.
328
329 %package jack
330 Summary:        A game programming library - JACK module
331 Summary(pl.UTF-8):      Biblioteka do programowania gier - moduł dla JACK-a
332 Group:          Libraries
333 Requires:       %{name} = %{version}-%{release}
334
335 %description jack
336 Allegro is a cross-platform library intended for use in computer games
337 and other types of multimedia programming.
338
339 This package contains module for use with JACK sound library.
340
341 %description jack -l pl.UTF-8
342 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
343 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
344
345 Ten pakiet zawiera moduł do wykorzystania z biblioteką dźwiękową JACK.
346
347 %package tools
348 Summary:        A game programming library - tools
349 Summary(de.UTF-8):      Zusätzliche Hilfprogramme für die Allegro Bibliothek
350 Summary(es.UTF-8):      Herramientas adicionales para la librería de programación Allegro
351 Summary(fr.UTF-8):      Outils supplémentaires pour la librairie de programmation Allegro
352 Summary(it.UTF-8):      Programmi di utilità aggiuntivi per la libreria Allegro
353 Summary(pl.UTF-8):      Biblioteka do programowania gier - narzędzia
354 Group:          Libraries
355 Requires:       %{name} = %{version}-%{release}
356
357 %description tools
358 Allegro is a cross-platform library intended for use in computer games
359 and other types of multimedia programming.
360
361 This package contains tools.
362
363 %description tools -l de.UTF-8
364 Allegro ist eine plattformübergreifende Bibliothek zur Verwendung in
365 Computerspielen und anderen Formen von Multinediaprogrammierung.
366 Dieses Paket enthält Programme, die für die Entwicklung von Allegro
367 Programmen hilfreich sind.
368
369 %description tools -l es.UTF-8
370 Allegro es una librería multi-plataforma creada para ser usada en la
371 programación de juegos u otro tipo de programación multimedia. Este
372 paquete contiene herramientas adicionales que son útiles para
373 desarrollar programas que usen Allegro.
374
375 %description tools -l fr.UTF-8
376 Allegro est une librairie multi-plateforme destinée à être utilisée
377 dans les jeux vidéo ou d'autres types de programmation multimédia. Ce
378 package contient des outils supplémentaires qui sont utiles pour le
379 développement de programmes avec Allegro.
380
381 %description tools -l it.UTF-8
382 Allegro è una libreria multipiattaforma dedicata all'uso nei
383 videogiochi ed in altri tipi di programmazione multimediale. Questo
384 pacchetto contiene programmi di utilità aggiuntivi utili allo sviluppo
385 di programmi con Allegro.
386
387 %description tools -l pl.UTF-8
388 Allegro jest przenośną biblioteką przeznaczoną do wykorzystania w
389 grach komputerowych i innych rodzajach oprogramowania multimedialnego.
390
391 Ten pakiet zawiera narzędzia.
392
393 %package tests
394 Summary:        A game programming library - test programs
395 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy testujące
396 Group:          Development/Libraries
397 Requires:       %{name} = %{version}-%{release}
398
399 %description tests
400 This package contains programs for testing allegro library.
401
402 %description tests -l pl.UTF-8
403 Pakiet zawiera programy testujące bibliotekę allegro.
404
405 %package examples
406 Summary:        A game programming library - examples
407 Summary(pl.UTF-8):      Biblioteka do programowania gier - programy przykładowe
408 Group:          Development/Libraries
409 Requires:       %{name} = %{version}-%{release}
410
411 %description examples
412 This package contains example programs which demonstrate allegro
413 features.
414
415 %description examples -l pl.UTF-8
416 Pakiet zawiera programy przykładowe demonstrujące możliwości
417 biblioteki allegro.
418
419 %prep
420 %setup -q
421 %patch0 -p1
422 %patch1 -p1
423 %patch2 -p1
424 %patch3 -p1
425 %patch4 -p1
426 %patch5 -p1
427
428 %build
429 %{__aclocal}
430 %{__autoheader} configure.in > include/allegro/platform/alunixac.hin
431 %{__autoconf}
432 #TARGET_ARCH="%{rpmcflags}" export TARGET_ARCH
433 # dbglib & proflib are compiled besides normlib, so it's ok to have them here
434 %configure \
435         %{?with_static:--enable-static} \
436         %{?with_dbglib:--enable-dbglib} \
437         %{?with_proflib:--enable-proflib} \
438 %if !%{with alsa}
439         --disable-alsadigi \
440         --disable-alsamidi \
441 %endif
442         %{!?with_arts:--disable-artsdigi} \
443         %{!?with_dga2:--disable-xwin-dga2} \
444         %{!?with_esd:--disable-esddigi} \
445         %{!?with_fbcon:--disable-fbcon} \
446         %{!?with_jack:--disable-jackdigi} \
447         %{!?with_svga:--disable-svgalib} \
448         %{!?with_vga:--disable-vga} \
449 %if !%{with sse}
450         --disable-sse \
451         --disable-asm \
452 %endif
453 %ifnarch %{ix86}
454         --disable-asm \
455         --disable-mmx \
456         --disable-sse
457 %endif
458
459 %{__make} \
460         MAKEINFO=makeinfo
461
462 %install
463 rm -rf $RPM_BUILD_ROOT
464
465 %{__make} install install-man install-info install-lib \
466         DESTDIR=$RPM_BUILD_ROOT
467
468 install modules.lst $RPM_BUILD_ROOT%{_libdir}/allegro/%{version}
469
470 mv $RPM_BUILD_ROOT%{_bindir}/demo{,-allegro}
471 mv $RPM_BUILD_ROOT%{_bindir}/play{,-allegro}
472 #mv $RPM_BUILD_ROOT%{_bindir}/setup{,-allegro}
473 mv $RPM_BUILD_ROOT%{_bindir}/test{,-allegro}
474
475 # help rpm to find reqs for ELF objects
476 chmod 755 $RPM_BUILD_ROOT%{_libdir}/{*.so,allegro/*/*.so}
477
478 %clean
479 rm -rf $RPM_BUILD_ROOT
480
481 %post   -p /sbin/ldconfig
482 %postun -p /sbin/ldconfig
483
484 %post devel
485 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
486
487 %postun devel
488 [ ! -x /usr/sbin/fix-info-dir ] || /usr/sbin/fix-info-dir %{_infodir} >/dev/null 2>&1
489
490 %files
491 %defattr(644,root,root,755)
492 %doc AUTHORS CHANGES THANKS readme.txt
493 %attr(755,root,root) %{_libdir}/liballeg-%{version}.so
494 %dir %{_libdir}/allegro
495 %dir %{_libdir}/allegro/%{version}
496 %{_libdir}/allegro/%{version}/modules.lst
497
498 %files devel
499 %defattr(644,root,root,755)
500 %attr(755,root,root) %{_bindir}/allegro-config
501 %{_libdir}/liballeg_unsharable.a
502 %{_includedir}/*
503 %{_aclocaldir}/allegro.m4
504 %{_mandir}/man3/*
505 %{_infodir}/*.info*
506
507 %if %{with static}
508 %files static
509 %defattr(644,root,root,755)
510 %{_libdir}/liballeg.a
511 %endif
512
513 %if %{with dbglib}
514 %files debug
515 %defattr(644,root,root,755)
516 %attr(755,root,root) %{_libdir}/liballd-%{version}.so
517 %{_libdir}/liballd_unsharable.a
518
519 %if %{with static}
520 %files debug-static
521 %defattr(644,root,root,755)
522 %{_libdir}/liballd.a
523 %endif
524 %endif
525
526 %if %{with proflib}
527 %files profile
528 %defattr(644,root,root,755)
529 %attr(755,root,root) %{_libdir}/liballp-%{version}.so
530 %{_libdir}/liballp_unsharable.a
531
532 %if %{with static}
533 %files profile-static
534 %defattr(644,root,root,755)
535 %{_libdir}/liballp.a
536 %endif
537 %endif
538
539 %if %{with svga}
540 %files svgalib
541 %defattr(644,root,root,755)
542 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-svgalib.so
543 %endif
544
545 %if %{with dga2}
546 %files dga2
547 %defattr(644,root,root,755)
548 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-dga2.so
549 %endif
550
551 %if %{with esd}
552 %files esd
553 %defattr(644,root,root,755)
554 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-esddigi.so
555 %endif
556
557 %if %{with arts}
558 %files arts
559 %defattr(644,root,root,755)
560 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-artsdigi.so
561 %endif
562
563 %if %{with fbcon}
564 %files fbcon
565 %defattr(644,root,root,755)
566 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-fbcon.so
567 %endif
568
569 %ifarch %{ix86}
570 %if %{with vga}
571 %files vga
572 %defattr(644,root,root,755)
573 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-vga.so
574 %endif
575 %endif
576
577 %if %{with alsa}
578 %files alsa
579 %defattr(644,root,root,755)
580 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsadigi.so
581 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-alsamidi.so
582 %endif
583
584 %if %{with jack}
585 %files jack
586 %defattr(644,root,root,755)
587 %attr(755,root,root) %{_libdir}/allegro/%{version}/alleg-jackdigi.so
588 %endif
589
590 %files tools
591 %defattr(644,root,root,755)
592 %attr(755,root,root) %{_bindir}/colormap
593 %attr(755,root,root) %{_bindir}/exedat
594 %attr(755,root,root) %{_bindir}/pack
595 %attr(755,root,root) %{_bindir}/rgbmap
596 %attr(755,root,root) %{_bindir}/textconv
597 #%attr(755,root,root) %{_bindir}/xkeymap
598 %attr(755,root,root) %{_bindir}/xf2pcx
599 %attr(755,root,root) %{_bindir}/dat
600 %attr(755,root,root) %{_bindir}/dat2c
601 %attr(755,root,root) %{_bindir}/dat2s
602 %attr(755,root,root) %{_bindir}/grabber
603 %attr(755,root,root) %{_bindir}/pat2dat
604 #%attr(755,root,root) %{_bindir}/setup-allegro
605
606 %files tests
607 %defattr(644,root,root,755)
608 %attr(755,root,root) %{_bindir}/afinfo
609 %attr(755,root,root) %{_bindir}/akaitest
610 %attr(755,root,root) %{_bindir}/cpptest
611 %attr(755,root,root) %{_bindir}/demo-allegro
612 %attr(755,root,root) %{_bindir}/digitest
613 %attr(755,root,root) %{_bindir}/filetest
614 %attr(755,root,root) %{_bindir}/gfxinfo
615 %attr(755,root,root) %{_bindir}/mathtest
616 %attr(755,root,root) %{_bindir}/miditest
617 %attr(755,root,root) %{_bindir}/play-allegro
618 %attr(755,root,root) %{_bindir}/playfli
619 %attr(755,root,root) %{_bindir}/test-allegro
620 %attr(755,root,root) %{_bindir}/vesainfo
621
622 %files examples
623 %defattr(644,root,root,755)
624 %attr(755,root,root) %{_bindir}/ex12bit
625 %attr(755,root,root) %{_bindir}/ex3buf
626 %attr(755,root,root) %{_bindir}/ex3d
627 %attr(755,root,root) %{_bindir}/exaccel
628 %attr(755,root,root) %{_bindir}/exalpha
629 %attr(755,root,root) %{_bindir}/exbitmap
630 %attr(755,root,root) %{_bindir}/exblend
631 %attr(755,root,root) %{_bindir}/excamera
632 %attr(755,root,root) %{_bindir}/excolmap
633 %attr(755,root,root) %{_bindir}/exconfig
634 %attr(755,root,root) %{_bindir}/excustom
635 %attr(755,root,root) %{_bindir}/exdata
636 %attr(755,root,root) %{_bindir}/exdbuf
637 %attr(755,root,root) %{_bindir}/exexedat
638 %attr(755,root,root) %{_bindir}/exfixed
639 %attr(755,root,root) %{_bindir}/exflame
640 %attr(755,root,root) %{_bindir}/exflip
641 %attr(755,root,root) %{_bindir}/exfont
642 %attr(755,root,root) %{_bindir}/exgui
643 %attr(755,root,root) %{_bindir}/exhello
644 %attr(755,root,root) %{_bindir}/exjoy
645 %attr(755,root,root) %{_bindir}/exkeys
646 %attr(755,root,root) %{_bindir}/exlights
647 %attr(755,root,root) %{_bindir}/exmem
648 %attr(755,root,root) %{_bindir}/exmidi
649 %attr(755,root,root) %{_bindir}/exmouse
650 %attr(755,root,root) %{_bindir}/expackf
651 %attr(755,root,root) %{_bindir}/expal
652 %attr(755,root,root) %{_bindir}/expat
653 %attr(755,root,root) %{_bindir}/exquat
654 %attr(755,root,root) %{_bindir}/exrgbhsv
655 %attr(755,root,root) %{_bindir}/exsample
656 %attr(755,root,root) %{_bindir}/exsyscur
657 %attr(755,root,root) %{_bindir}/exscale
658 %attr(755,root,root) %{_bindir}/exscn3d
659 %attr(755,root,root) %{_bindir}/exscroll
660 %attr(755,root,root) %{_bindir}/exshade
661 %attr(755,root,root) %{_bindir}/exspline
662 %attr(755,root,root) %{_bindir}/exsprite
663 %attr(755,root,root) %{_bindir}/exstars
664 %attr(755,root,root) %{_bindir}/exstream
665 %attr(755,root,root) %{_bindir}/exswitch
666 %attr(755,root,root) %{_bindir}/extimer
667 %attr(755,root,root) %{_bindir}/extrans
668 %attr(755,root,root) %{_bindir}/extruec
669 %attr(755,root,root) %{_bindir}/exunicod
670 %attr(755,root,root) %{_bindir}/exupdate
671 %attr(755,root,root) %{_bindir}/exxfade
672 %attr(755,root,root) %{_bindir}/exzbuf
673 %attr(755,root,root) %{_bindir}/exnew_events
This page took 0.146201 seconds and 3 git commands to generate.