]> git.pld-linux.org Git - packages/allegro-gl.git/blob - allegro-gl.spec
- new URL
[packages/allegro-gl.git] / allegro-gl.spec
1 Summary:        The Allegro game programming library GL backend
2 Summary(pl.UTF-8):      Wsparcie GL dla biblioteki do programowania gier Allegro
3 Name:           allegro-gl
4 Version:        0.4.3
5 Release:        1
6 License:        GPL v2 or zlib
7 Group:          Libraries
8 Source0:        http://dl.sourceforge.net/allegrogl/alleggl-%{version}.tar.bz2
9 # Source0-md5:  de84c6ab982499501940854893ea0dbd
10 Patch0:         %{name}-mouse.patch
11 Patch1:         %{name}-link.patch
12 Patch2:         %{name}-libpthread.patch
13 URL:            http://sourceforge.net/projects/allegrogl/
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  allegro-devel >= 4.3.1
16 BuildRequires:  autoconf >= 2.53
17 BuildRequires:  automake
18 Requires:       allegro >= 4.3.1
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %define         specflags       -fomit-frame-pointer
22
23 %description
24 AllegroGL is a cross-platform GL backend for the Allegro library.
25
26 %description -l pl.UTF-8
27 AllegroGL jest przenośną biblioteką dodającą wsparcie GL
28 w aplikacjach używających biblioteki Allegro.
29
30 %package devel
31 Summary:        A game programming library - header files
32 Summary(pl.UTF-8):      Biblioteka do programowania gier - pliki nagłówkowe
33 Group:          Development/Libraries
34 Requires:       %{name} = %{version}-%{release}
35 Requires:       allegro-devel >= 4.3.1
36
37 %description devel
38 AllegroGL is a cross-platform GL backend for the Allegro library.
39
40 This package contains header files neccessary for compiling
41 applications using AllegroGL library.
42
43 %description devel -l pl.UTF-8
44 AllegroGL jest przenośną biblioteką dodającą wsparcie GL
45 w aplikacjach używających biblioteki Allegro.
46
47 Ten pakiet zawiera pliki nagłówkowe niezbędne do kompilowania
48 aplikacji wykorzystujących bibliotekę AllegroGL.
49
50 %prep
51 %setup -q -n alleggl
52 %patch0 -p1
53 %patch1 -p1
54 %patch2 -p1
55
56 %build
57 %{__aclocal}
58 %{__autoconf}
59 %configure \
60         --enable-static \
61 %ifnarch %{ix86}
62         --disable-asm \
63         --disable-mmx \
64         --disable-sse
65 %endif
66
67 %{__make} lib \
68         CFLAGS="%{rpmcflags} -Wall -ffast-math"
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72 install -d $RPM_BUILD_ROOT{%{_libdir},%{_includedir}/allegrogl/GLext}
73
74 install include/alleggl*.h $RPM_BUILD_ROOT%{_includedir}
75 install include/allegrogl/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl
76 install include/allegrogl/GLext/*.h $RPM_BUILD_ROOT%{_includedir}/allegrogl/GLext
77 install lib/unix/libagl.so $RPM_BUILD_ROOT%{_libdir}
78
79 %clean
80 rm -rf $RPM_BUILD_ROOT
81
82 %post   -p /sbin/ldconfig
83 %postun -p /sbin/ldconfig
84
85 %files
86 %defattr(644,root,root,755)
87 %doc bugs.txt readme.txt todo.txt zlib.txt
88 %attr(755,root,root) %{_libdir}/libagl.so
89
90 %files devel
91 %defattr(644,root,root,755)
92 %doc howto.txt
93 %{_includedir}/alleggl*.h
94 %{_includedir}/allegrogl
This page took 0.05847 seconds and 3 git commands to generate.