]> git.pld-linux.org Git - packages/alienarena2007.git/blob - alienarena2007.spec
a433b411365206ac05113d899c57b9d7026aa870
[packages/alienarena2007.git] / alienarena2007.spec
1 %define         relyear         2007
2 %define         dateversion     20070613
3 #
4 Summary:        Alien Arena - freeware online deathmatch FPS game
5 Summary(pl.UTF-8):      Alien Arena - darmowa gra sieciowa typu FPS deathmatch
6 Name:           alienarena%{relyear}
7 Version:        6.10
8 Release:        0.1
9 License:        GPL
10 Group:          X11/Applications/Games
11 Source0:        http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/%{name}-%{dateversion}-linux.zip
12 # Source0-md5:  65d2948fa636cbc28c82da2264df2fea
13 URL:            http://red.planetarena.org/
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  dos2unix
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRequires:  xorg-lib-libXext-devel
21 BuildRequires:  xorg-lib-libXxf86dga-devel
22 BuildRequires:  xorg-lib-libXxf86vm-devel
23 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
24
25 %description
26 ALIEN ARENA is a standalone 3D first person online deathmatch shooter
27 crafted from the original source code of Quake II and Quake III,
28 released by id Software under the GPL license. With features including
29 32-bit graphics, new particle engine and effects, light blooms,
30 reflective water, hi resolution textures and skins, hi poly models,
31 stain maps, ALIEN ARENA pushes the envelope of graphical beauty
32 rivaling today's top games.
33
34 The game features 37 levels, which can be played online against other
35 players, or against the built in CodeRED bots.
36
37 Alien Arena offers CTF, AOA (All Out Assault) mode, in which players
38 can climb into vehicles to do battle, Deathball, and Team Core
39 Assault. Simply go into the multiplayer menu to start a server, change
40 the game rules, and choose a map to play on. You can also select from
41 five different mutators (instagib, rocket arena, excessive, low grav,
42 regen, and vampire) to further customize your game experience.
43
44 %description -l pl.UTF-8
45 ALIEN ARENA to samodzielna trójwymiarowa strzelanina online FPP z
46 trybem deathmatch, wywodząca się z oryginalnego kodu źródłowego Quake
47 II i Quake III, wydanego przez id Software na licencji GPL. Z cechami
48 obejmującymi 32-bitową grafikę, nowy silnik i efekty, światła,
49 odbijającą wodę, wysokiej rozdzielczości tekstury i skórki, modele z
50 dużej liczby wielokątów, mapy plam ALIEN ARENA dorównuje graficznemu
51 pięknu dzisiejszych wiodących gier.
52
53 Gra zawiera 37 poziomów, w które można grać online przeciwko innym
54 graczom lub wbudowanym botom CodeRED.
55
56 Alien Arena ofertuje tryby: CTF, AOA (All Out Assault), w którym
57 gracze mogą wchodzić na pojazdy uczestnicząc w bitwach, Deathball i
58 Team Core Assault. Wystarczy w menu gry dla wielu graczy uruchomić
59 serwer, zmienić zasady gry i wybrać mapę. Można także wybrać jedną z
60 pięciu różnych modyfikacji (instagib, rocket arena, excessive, low
61 grav, regen i vampire) aby jeszcze bardziej zmieniać doznania graczy.
62
63 %package server
64 Summary:        Alien Arena - server
65 Summary(pl.UTF-8):      Alien Arena - serwer
66 Group:          X11/Applications/Games
67 Requires(post,preun):   /sbin/chkconfig
68
69 %description server
70 The dedicated server for Alien Arena.
71
72 %description server -l pl.UTF-8
73 Dedykowany serwer dla gry Alien Arena.
74
75 %package data
76 Summary:        Alien Arena - the data, botinfo, and arena files
77 Summary(pl.UTF-8):      Alien Arena - pliki danych i botinfo
78 Group:          X11/Applications/Games
79
80 %description data
81 This package installs the data, botinfo, and arena files needed to run
82 Alien Arena.
83
84 %description data -l pl.UTF-8
85 Ten pakiet instaluje pliki danych i botinfo potrzebne do uruchomienia
86 gry Alien Arena.
87
88 %prep
89 %setup -q -n %{name}
90 rm -f ../GH3D.txt ../GamersHell.url
91
92 for file in lst cfg txt html lng h c ; do
93         find ./ -noleaf -type f -name \*.$file -exec dos2unix '{}' \;
94 done
95
96 %build
97 %{__make} \
98         CC="%{__cc}" \
99         RELEASE_CFLAGS='$(BASE_CFLAGS) %{rpmcflags}' \
100         X11BASE=/usr \
101         LOCALBASE=/usr \
102         _LIB=%{_lib}
103
104 %install
105 rm -rf $RPM_BUILD_ROOT
106
107 %{__make} install \
108         DESTDIR=$RPM_BUILD_ROOT
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post server
114 /sbin/chkconfig --add %{name}
115 %service %{name} restart
116
117 %preun server
118 if [ "$1" = "0" ]; then
119         %service -q %{name} stop
120         /sbin/chkconfig --del %{name}
121 fi
122
123 %files
124 %defattr(644,root,root,755)
125 %doc changelog README
126 %lang(nl) %doc docs/AA Dutch.txt
127 %lang(fr) %doc docs/AA French.txt
128 %lang(de) %doc docs/AA German.txt
129 %lang(el) %doc docs/AA Greek.txt
130 %lang(hu) %doc docs/AA Hungarian.txt
131 %lang(it) %doc docs/AA Italian.txt
132 %lang(pl) %doc docs/AA Polish.txt
133 %lang(pt) %doc docs/AA Portuguese.txt
134 %lang(ru) %doc docs/AA Russian.txt
135 %lang(es) %doc docs/AA_ES.txt
136 %attr(755,root,root) %{_bindir}/alien-arena
137 %{_desktopdir}/alien-arena.desktop
138 %{_pixmapsdir}/alien-arena.xpm
139
140 %files data
141 %defattr(644,root,root,755)
142
143 %files server
144 %defattr(644,root,root,755)
145 %attr(754,root,root) /etc/rc.d/init.d/%{name}
146 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
147 %attr(755,root,root) %{_bindir}/alien-arena-server
148 alien-arena/crded
149 alien-arena/kill-runaway-crded
150 alien-arena/launch-server
151 alien-arena/rcon
152 alien-arena/svstat
153 %{_mandir}/man6/alien-arena-server.6*
This page took 0.060872 seconds and 2 git commands to generate.