]> git.pld-linux.org Git - packages/alienarena2007.git/blob - alienarena2007.spec
- BR: unzip
[packages/alienarena2007.git] / alienarena2007.spec
1 %define         relyear         2007
2 %define         dateversion     20070613
3 #
4 Summary:        Alien Arena - freeware online deathmatch FPS game
5 Summary(pl.UTF-8):      Alien Arena - darmowa gra sieciowa typu FPS deathmatch
6 Name:           alienarena%{relyear}
7 Version:        6.10
8 Release:        0.1
9 License:        GPL
10 Group:          X11/Applications/Games
11 Source0:        http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/%{name}-%{dateversion}-linux.zip
12 # Source0-md5:  65d2948fa636cbc28c82da2264df2fea
13 URL:            http://red.planetarena.org/
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  dos2unix
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 BuildRequires:  unzip
20 BuildRequires:  xorg-lib-libX11-devel
21 BuildRequires:  xorg-lib-libXext-devel
22 BuildRequires:  xorg-lib-libXxf86dga-devel
23 BuildRequires:  xorg-lib-libXxf86vm-devel
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %description
27 ALIEN ARENA is a standalone 3D first person online deathmatch shooter
28 crafted from the original source code of Quake II and Quake III,
29 released by id Software under the GPL license. With features including
30 32-bit graphics, new particle engine and effects, light blooms,
31 reflective water, hi resolution textures and skins, hi poly models,
32 stain maps, ALIEN ARENA pushes the envelope of graphical beauty
33 rivaling today's top games.
34
35 The game features 37 levels, which can be played online against other
36 players, or against the built in CodeRED bots.
37
38 Alien Arena offers CTF, AOA (All Out Assault) mode, in which players
39 can climb into vehicles to do battle, Deathball, and Team Core
40 Assault. Simply go into the multiplayer menu to start a server, change
41 the game rules, and choose a map to play on. You can also select from
42 five different mutators (instagib, rocket arena, excessive, low grav,
43 regen, and vampire) to further customize your game experience.
44
45 %description -l pl.UTF-8
46 ALIEN ARENA to samodzielna trójwymiarowa strzelanina online FPP z
47 trybem deathmatch, wywodząca się z oryginalnego kodu źródłowego Quake
48 II i Quake III, wydanego przez id Software na licencji GPL. Z cechami
49 obejmującymi 32-bitową grafikę, nowy silnik i efekty, światła,
50 odbijającą wodę, wysokiej rozdzielczości tekstury i skórki, modele z
51 dużej liczby wielokątów, mapy plam ALIEN ARENA dorównuje graficznemu
52 pięknu dzisiejszych wiodących gier.
53
54 Gra zawiera 37 poziomów, w które można grać online przeciwko innym
55 graczom lub wbudowanym botom CodeRED.
56
57 Alien Arena ofertuje tryby: CTF, AOA (All Out Assault), w którym
58 gracze mogą wchodzić na pojazdy uczestnicząc w bitwach, Deathball i
59 Team Core Assault. Wystarczy w menu gry dla wielu graczy uruchomić
60 serwer, zmienić zasady gry i wybrać mapę. Można także wybrać jedną z
61 pięciu różnych modyfikacji (instagib, rocket arena, excessive, low
62 grav, regen i vampire) aby jeszcze bardziej zmieniać doznania graczy.
63
64 %package server
65 Summary:        Alien Arena - server
66 Summary(pl.UTF-8):      Alien Arena - serwer
67 Group:          X11/Applications/Games
68 Requires(post,preun):   /sbin/chkconfig
69
70 %description server
71 The dedicated server for Alien Arena.
72
73 %description server -l pl.UTF-8
74 Dedykowany serwer dla gry Alien Arena.
75
76 %package data
77 Summary:        Alien Arena - the data, botinfo, and arena files
78 Summary(pl.UTF-8):      Alien Arena - pliki danych i botinfo
79 Group:          X11/Applications/Games
80
81 %description data
82 This package installs the data, botinfo, and arena files needed to run
83 Alien Arena.
84
85 %description data -l pl.UTF-8
86 Ten pakiet instaluje pliki danych i botinfo potrzebne do uruchomienia
87 gry Alien Arena.
88
89 %prep
90 %setup -q -n %{name}
91 rm -f ../GH3D.txt ../GamersHell.url
92
93 for file in lst cfg txt html lng h c ; do
94         find ./ -noleaf -type f -name \*.$file -exec dos2unix '{}' \;
95 done
96
97 %build
98 %{__make} \
99         CC="%{__cc}" \
100         RELEASE_CFLAGS='$(BASE_CFLAGS) %{rpmcflags}' \
101         X11BASE=%{_prefix} \
102         LOCALBASE=%{_prefix} \
103         _LIB=%{_lib}
104
105 %install
106 rm -rf $RPM_BUILD_ROOT
107
108 %{__make} install \
109         DESTDIR=$RPM_BUILD_ROOT
110
111 %clean
112 rm -rf $RPM_BUILD_ROOT
113
114 %post server
115 /sbin/chkconfig --add %{name}
116 %service %{name} restart
117
118 %preun server
119 if [ "$1" = "0" ]; then
120         %service -q %{name} stop
121         /sbin/chkconfig --del %{name}
122 fi
123
124 %files
125 %defattr(644,root,root,755)
126 %doc changelog README
127 %lang(nl) %doc docs/AA Dutch.txt
128 %lang(fr) %doc docs/AA French.txt
129 %lang(de) %doc docs/AA German.txt
130 %lang(el) %doc docs/AA Greek.txt
131 %lang(hu) %doc docs/AA Hungarian.txt
132 %lang(it) %doc docs/AA Italian.txt
133 %lang(pl) %doc docs/AA Polish.txt
134 %lang(pt) %doc docs/AA Portuguese.txt
135 %lang(ru) %doc docs/AA Russian.txt
136 %lang(es) %doc docs/AA_ES.txt
137 %attr(755,root,root) %{_bindir}/alien-arena
138 %{_desktopdir}/alien-arena.desktop
139 %{_pixmapsdir}/alien-arena.xpm
140
141 %files data
142 %defattr(644,root,root,755)
143
144 %files server
145 %defattr(644,root,root,755)
146 %attr(754,root,root) /etc/rc.d/init.d/%{name}
147 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
148 %attr(755,root,root) %{_bindir}/alien-arena-server
149 alien-arena/crded
150 alien-arena/kill-runaway-crded
151 alien-arena/launch-server
152 alien-arena/rcon
153 alien-arena/svstat
154 %{_mandir}/man6/alien-arena-server.6*
This page took 0.084012 seconds and 3 git commands to generate.