]> git.pld-linux.org Git - packages/alienarena2007.git/blob - alienarena2007.spec
- pl
[packages/alienarena2007.git] / alienarena2007.spec
1 %define         relyear         2007
2 %define         dateversion     20070613
3 #
4 Summary:        Alien Arena - freeware online deathmatch FPS game
5 Summary(pl.UTF-8):      Alien Arena - darmowa gra sieciowa typu FPS deathmatch
6 Name:           alienarena%{relyear}
7 Version:        6.10
8 Release:        0.1
9 License:        GPL
10 Group:          X11/Applications/Games
11 Source0:        http://gd.tuwien.ac.at/opsys/linux/gentoo/distfiles/%{name}-%{dateversion}-linux.zip
12 # Source0-md5:  65d2948fa636cbc28c82da2264df2fea
13 URL:            http://red.planetarena.org/
14 BuildRequires:  OpenGL-GLU-devel
15 BuildRequires:  SDL-devel
16 BuildRequires:  dos2unix
17 BuildRequires:  libjpeg-devel
18 BuildRequires:  rpmbuild(macros) >= 1.228
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRequires:  xorg-lib-libXext-devel
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %description
24 ALIEN ARENA is a standalone 3D first person online deathmatch shooter
25 crafted from the original source code of Quake II and Quake III,
26 released by id Software under the GPL license. With features including
27 32-bit graphics, new particle engine and effects, light blooms,
28 reflective water, hi resolution textures and skins, hi poly models,
29 stain maps, ALIEN ARENA pushes the envelope of graphical beauty
30 rivaling today's top games.
31
32 The game features 37 levels, which can be played online against other
33 players, or against the built in CodeRED bots.
34
35 Alien Arena offers CTF, AOA (All Out Assault) mode, in which players
36 can climb into vehicles to do battle, Deathball, and Team Core
37 Assault. Simply go into the multiplayer menu to start a server, change
38 the game rules, and choose a map to play on. You can also select from
39 five different mutators (instagib, rocket arena, excessive, low grav,
40 regen, and vampire) to further customize your game experience.
41
42 %description -l pl.UTF-8
43 ALIEN ARENA to samodzielna trójwymiarowa strzelanina online FPP z
44 trybem deathmatch, wywodząca się z oryginalnego kodu źródłowego Quake
45 II i Quake III, wydanego przez id Software na licencji GPL. Z cechami
46 obejmującymi 32-bitową grafikę, nowy silnik i efekty, światła,
47 odbijającą wodę, wysokiej rozdzielczości tekstury i skórki, modele z
48 dużej liczby wielokątów, mapy plam ALIEN ARENA dorównuje graficznemu
49 pięknu dzisiejszych wiodących gier.
50
51 Gra zawiera 37 poziomów, w które można grać online przeciwko innym
52 graczom lub wbudowanym botom CodeRED.
53
54 Alien Arena ofertuje tryby: CTF, AOA (All Out Assault), w którym
55 gracze mogą wchodzić na pojazdy uczestnicząc w bitwach, Deathball i
56 Team Core Assault. Wystarczy w menu gry dla wielu graczy uruchomić
57 serwer, zmienić zasady gry i wybrać mapę. Można także wybrać jedną z
58 pięciu różnych modyfikacji (instagib, rocket arena, excessive, low
59 grav, regen i vampire) aby jeszcze bardziej zmieniać doznania graczy.
60
61 %package server
62 Summary:        Alien Arena - server
63 Summary(pl.UTF-8):      Alien Arena - serwer
64 Group:          X11/Applications/Games
65 Requires(post,preun):   /sbin/chkconfig
66
67 %description server
68 The dedicated server for Alien Arena.
69
70 %description server -l pl.UTF-8
71 Dedykowany serwer dla gry Alien Arena.
72
73 %package data
74 Summary:        Alien Arena - the data, botinfo, and arena files
75 Summary(pl.UTF-8):      Alien Arena - pliki danych i botinfo
76 Group:          X11/Applications/Games
77
78 %description data
79 This package installs the data, botinfo, and arena files needed to run
80 Alien Arena.
81
82 %description data -l pl.UTF-8
83 Ten pakiet instaluje pliki danych i botinfo potrzebne do uruchomienia
84 gry Alien Arena.
85
86 %prep
87 %setup -q -n %{name}
88 rm -f ../GH3D.txt ../GamersHell.url
89
90 for file in lst cfg txt html lng h c ; do
91         find ./ -noleaf -type f -name \*.$file -exec dos2unix '{}' \;
92 done
93
94 %build
95 %{__make} \
96         CFLAGS="%{rpmcflags} -ldl" \
97         LDFLAGS="%{rpmldflags}"
98
99 %install
100 rm -rf $RPM_BUILD_ROOT
101
102 %{__make} install \
103         DESTDIR=$RPM_BUILD_ROOT
104
105 %clean
106 rm -rf $RPM_BUILD_ROOT
107
108 %post server
109 /sbin/chkconfig --add %{name}
110 %service %{name} restart
111
112 %preun server
113 if [ "$1" = "0" ]; then
114         %service -q %{name} stop
115         /sbin/chkconfig --del %{name}
116 fi
117
118 %files
119 %defattr(644,root,root,755)
120 %doc changelog README
121 %lang(nl) %doc docs/AA Dutch.txt
122 %lang(fr) %doc docs/AA French.txt
123 %lang(de) %doc docs/AA German.txt
124 %lang(el) %doc docs/AA Greek.txt
125 %lang(hu) %doc docs/AA Hungarian.txt
126 %lang(it) %doc docs/AA Italian.txt
127 %lang(pl) %doc docs/AA Polish.txt
128 %lang(pt) %doc docs/AA Portuguese.txt
129 %lang(ru) %doc docs/AA Russian.txt
130 %lang(es) %doc docs/AA_ES.txt
131 %attr(755,root,root) %{_bindir}/alien-arena
132 %{_desktopdir}/alien-arena.desktop
133 %{_pixmapsdir}/alien-arena.xpm
134
135 %files data
136 %defattr(644,root,root,755)
137
138 %files server
139 %defattr(644,root,root,755)
140 # XXX: dup
141 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/*
142 %attr(754,root,root) /etc/rc.d/init.d/%{name}
143 %config(noreplace) %verify(not md5 mtime size) /etc/sysconfig/%{name}
144 %attr(755,root,root) %{_bindir}/alien-arena-server
145 alien-arena/crded
146 alien-arena/kill-runaway-crded
147 alien-arena/launch-server
148 alien-arena/rcon
149 alien-arena/svstat
150 %{_mandir}/man6/alien-arena-server.6*
This page took 0.087582 seconds and 3 git commands to generate.