]> git.pld-linux.org Git - packages/alarmwatch.git/blob - alarmwatch.spec
- spelling fix
[packages/alarmwatch.git] / alarmwatch.spec
1 Summary:        Daemon that watches lm_sensors and beeps on alarms
2 Summary(pl):    Demon kontroluj±cy stan lm_sensors i piszcz±cy podczas alarmów
3 Name:           alarmwatch
4 Version:        1.0
5 Release:        1
6 License:        GPL
7 Group:          Daemons
8 Source0:        http://www.azstarnet.com/~donut/programs/alarmwatch/%{name}-%{version}.tar.gz
9 # Source0-md5:  8a905a4746fdb028257af842afe748db
10 Source1:        %{name}.init
11 Source2:        %{name}.sysconfig
12 URL:            http://www.azstarnet.com/~donut/programs/alarmwatch.html
13 BuildRequires:  autoconf
14 PreReq:         rc-scripts
15 Requires(post,preun):   /sbin/chkconfig
16 Requires:       lm_sensors
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %description
20 alarmwatch watches the lm_sensors /proc filesystem for the chips you
21 specify, and alerts you by beeping and syslog messages when an alarm
22 that is not ignored is active.
23
24 %description -l pl
25 alarmwatch kontroluje stan wybranych uk³adów poprzez lm_sensors w
26 systemie plików /proc i ostrzega piskami oraz komunikatami w logach,
27 kiedy nie ignorowany alarm jest aktywny.
28
29 %prep
30 %setup -q
31
32 %build
33 %{__autoconf}
34 %configure
35
36 %{__make}
37
38 %install
39 rm -rf $RPM_BUILD_ROOT
40 install -d $RPM_BUILD_ROOT{%{_sbindir},%{_mandir}/man8} \
41         $RPM_BUILD_ROOT/etc/{rc.d/init.d,sysconfig}
42
43 install alarmwatch $RPM_BUILD_ROOT%{_sbindir}
44 sed -e 's@alarmwatch 1@alarmwatch 8@' alarmwatch.1 \
45         > $RPM_BUILD_ROOT%{_mandir}/man8/alarmwatch.8
46
47 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/alarmwatch
48 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/alarmwatch
49
50 %clean
51 rm -rf $RPM_BUILD_ROOT
52
53 %post
54 /sbin/chkconfig --add alarmwatch
55 if [ -f /var/lock/subsys/alarmwatch ]; then
56         /etc/rc.d/init.d/gpm alarmwatch >&2
57 else
58         echo "Run \"/etc/rc.d/init.d/alarmwatch start\" to start alarmwatch daemon."
59         echo "Remember to configure it first!"
60 fi
61
62 %preun
63 if [ "$1" = "0" ]; then
64         if [ -f /var/lock/subsys/alarmwatch ]; then
65                 /etc/rc.d/init.d/alarmwatch stop >&2
66         fi
67         /sbin/chkconfig --del alarmwatch
68 fi
69
70 %files
71 %defattr(644,root,root,755)
72 %doc README Changelog
73 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/alarmwatch
74 %attr(754,root,root) /etc/rc.d/init.d/alarmwatch
75 %attr(755,root,root) %{_sbindir}/*
76 %{_mandir}/man8/*
This page took 0.074977 seconds and 3 git commands to generate.