]> git.pld-linux.org Git - packages/aircrack-ng.git/blob - aircrack-ng.spec
a72f8d82a3f2150f259c30046fe1a06756af190c
[packages/aircrack-ng.git] / aircrack-ng.spec
1 #
2 # TODO:
3 # - PLD it more
4 # - Find more deps
5 # - sbin/bin - change to bin?
6 # - package airdrop-ng and airgraph-ng
7 #
8 # Conditional build:
9 %bcond_without  sqlite                  # build without sqlite support
10 %bcond_without  pcre                    # build without pcre support
11 %bcond_without  experimental
12 %bcond_with     ext_scripts             # build with extra scripts (NFY)
13 #
14 Summary:        Reliable 802.11 (wireless) sniffer and WEP/WPA-PSK key cracker
15 Summary(pl.UTF-8):      Pewny sniffer 802.11 (sieci bezprzewodowe) i łamacz kluczy WEP/WPA-PSK
16 Name:           aircrack-ng
17 Version:        1.2
18 %define subver  rc2
19 %define rel     0.1
20 Release:        %{subver}.%{rel}
21 License:        GPL
22 Group:          Applications/Networking
23 Source0:        http://download.aircrack-ng.org/%{name}-%{version}-%{subver}.tar.gz
24 # Source0-md5:  ebe9d537f06f4d6956213af09c4476da
25 URL:            http://www.aircrack-ng.org/
26 Patch0:         install.patch
27 Patch1:         pldflags.patch
28 BuildRequires:  libnl-devel
29 BuildRequires:  openssl-devel
30 BuildRequires:  pkgconfig
31 %{?with_pcre:BuildRequires:     pcre-devel}
32 %{?with_sqlite:BuildRequires:   sqlite3-devel}
33 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
34
35 %description
36 aircrack-ng is a set of tools for auditing wireless networks. It's an
37 enhanced/reborn version of aircrack. It consists of airodump-ng (an
38 802.11 packet capture program), aireplay-ng (an 802.11 packet
39 injection program), aircrack (static WEP and WPA-PSK cracking),
40 airdecap-ng (decrypts WEP/WPA capture files), and some tools to handle
41 capture files (merge, convert, etc.).
42
43 %description -l pl.UTF-8
44 aircrack-ng jest zestawem narzędzi do audytów sieci bezprzewodowych.
45 Jest to ulepszona/odnowiona wersja aircracka. Składa sie z programów
46 airodump-ng (do przechwytywania pakietów 802.11), aireplay-ng (do
47 wstrzykiwania pakietów 802.11), aircrack (do statycznego łamania WEP i
48 WPA-PSK), airdecap-ng (do odszyfrowywania przechwyconych plików
49 WEP/WPA) i paru narzędzi do obsługi plików przechwytów (merge,
50 convert, etc.).
51
52 %prep
53 %setup -q -n %{name}-%{version}-%{subver}
54 %patch0 -p1
55 %patch1 -p1
56
57 %build
58 %{__make} -j1 \
59         %{?with_experimental: experimental=true} \
60         %{?with_ext_scripts: ext_scripts=true} \
61         %{?with_pcre: pcre=true} \
62         %{?with_sqlite: sqlite=true} \
63         CC="%{__cc}" \
64         PLDFLAGS="%{rpmcppflags} %{rpmcflags}"
65
66 %install
67 rm -rf $RPM_BUILD_ROOT
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1}
69
70 %{__make} install \
71         %{?with_experimental: experimental=true} \
72         %{?with_ext_scripts: ext_scripts=true} \
73         %{?with_pcre: pcre=true} \
74         %{?with_sqlite: sqlite=true} \
75         prefix=%{_prefix} \
76         DESTDIR=$RPM_BUILD_ROOT
77
78 %clean
79 rm -rf $RPM_BUILD_ROOT
80
81 %files
82 %defattr(644,root,root,755)
83 %doc AUTHORS ChangeLog README test patches
84 %attr(755,root,root) %{_bindir}/aircrack-ng
85 %attr(755,root,root) %{_bindir}/airdecap-ng
86 %attr(755,root,root) %{_bindir}/airdecloak-ng
87 %{?with_sqlite:%attr(755,root,root) %{_bindir}/airolib-ng}
88 %attr(755,root,root) %{_bindir}/ivstools
89 %attr(755,root,root) %{_bindir}/kstats
90 %attr(755,root,root) %{_bindir}/makeivs-ng
91 %attr(755,root,root) %{_bindir}/packetforge-ng
92 %attr(755,root,root) %{_bindir}/wpaclean
93 %attr(755,root,root) %{_sbindir}/airbase-ng
94 %attr(755,root,root) %{_sbindir}/aireplay-ng
95 %attr(755,root,root) %{_sbindir}/airmon-ng
96 %attr(755,root,root) %{_sbindir}/airodump-ng
97 %attr(755,root,root) %{_sbindir}/airodump-ng-oui-update
98 %attr(755,root,root) %{_sbindir}/airserv-ng
99 %attr(755,root,root) %{_sbindir}/airtun-ng
100 %{_mandir}/man1/aircrack-ng.1*
101 %{_mandir}/man1/airdecap-ng.1*
102 %{_mandir}/man1/airdecloak-ng.1*
103 %{?with_sqlite:%{_mandir}/man1/airolib-ng.1*}
104 %{_mandir}/man1/besside-ng-crawler.1*
105 %{_mandir}/man1/ivstools.1*
106 %{_mandir}/man1/kstats.1*
107 %{_mandir}/man1/makeivs-ng.1*
108 %{_mandir}/man1/packetforge-ng.1*
109 %{_mandir}/man1/wpaclean.1*
110 %{_mandir}/man8/airbase-ng.8*
111 %{_mandir}/man8/aireplay-ng.8*
112 %{_mandir}/man8/airmon-ng.8*
113 %{_mandir}/man8/airodump-ng-oui-update.8*
114 %{_mandir}/man8/airodump-ng.8*
115 %{_mandir}/man8/airserv-ng.8*
116 %{_mandir}/man8/airtun-ng.8*
117 %{_mandir}/man8/besside-ng.8*
118
119 %if %{with experimental}
120 %attr(755,root,root) %{_bindir}/buddy-ng
121 %attr(755,root,root) %{_sbindir}/besside-ng
122 %attr(755,root,root) %{_sbindir}/easside-ng
123 %attr(755,root,root) %{_sbindir}/tkiptun-ng
124 %attr(755,root,root) %{_sbindir}/wesside-ng
125 %{_mandir}/man1/buddy-ng.1*
126 %{_mandir}/man8/easside-ng.8*
127 %{_mandir}/man8/tkiptun-ng.8*
128 %{_mandir}/man8/wesside-ng.8*
129 %endif
This page took 0.231064 seconds and 2 git commands to generate.