]> git.pld-linux.org Git - packages/agg.git/commitdiff
- cxx fixes for gcc 8 master auto/th/agg-2.5-8
authorJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Sep 2018 11:34:21 +0000 (13:34 +0200)
committerJan Rękorajski <baggins@pld-linux.org>
Mon, 3 Sep 2018 11:34:21 +0000 (13:34 +0200)
- rel 8

agg.spec
cxx.patch [new file with mode: 0644]

index 45de61d9b74283e94b776d5742ab5af8e3d4663a..917b8210eb5f01d67f9d934e710879e6d9db52fe 100644 (file)
--- a/agg.spec
+++ b/agg.spec
@@ -2,13 +2,14 @@ Summary:      A High Quality Rendering Engine for C++
 Summary(pl.UTF-8):     Silnik renderujący wysokiej jakości dla C++
 Name:          agg
 Version:       2.5
-Release:       7
+Release:       8
 License:       GPL v2+
 Group:         Libraries
 Source0:       http://www.antigrain.com/%{name}-%{version}.tar.gz
 # Source0-md5: ddc67cbdc7d51e1ec984c2ac2724c08a
 Patch0:                %{name}-depends.patch
 Patch1:                ac.patch
+Patch2:                cxx.patch
 URL:           http://www.antigrain.com/
 BuildRequires: SDL-devel
 BuildRequires: autoconf
@@ -78,6 +79,7 @@ Statyczna biblioteka agg.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
 
 %build
 %{__libtoolize}
@@ -86,7 +88,8 @@ Statyczna biblioteka agg.
 %{__autoconf}
 %{__automake}
 %configure \
-       --disable-gpc
+       --disable-gpc \
+       --disable-examples
 
 %{__make} -j1
 
diff --git a/cxx.patch b/cxx.patch
new file mode 100644 (file)
index 0000000..6975d02
--- /dev/null
+++ b/cxx.patch
@@ -0,0 +1,39 @@
+diff -ur agg-2.5/include/agg_renderer_outline_aa.h agg-2.5.c++/include/agg_renderer_outline_aa.h
+--- agg-2.5/include/agg_renderer_outline_aa.h  2006-10-09 06:07:08.000000000 +0200
++++ agg-2.5.c++/include/agg_renderer_outline_aa.h      2018-09-03 11:45:56.795337176 +0200
+@@ -1375,7 +1375,7 @@
+         //---------------------------------------------------------------------
+         void profile(const line_profile_aa& prof) { m_profile = &prof; }
+         const line_profile_aa& profile() const { return *m_profile; }
+-        line_profile_aa& profile() { return *m_profile; }
++        const line_profile_aa& profile() { return *m_profile; }
+         //---------------------------------------------------------------------
+         int subpixel_width() const { return m_profile->subpixel_width(); }
+diff -ur agg-2.5/include/agg_scanline_u.h agg-2.5.c++/include/agg_scanline_u.h
+--- agg-2.5/include/agg_scanline_u.h   2006-10-09 06:07:10.000000000 +0200
++++ agg-2.5.c++/include/agg_scanline_u.h       2018-09-03 11:48:04.543654164 +0200
+@@ -476,18 +476,19 @@
+         scanline32_u8_am() : base_type(), m_alpha_mask(0) {}
+         scanline32_u8_am(const AlphaMask& am) : base_type(), m_alpha_mask(&am) {}
++      base_type b;
+         //--------------------------------------------------------------------
+         void finalize(int span_y)
+         {
+-            base_type::finalize(span_y);
++            b.finalize(span_y);
+             if(m_alpha_mask)
+             {
+-                typename base_type::iterator span = base_type::begin();
+-                unsigned count = base_type::num_spans();
++                typename base_type::iterator span = b.begin();
++                unsigned count = b.num_spans();
+                 do
+                 {
+                     m_alpha_mask->combine_hspan(span->x, 
+-                                                base_type::y(), 
++                                                b.y(), 
+                                                 span->covers, 
+                                                 span->len);
+                     ++span;
This page took 0.13219 seconds and 4 git commands to generate.