]> git.pld-linux.org Git - packages/agg.git/blob - agg.spec
- rel 2
[packages/agg.git] / agg.spec
1 Summary:        A High Quality Rendering Engine for C++
2 Summary(pl.UTF-8):      Silnik renderujący wysokiej jakości dla C++
3 Name:           agg
4 Version:        2.5
5 Release:        2
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.antigrain.com/%{name}-%{version}.tar.gz
9 # Source0-md5:  ddc67cbdc7d51e1ec984c2ac2724c08a
10 Patch0:         %{name}-depends.patch
11 URL:            http://www.antigrain.com/
12 BuildRequires:  SDL-devel
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  freetype-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 %description
23 Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
24 written completely in standard and platform independent C++. It can be
25 used in many areas of computer programming where high quality 2D
26 graphics is an essential part of the project.
27
28 AGG uses only C++ and standard C runtime functions, such as memcpy,
29 sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
30 Template Library. Thus, AGG can be used in a very large number of
31 applications, including embedded systems.
32
33 %description -l pl.UTF-8
34 Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
35 napisany całkowicie w standardowym i niezależnym od platformy C++.
36 Może być używany w wielu zastosowaniach z zakresu programowania gdzie
37 zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
38
39 AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
40 cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
41 biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
42 zastosowaniach, także na systemach wbudowanych.
43
44 %package devel
45 Summary:        Support files necessary to compile applications with agg
46 Summary(pl.UTF-8):      Pliki potrzebne do kompilowania aplikacji z użyciem agg
47 Group:          Development/Libraries
48 Requires:       %{name} = %{version}-%{release}
49 Requires:       libstdc++-devel
50 # libaggfontfreetype R: freetype-devel
51 # libaggplatformsdl R: SDL-devel
52 # libaggplatformX11 R: xorg-lib-libX11-devel
53
54 %description devel
55 Header and support files necessary to compile applications using agg.
56
57 %description devel -l pl.UTF-8
58 Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
59 użyciem agg.
60
61 %package static
62 Summary:        Static agg library
63 Summary(pl.UTF-8):      Statyczna biblioteka agg
64 Group:          Development/Libraries
65 Requires:       %{name}-devel = %{version}-%{release}
66
67 %description static
68 Static agg library.
69
70 %description static -l pl.UTF-8
71 Statyczna biblioteka agg.
72
73 %prep
74 %setup -q
75 %patch0 -p1
76
77 %build
78 %{__libtoolize}
79 %{__aclocal}
80 %{__autoheader}
81 %{__autoconf}
82 %{__automake}
83 %configure \
84         --disable-gpc
85 %{__make}
86
87 %install
88 rm -rf $RPM_BUILD_ROOT
89
90 %{__make} install \
91         DESTDIR=$RPM_BUILD_ROOT
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %post   -p /sbin/ldconfig
97 %postun -p /sbin/ldconfig
98
99 %files
100 %defattr(644,root,root,755)
101 %doc authors copying readme
102 %attr(755,root,root) %{_libdir}/libagg*.so.*.*.*
103
104 %files devel
105 %defattr(644,root,root,755)
106 %attr(755,root,root) %{_libdir}/libagg*.so
107 %{_libdir}/libagg*.la
108 %{_includedir}/agg2
109 %{_pkgconfigdir}/libagg.pc
110 %{_aclocaldir}/libagg.m4
111
112 %files static
113 %defattr(644,root,root,755)
114 %{_libdir}/libagg*.a
This page took 0.10219 seconds and 3 git commands to generate.