]> git.pld-linux.org Git - packages/agg.git/blob - agg.spec
0ef3aee86a59c906443e276f69b83960c4d4aeda
[packages/agg.git] / agg.spec
1 Summary:        A High Quality Rendering Engine for C++
2 Summary(pl.UTF-8):      Silnik renderujący wysokiej jakości dla C++
3 Name:           agg
4 Version:        2.5
5 Release:        6
6 License:        GPL v2+
7 Group:          Libraries
8 Source0:        http://www.antigrain.com/%{name}-%{version}.tar.gz
9 # Source0-md5:  ddc67cbdc7d51e1ec984c2ac2724c08a
10 Patch0:         %{name}-depends.patch
11 URL:            http://www.antigrain.com/
12 BuildRequires:  SDL-devel
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  freetype-devel
16 BuildRequires:  libstdc++-devel
17 BuildRequires:  libtool
18 BuildRequires:  pkgconfig
19 BuildRequires:  xorg-lib-libX11-devel
20 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
21
22 # Unresolved symbol: _Z8agg_mainiPPc
23 %define         skip_post_check_so      libaggplatformsdl.so.*.*.* libaggplatformX11.so.*.*.* libaggplatformsdl.so.*.*.*
24
25 %description
26 Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
27 written completely in standard and platform independent C++. It can be
28 used in many areas of computer programming where high quality 2D
29 graphics is an essential part of the project.
30
31 AGG uses only C++ and standard C runtime functions, such as memcpy,
32 sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
33 Template Library. Thus, AGG can be used in a very large number of
34 applications, including embedded systems.
35
36 %description -l pl.UTF-8
37 Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
38 napisany całkowicie w standardowym i niezależnym od platformy C++.
39 Może być używany w wielu zastosowaniach z zakresu programowania gdzie
40 zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
41
42 AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
43 cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
44 biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
45 zastosowaniach, także na systemach wbudowanych.
46
47 %package devel
48 Summary:        Support files necessary to compile applications with agg
49 Summary(pl.UTF-8):      Pliki potrzebne do kompilowania aplikacji z użyciem agg
50 Group:          Development/Libraries
51 Requires:       %{name} = %{version}-%{release}
52 Requires:       libstdc++-devel
53 # libaggfontfreetype R: freetype-devel
54 # libaggplatformX11 R: xorg-lib-libX11-devel
55 # libaggplatformsdl R: SDL-devel
56
57 %description devel
58 Header and support files necessary to compile applications using agg.
59
60 %description devel -l pl.UTF-8
61 Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
62 użyciem agg.
63
64 %package static
65 Summary:        Static agg library
66 Summary(pl.UTF-8):      Statyczna biblioteka agg
67 Group:          Development/Libraries
68 Requires:       %{name}-devel = %{version}-%{release}
69
70 %description static
71 Static agg library.
72
73 %description static -l pl.UTF-8
74 Statyczna biblioteka agg.
75
76 %prep
77 %setup -q
78 %patch0 -p1
79
80 %build
81 %{__libtoolize}
82 %{__aclocal}
83 %{__autoheader}
84 %{__autoconf}
85 %{__automake}
86 %configure \
87         --disable-gpc
88
89 %{__make} -j1
90
91 %install
92 rm -rf $RPM_BUILD_ROOT
93
94 %{__make} install \
95         DESTDIR=$RPM_BUILD_ROOT
96
97 %clean
98 rm -rf $RPM_BUILD_ROOT
99
100 %post   -p /sbin/ldconfig
101 %postun -p /sbin/ldconfig
102
103 %files
104 %defattr(644,root,root,755)
105 %doc authors copying readme
106 %attr(755,root,root) %{_libdir}/libagg.so.*.*.*
107 %ghost %{_libdir}/libagg.so.2
108 %attr(755,root,root) %{_libdir}/libaggfontfreetype.so.*.*.*
109 %ghost %{_libdir}/libaggfontfreetype.so.2
110 %attr(755,root,root) %{_libdir}/libaggplatformX11.so.*.*.*
111 %ghost %{_libdir}/libaggplatformX11.so.2
112 %attr(755,root,root) %{_libdir}/libaggplatformsdl.so.*.*.*
113 %ghost %{_libdir}/libaggplatformsdl.so.2
114
115 %files devel
116 %defattr(644,root,root,755)
117 %{_libdir}/libagg.so
118 %{_libdir}/libaggfontfreetype.so
119 %{_libdir}/libaggplatformX11.so
120 %{_libdir}/libaggplatformsdl.so
121 %{_libdir}/libagg.la
122 %{_libdir}/libaggfontfreetype.la
123 %{_libdir}/libaggplatformX11.la
124 %{_libdir}/libaggplatformsdl.la
125 %{_includedir}/agg2
126 %{_pkgconfigdir}/libagg.pc
127 %{_aclocaldir}/libagg.m4
128
129 %files static
130 %defattr(644,root,root,755)
131 %{_libdir}/libagg.a
132 %{_libdir}/libaggfontfreetype.a
133 %{_libdir}/libaggplatformX11.a
134 %{_libdir}/libaggplatformsdl.a
This page took 0.059139 seconds and 2 git commands to generate.