]> git.pld-linux.org Git - packages/agg.git/blame - agg.spec
- cxx fixes for gcc 8
[packages/agg.git] / agg.spec
CommitLineData
3e3a5633 1Summary: A High Quality Rendering Engine for C++
500bc5a4 2Summary(pl.UTF-8): Silnik renderujący wysokiej jakości dla C++
838beb5e
ER
3Name: agg
4Version: 2.5
355d469d 5Release: 8
3e3a5633 6License: GPL v2+
838beb5e 7Group: Libraries
838beb5e
ER
8Source0: http://www.antigrain.com/%{name}-%{version}.tar.gz
9# Source0-md5: ddc67cbdc7d51e1ec984c2ac2724c08a
10Patch0: %{name}-depends.patch
127f6abb 11Patch1: ac.patch
355d469d 12Patch2: cxx.patch
f3fc0867 13URL: http://www.antigrain.com/
838beb5e 14BuildRequires: SDL-devel
f3fc0867 15BuildRequires: autoconf
838beb5e
ER
16BuildRequires: automake
17BuildRequires: freetype-devel
c70bbd4b 18BuildRequires: libstdc++-devel
838beb5e 19BuildRequires: libtool
c70bbd4b 20BuildRequires: pkgconfig
956123cc 21BuildRequires: xorg-lib-libX11-devel
838beb5e
ER
22BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
23
189cd8e6
ER
24# Unresolved symbol: _Z8agg_mainiPPc
25%define skip_post_check_so libaggplatformsdl.so.*.*.* libaggplatformX11.so.*.*.* libaggplatformsdl.so.*.*.*
26
838beb5e 27%description
3e3a5633
ER
28Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
29written completely in standard and platform independent C++. It can be
30used in many areas of computer programming where high quality 2D
31graphics is an essential part of the project.
32
33AGG uses only C++ and standard C runtime functions, such as memcpy,
34sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
35Template Library. Thus, AGG can be used in a very large number of
36applications, including embedded systems.
838beb5e 37
ae0d6b25
JR
38%description -l pl.UTF-8
39Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
40napisany całkowicie w standardowym i niezależnym od platformy C++.
41Może być używany w wielu zastosowaniach z zakresu programowania gdzie
42zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
f3fc0867 43
ae0d6b25
JR
44AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
45cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
46biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
47zastosowaniach, także na systemach wbudowanych.
f3fc0867 48
838beb5e
ER
49%package devel
50Summary: Support files necessary to compile applications with agg
500bc5a4 51Summary(pl.UTF-8): Pliki potrzebne do kompilowania aplikacji z użyciem agg
838beb5e
ER
52Group: Development/Libraries
53Requires: %{name} = %{version}-%{release}
c70bbd4b
JB
54Requires: libstdc++-devel
55# libaggfontfreetype R: freetype-devel
c70bbd4b 56# libaggplatformX11 R: xorg-lib-libX11-devel
189cd8e6 57# libaggplatformsdl R: SDL-devel
838beb5e
ER
58
59%description devel
f3fc0867
JB
60Header and support files necessary to compile applications using agg.
61
ae0d6b25
JR
62%description devel -l pl.UTF-8
63Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
64użyciem agg.
838beb5e 65
1ca4835f
ER
66%package static
67Summary: Static agg library
500bc5a4 68Summary(pl.UTF-8): Statyczna biblioteka agg
1ca4835f
ER
69Group: Development/Libraries
70Requires: %{name}-devel = %{version}-%{release}
71
72%description static
73Static agg library.
74
ae0d6b25 75%description static -l pl.UTF-8
f3fc0867
JB
76Statyczna biblioteka agg.
77
838beb5e
ER
78%prep
79%setup -q
80%patch0 -p1
127f6abb 81%patch1 -p1
355d469d 82%patch2 -p1
838beb5e
ER
83
84%build
c70bbd4b 85%{__libtoolize}
838beb5e
ER
86%{__aclocal}
87%{__autoheader}
88%{__autoconf}
838beb5e
ER
89%{__automake}
90%configure \
355d469d
JR
91 --disable-gpc \
92 --disable-examples
be32cf66
JR
93
94%{__make} -j1
838beb5e
ER
95
96%install
97rm -rf $RPM_BUILD_ROOT
f3fc0867 98
838beb5e
ER
99%{__make} install \
100 DESTDIR=$RPM_BUILD_ROOT
101
f3fc0867
JB
102%clean
103rm -rf $RPM_BUILD_ROOT
838beb5e
ER
104
105%post -p /sbin/ldconfig
106%postun -p /sbin/ldconfig
107
108%files
109%defattr(644,root,root,755)
110%doc authors copying readme
189cd8e6
ER
111%attr(755,root,root) %{_libdir}/libagg.so.*.*.*
112%ghost %{_libdir}/libagg.so.2
113%attr(755,root,root) %{_libdir}/libaggfontfreetype.so.*.*.*
114%ghost %{_libdir}/libaggfontfreetype.so.2
115%attr(755,root,root) %{_libdir}/libaggplatformX11.so.*.*.*
116%ghost %{_libdir}/libaggplatformX11.so.2
117%attr(755,root,root) %{_libdir}/libaggplatformsdl.so.*.*.*
118%ghost %{_libdir}/libaggplatformsdl.so.2
838beb5e
ER
119
120%files devel
121%defattr(644,root,root,755)
189cd8e6
ER
122%{_libdir}/libagg.so
123%{_libdir}/libaggfontfreetype.so
124%{_libdir}/libaggplatformX11.so
125%{_libdir}/libaggplatformsdl.so
126%{_libdir}/libagg.la
127%{_libdir}/libaggfontfreetype.la
128%{_libdir}/libaggplatformX11.la
129%{_libdir}/libaggplatformsdl.la
838beb5e 130%{_includedir}/agg2
1ca4835f 131%{_pkgconfigdir}/libagg.pc
838beb5e
ER
132%{_aclocaldir}/libagg.m4
133
1ca4835f
ER
134%files static
135%defattr(644,root,root,755)
189cd8e6
ER
136%{_libdir}/libagg.a
137%{_libdir}/libaggfontfreetype.a
138%{_libdir}/libaggplatformX11.a
139%{_libdir}/libaggplatformsdl.a
This page took 0.170628 seconds and 4 git commands to generate.