]> git.pld-linux.org Git - packages/agg.git/blame - agg.spec
- fix building with latest ac/am
[packages/agg.git] / agg.spec
CommitLineData
3e3a5633 1Summary: A High Quality Rendering Engine for C++
500bc5a4 2Summary(pl.UTF-8): Silnik renderujący wysokiej jakości dla C++
838beb5e
ER
3Name: agg
4Version: 2.5
127f6abb 5Release: 7
3e3a5633 6License: GPL v2+
838beb5e 7Group: Libraries
838beb5e
ER
8Source0: http://www.antigrain.com/%{name}-%{version}.tar.gz
9# Source0-md5: ddc67cbdc7d51e1ec984c2ac2724c08a
10Patch0: %{name}-depends.patch
127f6abb 11Patch1: ac.patch
f3fc0867 12URL: http://www.antigrain.com/
838beb5e 13BuildRequires: SDL-devel
f3fc0867 14BuildRequires: autoconf
838beb5e
ER
15BuildRequires: automake
16BuildRequires: freetype-devel
c70bbd4b 17BuildRequires: libstdc++-devel
838beb5e 18BuildRequires: libtool
c70bbd4b 19BuildRequires: pkgconfig
956123cc 20BuildRequires: xorg-lib-libX11-devel
838beb5e
ER
21BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
189cd8e6
ER
23# Unresolved symbol: _Z8agg_mainiPPc
24%define skip_post_check_so libaggplatformsdl.so.*.*.* libaggplatformX11.so.*.*.* libaggplatformsdl.so.*.*.*
25
838beb5e 26%description
3e3a5633
ER
27Anti-Grain Geometry (AGG) is a general purpose graphical toolkit
28written completely in standard and platform independent C++. It can be
29used in many areas of computer programming where high quality 2D
30graphics is an essential part of the project.
31
32AGG uses only C++ and standard C runtime functions, such as memcpy,
33sin, cos, sqrt, etc. The basic algorithms don't even use C++ Standard
34Template Library. Thus, AGG can be used in a very large number of
35applications, including embedded systems.
838beb5e 36
ae0d6b25
JR
37%description -l pl.UTF-8
38Anti-Grain Geometry (AGG) to toolkit graficzny ogólnego przeznaczenia
39napisany całkowicie w standardowym i niezależnym od platformy C++.
40Może być używany w wielu zastosowaniach z zakresu programowania gdzie
41zasadniczą częścią projektu jest wysokiej jakości grafika 2D.
f3fc0867 42
ae0d6b25
JR
43AGG używa tylko C++ i standardowych funkcji C, takich jak memcpy, sin,
44cos, sqrt itp. Podstawowe algorytmy nie używają nawet standardowej
45biblioteki C++. W ten sposób AGG może być używany w bardzo wielu
46zastosowaniach, także na systemach wbudowanych.
f3fc0867 47
838beb5e
ER
48%package devel
49Summary: Support files necessary to compile applications with agg
500bc5a4 50Summary(pl.UTF-8): Pliki potrzebne do kompilowania aplikacji z użyciem agg
838beb5e
ER
51Group: Development/Libraries
52Requires: %{name} = %{version}-%{release}
c70bbd4b
JB
53Requires: libstdc++-devel
54# libaggfontfreetype R: freetype-devel
c70bbd4b 55# libaggplatformX11 R: xorg-lib-libX11-devel
189cd8e6 56# libaggplatformsdl R: SDL-devel
838beb5e
ER
57
58%description devel
f3fc0867
JB
59Header and support files necessary to compile applications using agg.
60
ae0d6b25
JR
61%description devel -l pl.UTF-8
62Pliki nagłówkowe i pomocnicze potrzebne do kompilowania aplikacji z
63użyciem agg.
838beb5e 64
1ca4835f
ER
65%package static
66Summary: Static agg library
500bc5a4 67Summary(pl.UTF-8): Statyczna biblioteka agg
1ca4835f
ER
68Group: Development/Libraries
69Requires: %{name}-devel = %{version}-%{release}
70
71%description static
72Static agg library.
73
ae0d6b25 74%description static -l pl.UTF-8
f3fc0867
JB
75Statyczna biblioteka agg.
76
838beb5e
ER
77%prep
78%setup -q
79%patch0 -p1
127f6abb 80%patch1 -p1
838beb5e
ER
81
82%build
c70bbd4b 83%{__libtoolize}
838beb5e
ER
84%{__aclocal}
85%{__autoheader}
86%{__autoconf}
838beb5e
ER
87%{__automake}
88%configure \
89 --disable-gpc
be32cf66
JR
90
91%{__make} -j1
838beb5e
ER
92
93%install
94rm -rf $RPM_BUILD_ROOT
f3fc0867 95
838beb5e
ER
96%{__make} install \
97 DESTDIR=$RPM_BUILD_ROOT
98
f3fc0867
JB
99%clean
100rm -rf $RPM_BUILD_ROOT
838beb5e
ER
101
102%post -p /sbin/ldconfig
103%postun -p /sbin/ldconfig
104
105%files
106%defattr(644,root,root,755)
107%doc authors copying readme
189cd8e6
ER
108%attr(755,root,root) %{_libdir}/libagg.so.*.*.*
109%ghost %{_libdir}/libagg.so.2
110%attr(755,root,root) %{_libdir}/libaggfontfreetype.so.*.*.*
111%ghost %{_libdir}/libaggfontfreetype.so.2
112%attr(755,root,root) %{_libdir}/libaggplatformX11.so.*.*.*
113%ghost %{_libdir}/libaggplatformX11.so.2
114%attr(755,root,root) %{_libdir}/libaggplatformsdl.so.*.*.*
115%ghost %{_libdir}/libaggplatformsdl.so.2
838beb5e
ER
116
117%files devel
118%defattr(644,root,root,755)
189cd8e6
ER
119%{_libdir}/libagg.so
120%{_libdir}/libaggfontfreetype.so
121%{_libdir}/libaggplatformX11.so
122%{_libdir}/libaggplatformsdl.so
123%{_libdir}/libagg.la
124%{_libdir}/libaggfontfreetype.la
125%{_libdir}/libaggplatformX11.la
126%{_libdir}/libaggplatformsdl.la
838beb5e 127%{_includedir}/agg2
1ca4835f 128%{_pkgconfigdir}/libagg.pc
838beb5e
ER
129%{_aclocaldir}/libagg.m4
130
1ca4835f
ER
131%files static
132%defattr(644,root,root,755)
189cd8e6
ER
133%{_libdir}/libagg.a
134%{_libdir}/libaggfontfreetype.a
135%{_libdir}/libaggplatformX11.a
136%{_libdir}/libaggplatformsdl.a
This page took 0.078266 seconds and 4 git commands to generate.