]> git.pld-linux.org Git - packages/aften.git/commitdiff
- pl
authorJakub Bogusz <qboosh@pld-linux.org>
Mon, 14 Nov 2011 17:41:20 +0000 (17:41 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
- build and package shared library and C++ binding

Changed files:
    aften.spec -> 1.2

aften.spec

index 0765d89936ded698971976982d2151366ed0b1a5..88ac216e8b64fc68b7a7502553bcfafeb047045e 100644 (file)
@@ -1,23 +1,72 @@
 Summary:       A/52 audio encoder
-#Summary(pl.UTF-8):    -
+Summary(pl.UTF-8):     Koder dźwięku A/52
 Name:          aften
 Version:       0.0.8
 Release:       1
-License:       LGPL
+License:       LGPL v2+
 Group:         Applications/Sound
-Source0:       http://dl.sourceforge.net/%{name}/%{name}-%{version}.tar.bz2
+Source0:       http://downloads.sourceforge.net/aften/%{name}-%{version}.tar.bz2
 # Source0-md5: fde67146879febb81af3d95a62df8840
 URL:           http://aften.sourceforge.net/
-BuildRequires: cmake
+BuildRequires: cmake >= 2.4
+BuildRequires: libstdc++-devel
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
 Aften is an audio encoder which generates compressed audio streams
 based on ATSC A/52 specification. This type of audio is also known
+as AC-3 or Dolby(R) Digital and is one of the audio codecs used in
+DVD-Video content. 
+
+%description -l en.UTF-8
+Aften is an audio encoder which generates compressed audio streams
+based on ATSC A/52 specification. This type of audio is also known
 as AC-3 or Dolby® Digital and is one of the audio codecs used in
 DVD-Video content. 
 
-#%description -l pl.UTF-8
+%description -l pl.UTF-8
+Aften to koder dźwięku generujący skompresowane strumienie dźwięku
+oparte na specyfikacji ATSC A/52. Ten format jest znany także jako
+AC-3 lub Dolby® Digital i jest jednym z kodeków dźwięku używanych w
+treściach DVD-Video.
+
+%package devel
+Summary:       Header files for Aften library
+Summary(pl.UTF-8):     Pliki nagłówkowe biblioteki Aften
+Group:         Development/Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description devel
+Header files for Aften library.
+
+%description devel -l pl.UTF-8
+Pliki nagłówkowe biblioteki Aften.
+
+%package c++
+Summary:       C++ binding for Aften library
+Summary(pl.UTF-8):     Interfejs C++ do biblioteki Aften
+Group:         Libraries
+Requires:      %{name} = %{version}-%{release}
+
+%description c++
+C++ binding for Aften library.
+
+%description c++ -l pl.UTF-8
+Interfejs C++ do biblioteki Aften.
+
+%package c++-devel
+Summary:       Header file for C++ binding for Aften library
+Summary(pl.UTF-8):     Plik nagłówkowy interfejsu C++ do biblioteki Aften
+Group:         Development/Libraries
+Requires:      %{name}-c++ = %{version}-%{release}
+Requires:      %{name}-devel = %{version}-%{release}
+Requires:      libstdc++-devel
+
+%description c++-devel
+Header file for C++ binding for Aften library.
+
+%description c++-devel -l pl.UTF-8
+Plik nagłówkowy interfejsu C++ do biblioteki Aften.
 
 %prep
 %setup -q
@@ -25,15 +74,16 @@ DVD-Video content.
 %build
 install -d build
 cd build
-%cmake \
-        ../
+%cmake .. \
+       -DSHARED=ON \
+       -DBINDINGS_CXX=ON
 
 %{__make}
 
 %install
 rm -rf $RPM_BUILD_ROOT
 
-%{__make}  -C build install/fast \
+%{__make} -C build install/fast \
        DESTDIR=$RPM_BUILD_ROOT
 
 %clean
@@ -42,4 +92,26 @@ rm -rf $RPM_BUILD_ROOT
 %files
 %defattr(644,root,root,755)
 %doc Changelog README
-%attr(755,root,root) %{_bindir}/*
+%attr(755,root,root) %{_bindir}/aften
+%attr(755,root,root) %{_bindir}/wavfilter
+%attr(755,root,root) %{_bindir}/wavinfo
+%attr(755,root,root) %{_bindir}/wavrms
+%attr(755,root,root) %{_libdir}/libaften.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libaften.so.0
+
+%files devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libaften.so
+%dir %{_includedir}/aften
+%{_includedir}/aften/aften-types.h
+%{_includedir}/aften/aften.h
+
+%files c++
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libaftenxx.so.*.*.*
+%attr(755,root,root) %ghost %{_libdir}/libaftenxx.so.0
+
+%files c++-devel
+%defattr(644,root,root,755)
+%attr(755,root,root) %{_libdir}/libaftenxx.so
+%{_includedir}/aften/aftenxx.h
This page took 0.1142 seconds and 4 git commands to generate.