]> git.pld-linux.org Git - packages/aewm.git/blob - aewm.spec
- renamed gnome bcond
[packages/aewm.git] / aewm.spec
1 #
2 # Conditional build:
3 %bcond_with     gnome2          # build with support for GNOME2 wm-properties
4 #
5 Summary:        AEWM - the ascetic window manager
6 Summary(pl.UTF-8):      AEWM - "ascetyczny" zarządca okien
7 Name:           aewm
8 Version:        1.3.1
9 Release:        5
10 License:        MIT
11 Group:          X11/Window Managers
12 Source0:        http://www.red-bean.com/~decklin/aewm/%{name}-%{version}.tar.gz
13 # Source0-md5:  d357a30c29540101d0545a3c9167bba0
14 Source1:        %{name}.desktop
15 Source2:        %{name}-xsession.desktop
16 Patch0:         %{name}-xft.patch
17 Patch1:         %{name}-amd64.patch
18 URL:            http://www.red-bean.com/~decklin/aewm/
19 BuildRequires:  gtk+2-devel >= 1:2.0
20 BuildRequires:  motif-devel
21 BuildRequires:  pkgconfig
22 BuildRequires:  xorg-lib-libXft-devel
23 Conflicts:      filesystem < 3.0-20
24 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
25
26 %define         _wmpropsdir     /usr/share/gnome/wm-properties
27
28 %description
29 aewm is a minimal window manager for X11. It doesn't support icons,
30 multiple sessions, themes or so; it isn't even highly customizable.
31 Its main benefits are simplicity and speed.
32
33 %description -l pl.UTF-8
34 aewm jet minimalnym zarządcą okien dla X11. Nie potrafi obsługiwać
35 ikon, wielu sesji, motywów, tła itp. Nie jest zbyt konfigurowalny.
36 Jego zaletą jest prostota i szybkość.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %if "%{_lib}" == "lib64"
42 %patch1 -p1
43 %endif
44
45 %build
46 %{__make} \
47         CC="%{__cc}" \
48         CFLAGS="%{rpmcflags}" \
49         XROOT=%{_prefix}
50
51 %install
52 rm -rf $RPM_BUILD_ROOT
53 install -d \
54         $RPM_BUILD_ROOT{%{_bindir},%{_mandir}/man1,%{_sysconfdir}/X11/%{name}} \
55         $RPM_BUILD_ROOT%{_wmpropsdir} \
56         $RPM_BUILD_ROOT%{_datadir}/xsessions
57
58 %{__make} install \
59         DESTDIR=$RPM_BUILD_ROOT \
60         XROOT=%{_prefix} \
61         MANDIR=$RPM_BUILD_ROOT%{_mandir}/man1
62
63 %{?with_gnome2:install %{SOURCE1} $RPM_BUILD_ROOT%{_wmpropsdir}}
64 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/xsessions/%{name}.desktop
65 install src/aewmrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/aewmrc
66 install clients/clientsrc.sample $RPM_BUILD_ROOT%{_sysconfdir}/X11/%{name}/clientsrc
67
68 rm -f $RPM_BUILD_ROOT%{_mandir}/man1/{aemenu-*,aepanel-*,aesession.*,set-gnome-pda.*,switch-desk.*}
69 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/aemenu-gtk.1x
70 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/aemenu-xaw.1x
71 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/aepanel-gtk.1x
72 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/aepanel-xaw.1x
73 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/aesession.1x
74 echo ".so aeclients.1x" > $RPM_BUILD_ROOT%{_mandir}/man1/set-gnome-pda.1x
75
76 %clean
77 rm -rf $RPM_BUILD_ROOT
78
79 %files
80 %defattr(644,root,root,755)
81 %doc README NEWS TODO
82 %dir %{_sysconfdir}/X11/%{name}
83 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/X11/%{name}/*rc
84 %attr(755,root,root) %{_bindir}/*
85 %{_datadir}/xsessions/%{name}.desktop
86 %{?with_gnome2:%{_wmpropsdir}/*}
87 %{_mandir}/man1/*
This page took 0.077027 seconds and 3 git commands to generate.