]> git.pld-linux.org Git - packages/aethera.git/blob - aethera.spec
- more files, builds on amd64 too
[packages/aethera.git] / aethera.spec
1 %define         _rel    0.2
2 Summary:        Aethera - Email and PIM application
3 Summary(pl):    Aethera - aplikacja e-mail i zarz±dcy informacji osobistej (PIM)
4 Name:           aethera
5 Version:        1.2.1
6 Release:        050331.%{_rel}
7 License:        GPL
8 Group:          X11/Applications
9 Source0:        %{name}-%{version}.tar.gz
10 Patch0:         %{name}-libs.patch
11 Patch1:         %{name}-includes.patch
12 Patch2:         %{name}-install.patch
13 Patch3:         %{name}-fpic.patch
14 # Source0-md5:  f3efd064b5e9884bd7adf49bf763e213
15 URL:            http://www.thekompany.com/projects/aethera/
16 BuildRequires:  korelib-devel
17 BuildRequires:  qt-devel
18 #Requires: thekompany-support
19 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
20
21 %description
22 Aethera is a pim application, i.e. it handles all kinds of personal
23 information: email, contacts, notes, tasks, todos, journals.
24
25 %description -l pl
26 Aethera jest aplikacj± zarz±dcy informacji osobistej (PIM). Obs³uguje
27 wszystkie rodzaje informacji osobistych: e-mail, kontakty, notatki,
28 zadania, sprawy do za³atwienia, dzienniki.
29
30 %package devel
31 Summary:        Header files for Aethera
32 Group:          Development/Libraries
33 Requires:       %{name} = %{version}-%{release}
34
35 %description devel
36 Header files for Aethera library.
37
38 %prep
39 %setup -q
40 %patch0 -p1
41 %patch1 -p1
42 %patch2 -p1
43 %ifarch %{x8664}
44 %patch3 -p1
45 %endif
46
47 mkdir -p include/aethera
48 ln -sf ../../aethera/libs/clientskel/clientrmi.h include/aethera
49 ln -sf ../../aethera/libs/clientskel/vfsmodule.h include/aethera
50
51 %build
52 export QTDIR=/usr
53 export QMAKE_STRIP=:
54
55 # Use the new libraries in building process
56 export LD_LIBRARY_PATH=$dir/lib:$LD_LIBRARY_PATH
57 dir=$(pwd)
58
59 # Compile tkcBase
60 cd tkcbase
61 cat <<EOF > defines.pri
62 TKCBASE_LIB=%{_libdir}
63 TKCBASE_INCLUDE=%{_includedir}/tkcbase
64 CONFIG += release thread
65 EOF
66 qmake desktop.pro
67 %{__make}
68
69 # Compile tkcSSL
70 cd ../tkcssl
71 cat <<EOF > defines.pri
72 TKCSSL_LIB=%{_libdir}
73 TKCSSL_INCLUDE=%{_includedir}/tkcssl
74 INCLUDEPATH += $dir/tkcbase
75 DEPENDPATH += $dir/tkcbase
76 CONFIG += release thread
77 EOF
78 qmake tkcssl.pro
79 %{__make}
80
81 # Compile webdav
82 cd ../webdav
83 cat <<EOF > defines.pri
84 WEBDAV_LIB=%{_libdir}
85 WEBDAV_INCLUDE=%{_includedir}/tkcbase
86 CONFIG += release thread
87 EOF
88 qmake webdav.pro
89 %{__make}
90
91 # Compile Aethera
92 cd ../aethera
93 cat <<EOF > defines.pri
94 AETHERA_DIR=%{_libdir}/aethera
95 AETHERA_BIN=%{_bindir}
96 AETHERA_LIB=%{_libdir}
97 AETHERA_INCLUDE=%{_includedir}/aethera
98 TINO_LIB=%{_libdir}
99 TINO_INCLUDE=%{_includedir}/tino
100 INCLUDEPATH += $dir/include
101 INCLUDEPATH += $dir/tkcbase
102 DEPENDPATH += $dir/tkcbase
103 INCLUDEPATH += $dir/tkcssl
104 DEPENDPATH += $dir/tkcssl
105
106 CONFIG += qt warn_on release thread
107 EOF
108
109 qmake aethera.pro
110 %{__make}
111
112 # Compile KOrganizer plugin
113 cd ../koplugin
114 cat <<EOF > defines.pri
115 AETHERA_DIR = %{_libdir}/aethera
116
117 INCLUDEPATH += $dir/include
118 INCLUDEPATH += $dir/tkcbase
119 DEPENDPATH += $dir/tkcbase
120
121 INCLUDEPATH += $dir/tkcssl
122 DEPENDPATH += $dir/tkcssl
123
124 INCLUDEPATH += $dir/aethera/libs
125 DEPENDPATH += $dir/aethera/libs
126
127 INCLUDEPATH += $dir/aethera/libs/aethera
128 DEPENDPATH += $dir/aethera/libs/aethera
129
130 INCLUDEPATH += $direbdav/webdav
131 DEPENDPATH += $dir/webdav/webdav
132
133 INCLUDEPATH += $dir/aethera/libs/clientskel
134 DEPENDPATH += $dir/aethera/libs/clientskel
135
136 INCLUDEPATH += $dir/include/aethera/libs/plugins/kommailplugin
137 DEPENDPATH += $dir/include/aethera/libs/plugins/kommailplugin
138
139 INCLUDEPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
140 DEPENDPATH += $dir/include/aethera/libs/plugins/komcontactsplugin
141
142 INCLUDEPATH += $dir/include/tino
143 DEPENDPATH += $dir/include/tino
144
145 CONFIG += qt warn_on release thread
146 DEFINES += AETHERA_KOLAB
147 EOF
148
149 qmake KOPlugin.pro
150 %{__make}
151
152 %install
153 rm -rf $RPM_BUILD_ROOT
154 install -d $RPM_BUILD_ROOT%{_libdir}/aethera
155
156 export QTDIR=/usr
157 %{__make} -C tkcbase install \
158         INSTALL_ROOT=$RPM_BUILD_ROOT
159 %{__make} -C tkcssl install \
160         INSTALL_ROOT=$RPM_BUILD_ROOT
161 %{__make} -C webdav install \
162         INSTALL_ROOT=$RPM_BUILD_ROOT
163 %{__make} -C aethera install \
164         INSTALL_ROOT=$RPM_BUILD_ROOT
165 %{__make} -C koplugin install \
166         INSTALL_ROOT=$RPM_BUILD_ROOT
167
168 # x86 binary
169 rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/sox
170 # unneccessary wrappers
171 rm $RPM_BUILD_ROOT%{_libdir}/aethera/bin/aethera_sound
172 rm $RPM_BUILD_ROOT%{_prefix}/local/bin/aethera
173
174 %clean
175 rm -rf $RPM_BUILD_ROOT
176
177 %post   -p      /sbin/ldconfig
178 %postun -p      /sbin/ldconfig
179
180 %files
181 %defattr(644,root,root,755)
182 %attr(755,root,root) %{_bindir}/aethera
183 %attr(755,root,root) %{_libdir}/libaethera.so.1.0.1
184 %attr(755,root,root) %{_libdir}/libfilebrowser.so.1.0.0
185 %attr(755,root,root) %{_libdir}/libtino.so.1.0.0
186 %attr(755,root,root) %{_libdir}/libtkcbase.so.1.0.0
187 %attr(755,root,root) %{_libdir}/libtkcssl.so.1.0.0
188 %dir %{_libdir}/aethera
189 %dir %{_libdir}/aethera/plugins
190 %attr(755,root,root) %{_libdir}/aethera/plugins/libhomeplugin.so.1.0.0
191 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomcontactsplugin.so.1.0.0
192 %attr(755,root,root) %{_libdir}/aethera/plugins/libkommailplugin.so.1.0.0
193 %attr(755,root,root) %{_libdir}/aethera/plugins/libkomnotesplugin.so.1.0.0
194 %attr(755,root,root) %{_libdir}/aethera/plugins/libkorganizer.so.1.0.0
195 %attr(755,root,root) %{_libdir}/aethera/plugins/libmailimport.so.1.0.0
196 %{_libdir}/aethera/help
197 %{_libdir}/aethera/pics
198 %{_libdir}/aethera/sound
199 %{_libdir}/aethera/data
200 %dir %{_libdir}/aethera/i18n
201 %lang(de) %{_libdir}/aethera/i18n/aethera_de.qm
202 %lang(de) %{_libdir}/aethera/i18n/aethera_de.ts
203 %lang(de) %{_libdir}/aethera/i18n/koplugin_de.ts
204 %lang(en) %{_libdir}/aethera/i18n/aethera_en.ts
205 %lang(en) %{_libdir}/aethera/i18n/koplugin_en.ts
206 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.qm
207 %lang(fr) %{_libdir}/aethera/i18n/aethera_fr.ts
208 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.qm
209 %lang(fr) %{_libdir}/aethera/i18n/koplugin_fr.ts
210 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.qm
211 %lang(pt) %{_libdir}/aethera/i18n/aethera_pt.ts
212 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.qm
213 %lang(pt) %{_libdir}/aethera/i18n/koplugin_pt.ts
214 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.qm
215 %lang(pt) %{_libdir}/aethera/i18n/qt_pt.ts
216 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.qm
217 %lang(ru) %{_libdir}/aethera/i18n/aethera_ru.ts
218 %{_desktopdir}/aethera.desktop
219 %{_iconsdir}/hicolor/*/apps/aethera.png
220 %{_pixmapsdir}/*.png
221
222 %files devel
223 %defattr(644,root,root,755)
224 %{_libdir}/libtkwidgets.a
225 %{_libdir}/libwebdav.a
226 %{_includedir}/aethera
227 %{_includedir}/tino
228 %{_includedir}/tkcbase
229 %{_includedir}/tkcssl
This page took 0.396542 seconds and 4 git commands to generate.