]> git.pld-linux.org Git - packages/aegisub.git/commitdiff
- release 10, rebuild against icu 64, boost 1.70 auto/th/aegisub-3.2.2-10
authorAdam Gołębiowski <adamg@pld-linux.org>
Mon, 15 Apr 2019 07:13:35 +0000 (09:13 +0200)
committerAdam Gołębiowski <adamg@pld-linux.org>
Mon, 15 Apr 2019 07:13:35 +0000 (09:13 +0200)
aegisub-boost-1.70.patch [new file with mode: 0644]
aegisub-icu64.patch [new file with mode: 0644]
aegisub.spec

diff --git a/aegisub-boost-1.70.patch b/aegisub-boost-1.70.patch
new file mode 100644 (file)
index 0000000..a3bed95
--- /dev/null
@@ -0,0 +1,44 @@
+--- aegisub-3.2.2/src/colour_button.cpp.orig   2019-04-15 08:43:16.415251576 +0200
++++ aegisub-3.2.2/src/colour_button.cpp        2019-04-15 08:44:56.040476824 +0200
+@@ -18,7 +18,7 @@
+ #include "dialogs.h"
+-#include <boost/gil/gil_all.hpp>
++#include <boost/gil.hpp>
+ wxDEFINE_EVENT(EVT_COLOR, wxThreadEvent);
+--- aegisub-3.2.2/src/subtitles_provider_libass.cpp~   2014-12-08 01:07:09.000000000 +0100
++++ aegisub-3.2.2/src/subtitles_provider_libass.cpp    2019-04-15 08:49:46.265809744 +0200
+@@ -50,7 +50,7 @@
+ #include <libaegisub/util.h>
+ #include <atomic>
+-#include <boost/gil/gil_all.hpp>
++#include <boost/gil.hpp>
+ #include <memory>
+ #include <mutex>
+--- aegisub-3.2.2/src/video_frame.cpp~ 2014-12-08 01:07:09.000000000 +0100
++++ aegisub-3.2.2/src/video_frame.cpp  2019-04-15 09:02:28.425810852 +0200
+@@ -16,7 +16,7 @@
+ #include "video_frame.h"
+-#include <boost/gil/gil_all.hpp>
++#include <boost/gil.hpp>
+ #include <wx/image.h>
+ namespace {
+--- aegisub-3.2.2/src/video_provider_dummy.cpp~        2014-12-08 01:07:09.000000000 +0100
++++ aegisub-3.2.2/src/video_provider_dummy.cpp 2019-04-15 09:03:44.153106555 +0200
+@@ -46,7 +46,7 @@
+ #include <boost/algorithm/string/split.hpp>
+ #include <boost/filesystem/path.hpp>
+ #include <libaegisub/format.h>
+-#include <boost/gil/gil_all.hpp>
++#include <boost/gil.hpp>
+ DummyVideoProvider::DummyVideoProvider(double fps, int frames, int width, int height, agi::Color colour, bool pattern)
+ : framecount(frames)
diff --git a/aegisub-icu64.patch b/aegisub-icu64.patch
new file mode 100644 (file)
index 0000000..1f359f2
--- /dev/null
@@ -0,0 +1,43 @@
+--- aegisub-3.2.2/libaegisub/common/character_count.cpp~       2014-12-08 01:07:09.000000000 +0100
++++ aegisub-3.2.2/libaegisub/common/character_count.cpp        2019-04-15 08:12:10.451191386 +0200
+@@ -36,7 +36,7 @@
+       static std::once_flag token;
+       std::call_once(token, [&] {
+               UErrorCode status = U_ZERO_ERROR;
+-              bi.reset(BreakIterator::createCharacterInstance(Locale::getDefault(), status));
++              bi.reset(icu::BreakIterator::createCharacterInstance(icu::Locale::getDefault(), status));
+               if (U_FAILURE(status)) throw agi::InternalError("Failed to create character iterator");
+       });
+@@ -58,7 +58,7 @@
+       size_t count = 0;
+       auto pos = character_bi.first();
+-      for (auto end = character_bi.next(); end != BreakIterator::DONE; pos = end, end = character_bi.next()) {
++      for (auto end = character_bi.next(); end != icu::BreakIterator::DONE; pos = end, end = character_bi.next()) {
+               if (!mask)
+                       ++count;
+               else {
+@@ -143,7 +143,7 @@
+       auto& bi = get_break_iterator(&str[0], str.size());
+       for (auto pos = bi.first(), end = bi.next(); ; --n, pos = end, end = bi.next()) {
+-              if (end == BreakIterator::DONE)
++              if (end == icu::BreakIterator::DONE)
+                       return str.size();
+               if (n == 0)
+                       return pos;
+--- aegisub-3.2.2/src/utils.cpp~       2019-04-15 08:06:15.502668259 +0200
++++ aegisub-3.2.2/src/utils.cpp        2019-04-15 09:01:36.733106091 +0200
+@@ -265,9 +265,9 @@
+ }
+ wxString LocalizedLanguageName(wxString const& lang) {
+-      Locale iculoc(lang.c_str());
++      icu::Locale iculoc(lang.c_str());
+       if (!iculoc.isBogus()) {
+-              UnicodeString ustr;
++              icu::UnicodeString ustr;
+               iculoc.getDisplayName(iculoc, ustr);
+ #ifdef _MSC_VER
+               return wxString(ustr.getBuffer());
index 70b10dd22b133a4cb22a6ee5904dd20f4f16c728..e4eb915c16501350668ba0ed3e1a471d798ebccb 100644 (file)
@@ -11,13 +11,15 @@ Summary:    Subtitle editor
 Summary(pl.UTF-8):     Edytor napisów
 Name:          aegisub
 Version:       3.2.2
-Release:       9
+Release:       10
 License:       BSD
 Group:         X11/Applications
 Source0:       http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
 # Source0-md5: d80e852c34811add358c06d77f5cd40d
 Patch0:                pthread.patch
 Patch1:                %{name}-icu.patch
+Patch2:                %{name}-icu64.patch
+Patch3:                %{name}-boost-1.70.patch
 URL:           http://www.aegisub.net/
 # AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
 #BuildRequires:        OpenAL-devel >= 0.0.8
@@ -86,6 +88,8 @@ obsługa tych zaawansowanych funkcji.
 %setup -q
 %patch0 -p1
 %patch1 -p1
+%patch2 -p1
+%patch3 -p1
 
 %{__mv} vendor{,.keep}
 mkdir vendor
This page took 0.046706 seconds and 4 git commands to generate.