]> git.pld-linux.org Git - packages/aegisub.git/blobdiff - aegisub.spec
rebuild with wxWidgets 3.2
[packages/aegisub.git] / aegisub.spec
index 5bac5820e0a1d86433f402c4064d7de792f5edf0..e239f60aaf9d7204cd83443c83b644d8fda67595 100644 (file)
@@ -7,41 +7,62 @@
 # Conditional build:
 %bcond_without ffms2   # build ffms2 A/V provider
 
+%define                snap    85f711f
+%define                gitrev  85f711fccc75f01fd44f25537b8777df10c4b3d1
+
 Summary:       Subtitle editor
+Summary(pl.UTF-8):     Edytor napisów
 Name:          aegisub
-Version:       3.2.0
-Release:       2
+Version:       3.2.2
+Release:       22
 License:       BSD
 Group:         X11/Applications
-Source0:       http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
-# Source0-md5: 914685eb87daf230ac8856ed81479b43
-URL:           http://www.aegisub.net/
-BuildRequires: Mesa-libGL-devel
+#Source0:      http://ftp.aegisub.org/pub/releases/%{name}-%{version}.tar.xz
+Source0:       https://github.com/Aegisub/Aegisub/archive/%{snap}/%{name}-%{version}-%{snap}.tar.gz
+# Source0-md5: ecb9b5441ead4135c9b1baec0abdec49
+Patch0:                make-4.3.patch
+Patch1:                boost181.patch
+URL:           http://www.aegisub.org/
+# AC_AGI_COMPILE tries to run test program which tries to open device and most likely fails
+#BuildRequires:        OpenAL-devel >= 0.0.8
+BuildRequires: OpenGL-devel
 BuildRequires: alsa-lib-devel
-BuildRequires: autoconf
-BuildRequires: automake
-BuildRequires: boost-devel >= 1.50
-%{?with_ffms2:BuildRequires:   ffms2-devel}
+BuildRequires: boost-devel >= 1.50.0
+%{?with_ffms2:BuildRequires:   ffms2-devel >= 2.16}
 BuildRequires: fftw3-devel >= 3.3
 BuildRequires: fontconfig-devel >= 1:2.4
+# pkgconfig(freetype2) >= 9.7.0
+BuildRequires: freetype-devel >= 1:2.1.9
 BuildRequires: gettext-tools
 BuildRequires: hunspell-devel >= 1.2.0
 BuildRequires: intltool
-BuildRequires: libass-devel
-BuildRequires: libicu-devel
+BuildRequires: libass-devel >= 0.9.7
+BuildRequires: libicu-devel >= 4.8.1.1
 BuildRequires: libstdc++-devel
 BuildRequires: lua51-devel
-BuildRequires: pkg-config >= 0.20
+BuildRequires: pkgconfig >= 1:0.20
+BuildRequires: portaudio-devel >= 19
 BuildRequires: pulseaudio-devel >= 0.5
 BuildRequires: tar >= 1:1.22
-BuildRequires: wxGTK2-unicode-gl-devel
-BuildRequires: wxWidgets-devel >= 2.9.5
+BuildRequires: uchardet-devel
+BuildRequires: wxGTK3-unicode-gl-devel >= 3.0.0
+BuildRequires: wxWidgets-devel >= 3.0.0
 BuildRequires: xz
 BuildRequires: zlib-devel
-Requires:      desktop-file-utils
-Requires:      gtk-update-icon-cache
+Requires(post,postun): desktop-file-utils
+Requires(post,postun): gtk-update-icon-cache
+Requires:      ffms2 >= 2.16
+Requires:      fftw3 >= 3.3
+Requires:      fontconfig-libs >= 1:2.4
+Requires:      freetype >= 1:2.1.9
+Requires:      hunspell >= 1.2.0
+Requires:      libass >= 0.9.7
+Requires:      libicu >= 4.8.1.1
+Requires:      pulseaudio-libs >= 0.5
+# due to luajit usage
+ExclusiveArch: %{ix86} %{x8664} arm mips ppc
 # missing atomic_ops
-ExcludeArch:   i486
+ExcludeArch:   i386 i486
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
 %description
@@ -54,20 +75,44 @@ Aegisub natively works with the Advanced SubStation Alpha format
 subtitles, apart from just basic timed text. Aegisubs goal is to
 support using these advanced functions with ease.
 
-%prep
-%setup -q
+%description -l pl.UTF-8
+Aegisub to zaawansowany edytor napisów dla Windows oraz systemów
+uniksowych, takich jak Linux, Mac OS X czy BSD. Jest to program o
+otwartych źródłach, darmowy do dowolnego użytku.
 
-mv vendor{,.keep}
+Aegisub działa natywnie na formacie Advanced SubStation Alpha (w
+stosownym skrócie ASS), pozwalającym na wiele zaawansowanych efektów w
+napisach, poza samym powiązaniem z czasem. Celem Aegisubs jest łatwa
+obsługa tych zaawansowanych funkcji.
+
+%prep
+%setup -q -n Aegisub-%{gitrev}
+%patch0 -p1
+%patch1 -p1
+
+cat <<'EOF' >build/git_version.h
+#define BUILD_GIT_VERSION_NUMBER 9010
+#define BUILD_GIT_VERSION_STRING "3.2.2.6f546951b"
+#define TAGGED_RELEASE 0
+#define INSTALLER_VERSION "0.0.0"
+#define RESOURCE_BASE_VERSION 0, 0, 0
+EOF
+
+%{__mv} vendor{,.keep}
 mkdir vendor
-mv vendor.keep/{luabins,luajit,universalchardet} vendor
+%{__mv} vendor.keep/{luabins,luajit} vendor
 
 %build
+./autogen.sh
+export C
 %configure \
-       --with-player-audio=PulseAudio \
+       --disable-compiler-flags \
        --disable-update-checker \
-       --with-wx-config=wx-gtk2-unicode-config \
+       --with-boost-libdir=%{_libdir} \
        %{__with_without ffms2} \
-       --without-oss
+       --without-oss \
+       --with-player-audio=PulseAudio \
+       --with-wx-config=wx-gtk3-unicode-config
 
 %{__make}
 
@@ -76,14 +121,13 @@ rm -rf $RPM_BUILD_ROOT
 %{__make} install \
        DESTDIR=$RPM_BUILD_ROOT
 
-ln -s %{name}-3.2 $RPM_BUILD_ROOT%{_bindir}/%{name}
-
-%{__rm} $RPM_BUILD_ROOT%{_localedir}/fr_FR
-%{__rm} $RPM_BUILD_ROOT%{_localedir}/pt_PT
-%{__rm} $RPM_BUILD_ROOT%{_localedir}/sr_RS
-%{__rm} $RPM_BUILD_ROOT%{_localedir}/sr_RS@latin
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{fr_FR,fr}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{pt_PT,pt}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{sr_RS,sr}@latin
+%{__mv} $RPM_BUILD_ROOT%{_localedir}/{uk_UA,uk}
 
-%find_lang %{name}-32
+%find_lang %{name}
 
 %clean
 rm -rf $RPM_BUILD_ROOT
@@ -96,11 +140,11 @@ rm -rf $RPM_BUILD_ROOT
 %update_desktop_database
 %update_icon_cache hicolor
 
-%files -f %{name}-32.lang
+%files -f %{name}.lang
 %defattr(644,root,root,755)
-%doc LICENCE
+%doc LICENCE README.md
 %attr(755,root,root) %{_bindir}/%{name}
-%attr(755,root,root) %{_bindir}/%{name}-3.2
 %{_datadir}/%{name}
 %{_desktopdir}/%{name}.desktop
+%{_datadir}/metainfo/aegisub.appdata.xml
 %{_iconsdir}/hicolor/*/apps/%{name}.*
This page took 0.042089 seconds and 4 git commands to generate.