]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- up to labs version 11.2.202.19
[packages/adobe-flash.git] / adobe-flash.spec
index 83ddf68fb41e6f3d80ec870631908aa9f25bc279..fe7a6783bece9bcbd4248a067f5ea56f99e0574e 100644 (file)
 #
+# TODO: package kde4 component
+#
 # Conditional build:
 %bcond_with    license_agreement       # generates package
-#
-%define                _ver_major      9
-%define                _ver_minor      0
-%define                _ver_patch      21
-%define                _ver_serial     78
-%define                base_name       macromedia-flash
+
+%define                ver32   11.2.202.19
+%define                ver64   11.2.202.19
+
+%ifarch %{ix86}
+%define                version %{ver32}
+%define                libmark %{nil}
+%endif
+%ifarch %{x8664}
+%define                version %{ver64}
+%define                libmark ()(64bit)
+%endif
+
+%define                base_name       adobe-flash
+%define                rel 1
 Summary:       Flash plugin for Netscape-compatible WWW browsers
-Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
+Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-%define                _rel 1
-Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
-Release:       %{_rel}%{?with_license_agreement:wla}
+Version:       %{version}
+Release:       %{rel}%{?with_license_agreement:wla}
+Epoch:         1
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-#Source0:      http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_101806.tar.gz
-Source0:       http://download.macromedia.com/pub/labs/flashplayer9_update/FP9_plugin_beta_112006.tar.gz
-# NoSource0-md5:       3ab408f85ae6d8180cc913edf97bf3eb
+Source0:       http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer11-2/flashplayer11-2_p1_install_lin_32_102611.tar.gz
+# NoSourceSource0-md5: 4e85ea589dc9ca6fc128380f64e21b70
+NoSource:      0
+Source1:       http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer11-2/flashplayer11-2_p1_install_lin_64_102611.tar.gz
+# NoSourceSource1-md5: 0569d9bef0025f3804b026f7a996e082
+NoSource:      1
+Source2:       mms.cfg
 %else
-Source0:       license-installer.sh
-# NoSource0-md5:       3ab408f85ae6d8180cc913edf97bf3eb
+Source3:       http://svn.pld-linux.org/svn/license-installer/license-installer.sh
+# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
 %endif
-URL:           http://labs.adobe.com/technologies/flashplayer9/
+URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
-BuildRequires: rpmbuild(macros) >= 1.236
-Requires:      browser-plugins(%{_target_base_arch})
+BuildRequires: rpmbuild(macros) >= 1.357
+BuildRequires: sed >= 4.0
+Requires:      browser-plugins >= 2.0
+# dlopened by player
+Requires:      libasound.so.2%{libmark}
+Requires:      libcurl.so.4%{libmark}
+Requires:      hicolor-icon-theme
 %else
-Requires:      rpm-build-tools
+Requires:      rpm-build-tools >= 4.4.37
+Requires:      rpmbuild(macros) >= 1.544
 %endif
+Provides:      browser(flash)
+Provides:      macromedia-flash
 Obsoletes:     flash-plugin
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     macromedia-flash
 Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     mozilla-plugin-macromedia-flash
-ExclusiveArch: %{ix86}
+ExclusiveArch: %{ix86} %{x8664}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
+%define                _sysconfdir     /etc/adobe
 
-# TODO: galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, mozilla-firefox-bin, konqueror, opera, seamonkey
-
-%description
-Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
-client runtime that delivers powerful and consistent user experiences across
-major operating systems, browsers, mobile phones, and devices. Installed on
-over 700 million Internet-connected desktops and mobile devices, Flash Player
-enables organizations and individuals to build and deliver great digital
-experiences to their end users.
+# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
+%define                _noautoreqdep   libstdc++.so.6
 
-Supported browsers: %{browsers}.
+# No debuginfo to be stored
+%define                _enable_debug_packages  0
 
-%description -l pl
-Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
+%description
+Adobe(R) Flash(R) Player for Linux - the next-generation client
+runtime for engaging with Flash content and applications on Linux.
 
-Obs³ugiwane przegl±darki: %{browsers}.
+%description -l pl.UTF-8
+Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
+treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n flash-player-plugin-%{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
+%ifarch %{x8664}
+%setup -q -T -c -b 1
+%else
+%setup -q -T -c -b 0
+%endif
+
+%build
+s=$(echo 'LNX %{version}' | tr . ,)
+v=$(strings libflashplayer.so | grep '^LNX ')
+if [ "$v" != "$s" ]; then
+       : wrong version
+       exit 1
+fi
 %endif
 
 %install
 rm -rf $RPM_BUILD_ROOT
-%if !%{with license_agreement}
+%if %{without license_agreement}
 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
 
 sed -e '
@@ -78,82 +109,49 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+       s,@DATADIR@,%{_datadir}/%{base_name},g
+' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
-install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
+cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.so $RPM_BUILD_ROOT%{_plugindir}
-
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir},%{_bindir},%{_desktopdir},%{_iconsdir}}
+cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
+#install usr/bin/flash-player-properties $RPM_BUILD_ROOT%{_bindir}
+#install usr/share/applications/flash-player-properties.desktop $RPM_BUILD_ROOT%{_desktopdir}/flash-player-properties.desktop
+#cp -a usr/share/icons/* $RPM_BUILD_ROOT%{_iconsdir}
 %endif
 
 %clean
 rm -rf $RPM_BUILD_ROOT
 
-%if !%{with license_agreement}
+%if %{without license_agreement}
 %post
 %{_bindir}/%{base_name}.install
-
 %else
-
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so
-
-%triggerin -- mozilla-firefox-bin
-%nsplugin_install -d %{_libdir}/mozilla-firefox-bin/plugins libflashplayer.so
-
-%triggerun -- mozilla-firefox-bin
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox-bin/plugins libflashplayer.so
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerin -- opera
-%nsplugin_install -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerun -- opera
-%nsplugin_uninstall -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerin -- seamonkey
-%nsplugin_install -d %{_libdir}/seamonkey/plugins libflashplayer.so
-
-%triggerun -- seamonkey
-%nsplugin_uninstall -d %{_libdir}/seamonkey/plugins libflashplayer.so
-
-# as rpm removes the old obsoleted package files after the triggers
-# above are ran, add another trigger to make the links there.
-%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- mozilla-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- konqueror-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
+%post
+%update_browser_plugins
+%update_icon_cache hicolor
+
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
+fi
+%update_icon_cache hicolor
 %endif
 
 %files
 %defattr(644,root,root,755)
-
-%if !%{with license_agreement}
+%if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%doc *.txt
-%attr(755,root,root) %{_plugindir}/*.so
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+#%attr(755,root,root) %{_bindir}/flash-player-properties
+%attr(755,root,root) %{_browserpluginsdir}/*.so
+#%{_desktopdir}/flash-player-properties.desktop
+#%{_iconsdir}/hicolor/*/apps/*.png
 %endif
This page took 0.075348 seconds and 4 git commands to generate.