]> git.pld-linux.org Git - packages/adobe-flash.git/blobdiff - adobe-flash.spec
- disable debuginfo
[packages/adobe-flash.git] / adobe-flash.spec
index 1ffe83c49566a637b01ddaaa292a6194f6a0b51f..233425ccbb9282db2222858529d3a4287438dba8 100644 (file)
@@ -1,63 +1,65 @@
+#
 # Conditional build:
 %bcond_with    license_agreement       # generates package
-
-%define                _ver_major      7
-%define                _ver_minor      0
-%define                _ver_patch      25
+#
+%define                ver_major       9
+%define                ver_minor       0
+%define                ver_patch       124
+%define                ver_serial      0
+%define                base_name       adobe-flash
+%define                rel 2
 Summary:       Flash plugin for Netscape-compatible WWW browsers
-Summary(pl):   Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape
-%define                base_name       macromedia-flash
+Summary(pl.UTF-8):     Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
 %if %{with license_agreement}
 Name:          %{base_name}
 %else
 Name:          %{base_name}-installer
 %endif
-Version:       %{_ver_major}.%{_ver_minor}.%{_ver_patch}
-Release:       2.36%{?with_license_agreement:wla}
+Version:       %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
+Release:       %{rel}%{?with_license_agreement:wla}
 License:       Free to use, non-distributable
 Group:         X11/Applications/Multimedia
 %if %{with license_agreement}
-Source0:       http://fpdownload.macromedia.com/get/shockwave/flash/english/linux/%{_ver_major}.%{_ver_minor}r%{_ver_patch}/install_flash_player_%{_ver_major}_linux.tar.gz
-# NoSource0-md5:       79c59a5ea29347e01c8e6575dd054cd1
+Source0:       http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
+# NoSource0-md5:       a311fd97aa6c214f63dc089a20cf7a39
 %else
-Source0:       license-installer.sh
+Source1:       license-installer.sh
 %endif
-URL:           http://www.macromedia.com/software/flashplayer/
+URL:           http://www.adobe.com/products/flashplayer/
 %if %{with license_agreement}
-BuildRequires: rpmbuild(macros) >= 1.236
-%endif
-Requires:      browser-plugins(%{_target_cpu})
-%if %{without license_agreement}
-Requires:      cpio
+BuildRequires: rpmbuild(macros) >= 1.357
+Requires:      browser-plugins >= 2.0
+# apparently dlopened by player
+Requires:      libasound.so.2
+%else
 Requires:      rpm-build-tools
-Requires:      wget
 %endif
+Provides:      macromedia-flash
+Provides:      browser(flash)
 Obsoletes:     flash-plugin
-Obsoletes:     mozilla-plugin-macromedia-flash
-Obsoletes:     mozilla-firefox-plugin-macromedia-flash
 Obsoletes:     konqueror-plugin-macromedia-flash
+Obsoletes:     macromedia-flash
+Obsoletes:     mozilla-firefox-plugin-macromedia-flash
+Obsoletes:     mozilla-plugin-macromedia-flash
 ExclusiveArch: %{ix86}
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
-%define                _plugindir      %{_libdir}/browser-plugins
+%define                _sysconfdir     /etc/adobe
 
-# TODO: galeon and skipstone.
-# use macro, otherwise extra LF inserted along with the ifarch
-%define        browsers mozilla, mozilla-firefox, konqueror, opera
+# No debuginfo to be stored
+%define                _enable_debug_packages  0
 
 %description
-Flash plugin for Netscape-compatible WWW browsers.
-
-Supported browsers: %{browsers}.
+Adobe(R) Flash(R) Player 9 for Linux - the next-generation client
+runtime for engaging with Flash content and applications on Linux.
 
-%description -l pl
-Wtyczka Flash dla przegl±darek WWW zgodnych z Netscape.
-
-Obs³ugiwane przegl±darki: %{browsers}.
+%description -l pl.UTF-8
+Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
+treści i aplikacji we Flashu pod Linuksem.
 
 %prep
 %if %{with license_agreement}
-%setup -q -n install_flash_player_7_linux
+%setup -q -n install_flash_player_%{ver_major}_linux
 %endif
 
 %install
@@ -71,14 +73,19 @@ sed -e '
        s-@VERSION@-%{version}-g
        s-@RELEASE@-%{release}-g
        s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
-' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
+' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
 
 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
 
 %else
 
-install -d $RPM_BUILD_ROOT%{_plugindir}
-install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
+install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
+cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
+# http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
+AutoUpdateDisable=1
+AutoUpdateInterval=0
+EOF
+install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
 
 %endif
 
@@ -86,69 +93,25 @@ install *.{so,xpt} $RPM_BUILD_ROOT%{_plugindir}
 rm -rf $RPM_BUILD_ROOT
 
 %if %{without license_agreement}
-%pre
+%post
 %{_bindir}/%{base_name}.install
-
 %else
+%post
+%update_browser_plugins
 
-%triggerin -- mozilla-firefox
-%nsplugin_install -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerun -- mozilla-firefox
-%nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerin -- mozilla
-%nsplugin_install -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
-fi
-
-%triggerun -- mozilla
-%nsplugin_uninstall -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-if [ -d /usr/%{_lib}/mozilla ]; then
-       umask 022
-       rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
-       if [ -x /usr/bin/regxpcom ]; then
-               MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
-       fi
+%postun
+if [ "$1" = 0 ]; then
+       %update_browser_plugins
 fi
-
-%triggerin -- konqueror
-%nsplugin_install -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerun -- konqueror
-%nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
-
-%triggerin -- opera
-%nsplugin_install -d %{_libdir}/opera/plugins libflashplayer.so
-
-%triggerun -- opera
-%nsplugin_uninstall -d %{_libdir}/opera/plugins libflashplayer.so
-
-# as rpm removes the old obsoleted package files after the triggers
-# above are ran, add another trigger to make the links there.
-%triggerpostun -- mozilla-firefox-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla-firefox/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- mozilla-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/mozilla/plugins libflashplayer.so flashplayer.xpt
-
-%triggerpostun -- konqueror-plugin-macromedia-flash
-%nsplugin_install -f -d %{_libdir}/kde3/plugins/konqueror libflashplayer.so
 %endif
 
 %files
 %defattr(644,root,root,755)
-
 %if %{without license_agreement}
 %attr(755,root,root) %{_bindir}/%{base_name}.install
 %{_datadir}/%{base_name}
-
 %else
-%attr(755,root,root) %{_plugindir}/*.so
-%{_plugindir}/*.xpt
+%dir %{_sysconfdir}
+%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
+%attr(755,root,root) %{_browserpluginsdir}/*.so
 %endif
This page took 0.065269 seconds and 4 git commands to generate.