]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
ee54b06b8ebade9c89f96951d057ffcd8a86964b
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         _ver_major      9
6 %define         _ver_minor      0
7 %define         _ver_patch      31
8 %define         _ver_serial     0
9 %define         base_name       macromedia-flash
10 Summary:        Flash plugin for Netscape-compatible WWW browsers
11 Summary(pl):    Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape
12 %if %{with license_agreement}
13 Name:           %{base_name}
14 %else
15 Name:           %{base_name}-installer
16 %endif
17 %define         _rel 1
18 Version:        %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
19 Release:        %{_rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
24 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
25 %else
26 Source0:        license-installer.sh
27 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
28 %endif
29 URL:            http://www.adobe.com/products/flashplayer/
30 %if %{with license_agreement}
31 BuildRequires:  rpmbuild(macros) >= 1.357
32 Requires:       browser-plugins >= 2.0
33 %else
34 Requires:       rpm-build-tools
35 %endif
36 Obsoletes:      flash-plugin
37 Obsoletes:      konqueror-plugin-macromedia-flash
38 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
39 Obsoletes:      mozilla-plugin-macromedia-flash
40 ExclusiveArch:  %{ix86}
41 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
42
43 %define         _sysconfdir     /etc/adobe
44
45 %description
46 Adobe(R) Flash(R) Player is the high-performance, lightweight, highly expressive
47 client runtime that delivers powerful and consistent user experiences across
48 major operating systems, browsers, mobile phones, and devices. Installed on
49 over 700 million Internet-connected desktops and mobile devices, Flash Player
50 enables organizations and individuals to build and deliver great digital
51 experiences to their end users.
52
53 %description -l pl
54 Wtyczka Flash dla przeglĀ±darek WWW zgodnych z Netscape.
55
56 %prep
57 %if %{with license_agreement}
58 %setup -q -n install_flash_player_%{_ver_major}_linux
59 %endif
60
61 %install
62 rm -rf $RPM_BUILD_ROOT
63 %if %{without license_agreement}
64 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
65
66 sed -e '
67         s/@BASE_NAME@/%{base_name}/g
68         s/@TARGET_CPU@/%{_target_cpu}/g
69         s-@VERSION@-%{version}-g
70         s-@RELEASE@-%{release}-g
71         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
72 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
73
74 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
75
76 %else
77
78 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
79 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
80 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
81 AutoUpdateDisable=1
82 AutoUpdateInterval=0
83 EOF
84 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
85
86 %endif
87
88 %clean
89 rm -rf $RPM_BUILD_ROOT
90
91 %if %{without license_agreement}
92 %post
93 %{_bindir}/%{base_name}.install
94 %else
95 %post
96 %update_browser_plugins
97
98 %postun
99 if [ "$1" = 0 ]; then
100         %update_browser_plugins
101 fi
102 %endif
103
104 %files
105 %defattr(644,root,root,755)
106 %if %{without license_agreement}
107 %attr(755,root,root) %{_bindir}/%{base_name}.install
108 %{_datadir}/%{base_name}
109 %else
110 %doc *.txt
111 %dir %{_sysconfdir}
112 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
113 %attr(755,root,root) %{_browserpluginsdir}/*.so
114 %endif
This page took 0.023595 seconds and 2 git commands to generate.