]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
6e092e4c4f02bc15bc0c4b20acb1cf33d507ea9d
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         ver_major       10
6 %define         ver_minor       0
7 %define         ver_patch       0
8 %define         ver_serial      0
9 %define         base_name       adobe-flash
10 %define         rel 3
11 Summary:        Flash plugin for Netscape-compatible WWW browsers
12 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
13 %if %{with license_agreement}
14 Name:           %{base_name}
15 %else
16 Name:           %{base_name}-installer
17 %endif
18 Version:        %{ver_major}.%{ver_minor}.%{ver_patch}.%{ver_serial}
19 Release:        %{rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://download.macromedia.com/pub/labs/flashplayer10/flashplayer10_install_linux_081108.tar.gz
24 # NoSource0-md5:        
25 %else
26 Source1:        license-installer.sh
27 %endif
28 URL:            http://www.adobe.com/products/flashplayer/
29 %if %{with license_agreement}
30 BuildRequires:  rpmbuild(macros) >= 1.357
31 Requires:       browser-plugins >= 2.0
32 # apparently dlopened by player
33 Requires:       libasound.so.2
34 %else
35 Requires:       rpm-build-tools
36 %endif
37 Provides:       macromedia-flash
38 Provides:       browser(flash)
39 Obsoletes:      flash-plugin
40 Obsoletes:      konqueror-plugin-macromedia-flash
41 Obsoletes:      macromedia-flash
42 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
43 Obsoletes:      mozilla-plugin-macromedia-flash
44 ExclusiveArch:  %{ix86}
45 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
46
47 %define         _sysconfdir     /etc/adobe
48
49 # No debuginfo to be stored
50 %define         _enable_debug_packages  0
51
52 %description
53 Adobe(R) Flash(R) Player 9 for Linux - the next-generation client
54 runtime for engaging with Flash content and applications on Linux.
55
56 %description -l pl.UTF-8
57 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
58 treści i aplikacji we Flashu pod Linuksem.
59
60 %prep
61 %if %{with license_agreement}
62 %setup -q -n install_flash_player_%{ver_major}_linux
63 %endif
64
65 %install
66 rm -rf $RPM_BUILD_ROOT
67 %if %{without license_agreement}
68 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
69
70 sed -e '
71         s/@BASE_NAME@/%{base_name}/g
72         s/@TARGET_CPU@/%{_target_cpu}/g
73         s-@VERSION@-%{version}-g
74         s-@RELEASE@-%{release}-g
75         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
76 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
77
78 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
79
80 %else
81
82 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
83 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
84 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
85 AutoUpdateDisable=1
86 AutoUpdateInterval=0
87 # OverrideGPUValidation=true
88 EOF
89 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
90
91 %endif
92
93 %clean
94 rm -rf $RPM_BUILD_ROOT
95
96 %if %{without license_agreement}
97 %post
98 %{_bindir}/%{base_name}.install
99 %else
100 %post
101 %update_browser_plugins
102
103 %postun
104 if [ "$1" = 0 ]; then
105         %update_browser_plugins
106 fi
107 %endif
108
109 %files
110 %defattr(644,root,root,755)
111 %if %{without license_agreement}
112 %attr(755,root,root) %{_bindir}/%{base_name}.install
113 %{_datadir}/%{base_name}
114 %else
115 %dir %{_sysconfdir}
116 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
117 %attr(755,root,root) %{_browserpluginsdir}/*.so
118 %endif
This page took 0.058745 seconds and 2 git commands to generate.