]> git.pld-linux.org Git - packages/adobe-flash.git/blob - adobe-flash.spec
58278605065de2d7b6ded61818d47ed044a03f92
[packages/adobe-flash.git] / adobe-flash.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         _ver_major      9
6 %define         _ver_minor      0
7 %define         _ver_patch      31
8 %define         _ver_serial     0
9 %define         base_name       adobe-flash
10 Summary:        Flash plugin for Netscape-compatible WWW browsers
11 Summary(pl.UTF-8):      Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
12 %if %{with license_agreement}
13 Name:           %{base_name}
14 %else
15 Name:           %{base_name}-installer
16 %endif
17 %define         _rel 1
18 Version:        %{_ver_major}.%{_ver_minor}.%{_ver_patch}.%{_ver_serial}
19 Release:        %{_rel}%{?with_license_agreement:wla}
20 License:        Free to use, non-distributable
21 Group:          X11/Applications/Multimedia
22 %if %{with license_agreement}
23 Source0:        http://fpdownload.macromedia.com/get/flashplayer/current/install_flash_player_9_linux.tar.gz
24 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
25 %else
26 Source0:        license-installer.sh
27 # NoSource0-md5:        76b38231a68995935185aa42dfda9db7
28 %endif
29 URL:            http://www.adobe.com/products/flashplayer/
30 %if %{with license_agreement}
31 BuildRequires:  rpmbuild(macros) >= 1.357
32 Requires:       browser-plugins >= 2.0
33 %else
34 Requires:       rpm-build-tools
35 %endif
36 Provides:       macromedia-flash
37 Obsoletes:      flash-plugin
38 Obsoletes:      konqueror-plugin-macromedia-flash
39 Obsoletes:      macromedia-flash
40 Obsoletes:      mozilla-firefox-plugin-macromedia-flash
41 Obsoletes:      mozilla-plugin-macromedia-flash
42 ExclusiveArch:  %{ix86}
43 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
44
45 %define         _sysconfdir     /etc/adobe
46
47 %description
48 Adobe(R) Flash(R) Player 9 for Linux - the next-generation client
49 runtime for engaging with Flash content and applications on Linux.
50
51 %description -l pl.UTF-8
52 Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
53 treści i aplikacji we Flashu pod Linuksem.
54
55 %prep
56 %if %{with license_agreement}
57 %setup -q -n install_flash_player_%{_ver_major}_linux
58 %endif
59
60 %install
61 rm -rf $RPM_BUILD_ROOT
62 %if %{without license_agreement}
63 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
64
65 sed -e '
66         s/@BASE_NAME@/%{base_name}/g
67         s/@TARGET_CPU@/%{_target_cpu}/g
68         s-@VERSION@-%{version}-g
69         s-@RELEASE@-%{release}-g
70         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
71 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
72
73 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
74
75 %else
76
77 install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir}}
78 cat <<'EOF' > $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
79 # http://www.adobe.com/cfusion/knowledgebase/index.cfm?id=16701594
80 AutoUpdateDisable=1
81 AutoUpdateInterval=0
82 EOF
83 install *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
84
85 %endif
86
87 %clean
88 rm -rf $RPM_BUILD_ROOT
89
90 %if %{without license_agreement}
91 %post
92 %{_bindir}/%{base_name}.install
93 %else
94 %post
95 %update_browser_plugins
96
97 %postun
98 if [ "$1" = 0 ]; then
99         %update_browser_plugins
100 fi
101 %endif
102
103 %files
104 %defattr(644,root,root,755)
105 %if %{without license_agreement}
106 %attr(755,root,root) %{_bindir}/%{base_name}.install
107 %{_datadir}/%{base_name}
108 %else
109 %doc *.txt
110 %dir %{_sysconfdir}
111 %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
112 %attr(755,root,root) %{_browserpluginsdir}/*.so
113 %endif
This page took 0.14744 seconds and 2 git commands to generate.