]> git.pld-linux.org Git - packages/adobe-flash.git/blame - adobe-flash.spec
- up to labs version 11.2.202.19
[packages/adobe-flash.git] / adobe-flash.spec
CommitLineData
e9cc6da3 1#
5e166df9
AF
2# TODO: package kde4 component
3#
aa3cbbce 4# Conditional build:
5%bcond_with license_agreement # generates package
5e166df9 6
6df44cc6
AM
7%define ver32 11.2.202.19
8%define ver64 11.2.202.19
84bf8124 9
e6d2385a 10%ifarch %{ix86}
84bf8124 11%define version %{ver32}
e6d2385a
ER
12%define libmark %{nil}
13%endif
e0aacdca 14%ifarch %{x8664}
84bf8124 15%define version %{ver64}
e6d2385a 16%define libmark ()(64bit)
b18d4034 17%endif
19d7e29f 18
fdeb48aa 19%define base_name adobe-flash
5e166df9 20%define rel 1
53f15d83 21Summary: Flash plugin for Netscape-compatible WWW browsers
989db712 22Summary(pl.UTF-8): Wtyczka Flash dla przeglądarek WWW zgodnych z Netscape
aa3cbbce 23%if %{with license_agreement}
24Name: %{base_name}
25%else
26Name: %{base_name}-installer
27%endif
84bf8124 28Version: %{version}
5e11dd18 29Release: %{rel}%{?with_license_agreement:wla}
4ec0200b 30Epoch: 1
53f15d83 31License: Free to use, non-distributable
01b5e1fb 32Group: X11/Applications/Multimedia
aa3cbbce 33%if %{with license_agreement}
6df44cc6
AM
34Source0: http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer11-2/flashplayer11-2_p1_install_lin_32_102611.tar.gz
35# NoSourceSource0-md5: 4e85ea589dc9ca6fc128380f64e21b70
364b3cd0 36NoSource: 0
6df44cc6
AM
37Source1: http://download.macromedia.com/pub/labs/flashplatformruntimes/flashplayer11-2/flashplayer11-2_p1_install_lin_64_102611.tar.gz
38# NoSourceSource1-md5: 0569d9bef0025f3804b026f7a996e082
e0aacdca 39NoSource: 1
63f88470 40Source2: mms.cfg
18284157 41%else
63f88470
ER
42Source3: http://svn.pld-linux.org/svn/license-installer/license-installer.sh
43# Source3-md5: 329c25f457fea66ec502b7ef70cb9ede
aa3cbbce 44%endif
ba9bcac5 45URL: http://www.adobe.com/products/flashplayer/
b68eb59b 46%if %{with license_agreement}
df79ad5e 47BuildRequires: rpmbuild(macros) >= 1.357
5f855dbc 48BuildRequires: sed >= 4.0
df79ad5e 49Requires: browser-plugins >= 2.0
15b3da69 50# dlopened by player
b18d4034
AM
51Requires: libasound.so.2%{libmark}
52Requires: libcurl.so.4%{libmark}
5e166df9 53Requires: hicolor-icon-theme
94ae04b2 54%else
1fe695bf 55Requires: rpm-build-tools >= 4.4.37
9377eeca 56Requires: rpmbuild(macros) >= 1.544
533db319 57%endif
bcccd50e 58Provides: browser(flash)
5f855dbc 59Provides: macromedia-flash
533db319 60Obsoletes: flash-plugin
533db319 61Obsoletes: konqueror-plugin-macromedia-flash
5891b1a0 62Obsoletes: macromedia-flash
a00d2cc2
ER
63Obsoletes: mozilla-firefox-plugin-macromedia-flash
64Obsoletes: mozilla-plugin-macromedia-flash
e0aacdca 65ExclusiveArch: %{ix86} %{x8664}
01b5e1fb
PG
66BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
67
ed1085d2
ER
68%define _sysconfdir /etc/adobe
69
0fa08e0e
ER
70# So that building package on AC system won't write package name dep that Th system can't understand (libstdc++4)
71%define _noautoreqdep libstdc++.so.6
72
1fe30e9c
ER
73# No debuginfo to be stored
74%define _enable_debug_packages 0
75
01b5e1fb 76%description
65fff478 77Adobe(R) Flash(R) Player for Linux - the next-generation client
e338620c 78runtime for engaging with Flash content and applications on Linux.
53f15d83 79
5f2286aa
JR
80%description -l pl.UTF-8
81Adobe(R) Flash(R) Player - środowisko nowej generacji do obsługi
82treści i aplikacji we Flashu pod Linuksem.
53f15d83 83
01b5e1fb 84%prep
aa3cbbce 85%if %{with license_agreement}
b18d4034
AM
86%ifarch %{x8664}
87%setup -q -T -c -b 1
88%else
3170126a 89%setup -q -T -c -b 0
b18d4034 90%endif
d4052f7c
ER
91
92%build
e6d2385a 93s=$(echo 'LNX %{version}' | tr . ,)
7673fff0 94v=$(strings libflashplayer.so | grep '^LNX ')
d4052f7c
ER
95if [ "$v" != "$s" ]; then
96 : wrong version
97 exit 1
98fi
3a950945 99%endif
d6511d55 100
01b5e1fb
PG
101%install
102rm -rf $RPM_BUILD_ROOT
ed1085d2 103%if %{without license_agreement}
aa3cbbce 104install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
105
18284157
ER
106sed -e '
107 s/@BASE_NAME@/%{base_name}/g
108 s/@TARGET_CPU@/%{_target_cpu}/g
109 s-@VERSION@-%{version}-g
110 s-@RELEASE@-%{release}-g
111 s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
03482652 112 s,@DATADIR@,%{_datadir}/%{base_name},g
63f88470 113' %{SOURCE3} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
aa3cbbce 114
63f88470 115cp -p %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
aa3cbbce 116
117%else
118
5e166df9 119install -d $RPM_BUILD_ROOT{%{_sysconfdir},%{_browserpluginsdir},%{_bindir},%{_desktopdir},%{_iconsdir}}
63f88470
ER
120cp -p %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/mms.cfg
121install -p *.so $RPM_BUILD_ROOT%{_browserpluginsdir}
6df44cc6
AM
122#install usr/bin/flash-player-properties $RPM_BUILD_ROOT%{_bindir}
123#install usr/share/applications/flash-player-properties.desktop $RPM_BUILD_ROOT%{_desktopdir}/flash-player-properties.desktop
124#cp -a usr/share/icons/* $RPM_BUILD_ROOT%{_iconsdir}
aa3cbbce 125%endif
126
01b5e1fb
PG
127%clean
128rm -rf $RPM_BUILD_ROOT
129
df79ad5e 130%if %{without license_agreement}
ae33c71b 131%post
18284157 132%{_bindir}/%{base_name}.install
533db319 133%else
df79ad5e
ER
134%post
135%update_browser_plugins
5e166df9 136%update_icon_cache hicolor
533db319 137
df79ad5e
ER
138%postun
139if [ "$1" = 0 ]; then
140 %update_browser_plugins
141fi
5e166df9 142%update_icon_cache hicolor
533db319
ER
143%endif
144
aa3cbbce 145%files
146%defattr(644,root,root,755)
df79ad5e 147%if %{without license_agreement}
aa3cbbce 148%attr(755,root,root) %{_bindir}/%{base_name}.install
149%{_datadir}/%{base_name}
aa3cbbce 150%else
ed1085d2
ER
151%dir %{_sysconfdir}
152%config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/mms.cfg
6df44cc6 153#%attr(755,root,root) %{_bindir}/flash-player-properties
df79ad5e 154%attr(755,root,root) %{_browserpluginsdir}/*.so
6df44cc6
AM
155#%{_desktopdir}/flash-player-properties.desktop
156#%{_iconsdir}/hicolor/*/apps/*.png
aa3cbbce 157%endif
This page took 0.049125 seconds and 4 git commands to generate.