]> git.pld-linux.org Git - packages/adeos.git/commitdiff
- add weekly cron-job - works fine
authorPaweł Gołaszewski <blues@pld-linux.org>
Tue, 4 Jun 2002 10:49:48 +0000 (10:49 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
STBR

Changed files:
    adeos.spec -> 1.2

adeos.spec

index 33743ab97ae42253b78583b863f11a8c0a9b3086..aead7cff9b7327c5b4af7016c9bf5c91fd7cea2f 100644 (file)
@@ -6,9 +6,13 @@ Release:       1
 Group:         Applications/System
 License:       GPL v2
 Source0:       http://linux.wku.edu/~lamonml/software/adeos/%{name}-%{version}.tar.bz2
+Requires:      crondaemon
+Requires:      webserver
 URL:           http://linux.wku.edu/~lamonml/software/adeos/
 BuildRoot:     %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
 
+%define                _wwwdir         /home/httpd/html/%{name}
+
 %description
 Adeos (named after the obscure Roman goddess of modesty) is an
 automated filesystem security scanner. It recursively walks all
@@ -32,10 +36,18 @@ czy pliki zapisywalne dla wszystkich.
 
 %install
 rm -rf $RPM_BUILD_ROOT
-install -d $RPM_BUILD_ROOT%{_bindir}
+install -d $RPM_BUILD_ROOT{%{_bindir},/etc/cron.weekly,%{_wwwdir}}
 
 install %{name}        $RPM_BUILD_ROOT%{_bindir}
 
+cat > $RPM_BUILD_ROOT/etc/cron.weekly/%{name}.sh <<EOF
+cd %{_wwwdir}
+%{_bindir}/%{name} -h
+chmod a+r result.html
+EOF
+
+touch $RPM_BUILD_ROOT%{_wwwdir}/result.html
+
 %clean
 rm -rf $RPM_BUILD_ROOT
 
@@ -43,3 +55,6 @@ rm -rf $RPM_BUILD_ROOT
 %defattr(644,root,root,755)
 %doc CHANGELOG README
 %attr(755,root,root) %{_bindir}/*
+%dir %{_wwwdir}
+%ghost %{_wwwdir}/result.html
+%attr(755,root,root) %config(noreplace) /etc/cron.weekly/%{name}.sh
This page took 0.072285 seconds and 4 git commands to generate.