]> git.pld-linux.org Git - packages/acx.git/blob - acx.spec
- fixed smp only build
[packages/acx.git] / acx.spec
1 # TODO:
2 # - add firmware download?
3 #
4 # Conditional build:
5 %bcond_without  dist_kernel     # without distribution kernel
6 %bcond_without  up              # don't build UP module
7 %bcond_without  smp             # don't build SMP module
8 #
9 %ifarch sparc
10 %undefine       with_smp
11 %endif
12 #
13 Summary:        Linux driver for WLAN card base on ACX100/ACX111
14 Summary(pl.UTF-8):      Sterownik dla Linuksa do kart bezprzewodowych na układzie ACX100/ACX111
15 Name:           acx
16 Version:        20070101
17 %define _rel    2
18 Release:        %{_rel}
19 License:        MPL or GPL
20 Group:          Base/Kernel
21 Source0:        http://www.cmartin.tk/acx/%{name}-%{version}.tar.bz2
22 # Source0-md5:  ec6322b9c82781897a9433ef0cefda6f
23 URL:            http://acx100.sourceforge.net/
24 %{?with_dist_kernel:BuildRequires:      kernel%{_alt_kernel}-module-build >= 3:2.6.16}
25 BuildRequires:  rpmbuild(macros) >= 1.330
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 This is driver for WLAN card based on ACX100/ACX111 for Linux.
30
31 %description -l pl.UTF-8
32 Sterownik dla Linuksa do kart WLAN opartych o układ ACX100/ACX111.
33
34 %package -n kernel%{_alt_kernel}-net-acx
35 Summary:        Linux driver for WLAN card base on ACX100/ACX111
36 Summary(pl.UTF-8):      Sterownik dla Linuksa do kart bezprzewodowych na układzie ACX100/ACX111
37 Release:        %{_rel}@%{_kernel_ver_str}
38 Group:          Base/Kernel
39 Obsoletes:      kernel%{_alt_kernel}-net-acx100
40 %{?with_dist_kernel:%requires_releq_kernel_up}
41 Requires(post,postun):  /sbin/depmod
42
43 %description -n kernel%{_alt_kernel}-net-acx
44 This is driver for WLAN card based on ACX100/ACX111 for Linux.
45
46 %description -n kernel%{_alt_kernel}-net-acx -l pl.UTF-8
47 Sterownik dla Linuksa do kart WLAN opartych o układ ACX100/ACX111.
48
49 %package -n kernel%{_alt_kernel}-smp-net-acx
50 Summary:        Linux SMP driver for WLAN card base on ACX100/ACX111
51 Summary(pl.UTF-8):      Sterownik dla Linuksa SMP do kart bezprzewodowych na układzie ACX100/ACX111
52 Release:        %{_rel}@%{_kernel_ver_str}
53 Group:          Base/Kernel
54 Obsoletes:      kernel%{_alt_kernel}-smp-net-acx100
55 %{?with_dist_kernel:%requires_releq_kernel_smp}
56 Requires(post,postun):  /sbin/depmod
57
58 %description -n kernel%{_alt_kernel}-smp-net-acx
59 Linux SMP driver for WLAN card base on ACX100/ACX111.
60
61 %description -n kernel%{_alt_kernel}-smp-net-acx -l pl.UTF-8
62 Sterownik dla Linuksa SMP do kart bezprzewodowych na układzie ACX100/ACX111.
63
64 %prep
65 %setup -q
66
67 %build
68 %build_kernel_modules -m acx
69
70 %install
71 rm -rf $RPM_BUILD_ROOT
72
73 %install_kernel_modules -m acx -d misc
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %post   -n kernel%{_alt_kernel}-net-acx
79 %depmod %{_kernel_ver}
80
81 %postun -n kernel%{_alt_kernel}-net-acx
82 %depmod %{_kernel_ver}
83
84 %post   -n kernel%{_alt_kernel}-smp-net-acx
85 %depmod %{_kernel_ver}smp
86
87 %postun -n kernel%{_alt_kernel}-smp-net-acx
88 %depmod %{_kernel_ver}smp
89
90 %if %{with up}
91 %files -n kernel%{_alt_kernel}-net-acx
92 %defattr(644,root,root,755)
93 %doc Changelog README
94 /lib/modules/%{_kernel_ver}/misc/*.ko*
95 %endif
96
97 %if %{with smp}
98 %files -n kernel%{_alt_kernel}-smp-net-acx
99 %defattr(644,root,root,755)
100 %doc Changelog README
101 /lib/modules/%{_kernel_ver}smp/misc/*.ko*
102 %endif
This page took 0.067185 seconds and 4 git commands to generate.