]> git.pld-linux.org Git - packages/acroread.git/blob - acroread.spec
- removed obsolete rm
[packages/acroread.git] / acroread.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         base_name       acroread
6 %define         rel             3
7 Summary:        Adobe Acrobat Reader
8 Summary(pl.UTF-8):      Adobe Acrobat Reader - czytnik plików PDF
9 Summary(ru.UTF-8):      Программа для чтения документов в формате PDF от Adobe
10 Summary(uk.UTF-8):      Програма для читання документів у форматі PDF від Adobe
11 %if %{with license_agreement}
12 Name:           %{base_name}
13 %else
14 Name:           %{base_name}-installer
15 %endif
16 Version:        9.4.2
17 Release:        %{rel}%{?with_license_agreement:wla}
18 Epoch:          1
19 License:        distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20 # in short:
21 # - not distributable on public sites (only linking to adobe.com permitted)
22 # - distribution on CD requires signing Distribution Agreement (see URL above)
23 Group:          X11/Applications/Graphics
24 %if %{with license_agreement}
25 Source0:        ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr9.4.2-1_i486linux_enu.tar.bz2
26 # NoSource0-md5:        307aaaf22e8c08958927dfabb0f4d745
27 NoSource:       0
28 %else
29 Source1:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
30 # Source1-md5:  329c25f457fea66ec502b7ef70cb9ede
31 %endif
32 # please update @COPYSOURCES@ below if you add more Sources or Patches.
33 Source2:        %{base_name}.desktop
34 Source3:        %{base_name}.png
35 URL:            http://www.adobe.com/products/acrobat/
36 %if %{with license_agreement}
37 BuildRequires:  rpmbuild(macros) >= 1.357
38 Requires:       ca-certificates >= 20080809-4
39 Requires:       iconv
40 Requires:       openldap-libs < 2.5
41 Requires:       openldap-libs >= 2.4
42 %else
43 Requires:       rpm-build-tools >= 4.4.37
44 Requires:       rpmbuild(macros) >= 1.544
45 %endif
46 ExclusiveArch:  %{ix86}
47 ExcludeArch:    i386
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         platform        intellinux
51 %define         tar0            ILINXR.TAR
52 %define         tar1            COMMON.TAR
53
54 %define         _noautostrip    .*\.api
55 %define         _noautoprov     libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
56 %define         _noautoreq      %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
57 %define         no_install_post_check_so        1
58 %define         skip_post_check_so libWRServices.so.3.1 libadobelinguistic.so.3.2.0 libauthplay.so.0.0.0
59
60 %description
61 Adobe(R) Reader(R) is free software that lets you view and print PDF
62 files (Portable Document Format) on a variety of hardware and
63 operating system platforms.
64
65 %description -l pl.UTF-8
66 Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
67 oglądanie oraz drukowanie plików PDF (Portable Document Format) na
68 różnych platformach sprzętowych oraz różnych systemach operacyjnych.
69
70 %description -l ru.UTF-8
71 Программа для чтения документов в формате Portable Document Format
72 (PDF), сгенерированных Adobe Acrobat'ом.
73
74 %description -l uk.UTF-8
75 Програма для читання документів у форматі Portable Document Format
76 (PDF), згенерованих Adobe Acrobat'ом.
77
78 %package -n browser-plugin-%{name}
79 Summary:        PDF plugin for Mozilla compatible browsers
80 Summary(pl.UTF-8):      Wtyczka PDF dla przeglądarek zgodnych Mozilla
81 Group:          X11/Applications
82 Requires:       %{base_name} = %{epoch}:%{version}-%{release}
83 Requires:       browser-plugins >= 2.0
84 Obsoletes:      acroread-plugin
85 Obsoletes:      mozilla-plugin-acroread
86
87 %description -n browser-plugin-%{name}
88 A Mozilla plugin for displaying PDF (Portable Document Format) files.
89
90 %description -n browser-plugin-%{name} -l pl.UTF-8
91 Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
92
93 %prep
94 %if %{with license_agreement}
95 %setup -q -c
96 cd AdobeReader
97 tar xf %{tar0}
98 tar xf %{tar1}
99 %endif
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %if %{without license_agreement}
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
105
106 sed -e '
107         s/@BASE_NAME@/%{base_name}/g
108         s/@TARGET_CPU@/%{_target_cpu}/g
109         s-@VERSION@-%{version}-g
110         s-@RELEASE@-%{release}-g
111         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
112         s,@DATADIR@,%{_datadir}/%{base_name},g
113         s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
114 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
115
116 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
118 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
119
120 %else
121 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name}/bin} \
122         $RPM_BUILD_ROOT{%{_browserpluginsdir},%{_desktopdir},%{_pixmapsdir}}
123
124 cd AdobeReader/Adobe/Reader9
125 cp -a Browser Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
126 %{__rm} $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Browser/install_browser_plugin
127 awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
128         '/^install_dir=/ {print "install_dir="INSTDIR; next} \
129         {print}' \
130         bin/%{base_name} > $RPM_BUILD_ROOT%{_libdir}/%{base_name}/bin/%{base_name}
131
132 # IMPORTANT NOTE: Here symlinks must be used instead of moving parts of tree
133 # for compatibility with other binary-only Adobe software (like AIR).
134 # This one is required to find Reader tree (relative to symlink target)...
135 ln -sf %{_libdir}/%{base_name}/bin/%{base_name} $RPM_BUILD_ROOT%{_bindir}/%{base_name}
136 # ...and nppdf plugin is expected in Browser subdir...
137 # ...so just symlink it to be used as browsers plugin.
138 ln -sf %{_libdir}/%{base_name}/Browser/%{platform}/nppdf.so $RPM_BUILD_ROOT%{_browserpluginsdir}/nppdf.so
139
140 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
141 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
142
143 ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
144 ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
145 ln -sf /etc/certs/ca-certificates.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
146
147 # don't generate dependencies for internal libs
148 chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
149 %endif
150
151 %clean
152 rm -rf $RPM_BUILD_ROOT
153
154 %if %{without license_agreement}
155 %post
156 %{_bindir}/%{base_name}.install
157 %endif
158
159 %if %{with license_agreement}
160 %post -n browser-plugin-%{name}
161 %update_browser_plugins
162
163 %postun -n browser-plugin-%{name}
164 if [ "$1" = 0 ]; then
165         %update_browser_plugins
166 fi
167 %endif
168
169 %files
170 %defattr(644,root,root,755)
171 %if %{without license_agreement}
172 %attr(755,root,root) %{_bindir}/%{base_name}.install
173 %{_datadir}/%{base_name}
174 %else
175 %doc AdobeReader/ReadMe.htm
176 %attr(755,root,root) %{_bindir}/acroread
177 %dir %{_libdir}/%{base_name}
178 %dir %{_libdir}/%{base_name}/Browser
179 %dir %{_libdir}/%{base_name}/Browser/%{platform}
180 %attr(755,root,root) %{_libdir}/%{base_name}/Browser/%{platform}/nppdf.so
181 %{_libdir}/%{base_name}/Browser/HowTo
182 %dir %{_libdir}/%{base_name}/Reader
183 %{_libdir}/%{base_name}/Reader/help
184 %{_libdir}/%{base_name}/Reader/AcroVersion
185 %{_libdir}/%{base_name}/Reader/Cert
186 %{_libdir}/%{base_name}/Reader/GlobalPrefs
187 %{_libdir}/%{base_name}/Reader/IDTemplates
188 %{_libdir}/%{base_name}/Reader/JavaScripts
189 %{_libdir}/%{base_name}/Reader/Legal
190 %{_libdir}/%{base_name}/Reader/Tracker
191 %{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
192 %{_libdir}/%{base_name}/Reader/pmd.cer
193 %{_libdir}/%{base_name}/Reader/%{platform}/mozilla
194 %dir %{_libdir}/%{base_name}/Reader/%{platform}
195 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
196 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
197 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
198 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
199 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
200 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
201 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
202 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
203 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
204 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
205 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
206 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
207 %{_libdir}/%{base_name}/Resource
208 %dir %{_libdir}/%{base_name}/bin
209 %attr(755,root,root) %{_libdir}/%{base_name}/bin/acroread
210 %{_desktopdir}/acroread.desktop
211 %{_pixmapsdir}/acroread.png
212
213 %files -n browser-plugin-%{name}
214 %defattr(644,root,root,755)
215 %attr(755,root,root) %{_browserpluginsdir}/nppdf.so
216 %endif
This page took 0.048042 seconds and 4 git commands to generate.