]> git.pld-linux.org Git - packages/acroread.git/blob - acroread.spec
- updated symlinks for openldap 2.4.x
[packages/acroread.git] / acroread.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         base_name       acroread
6 Summary:        Adobe Acrobat Reader
7 Summary(pl.UTF-8):      Adobe Acrobat Reader - czytnik plików PDF
8 Summary(ru.UTF-8):      Программа для чтения документов в формате PDF от Adobe
9 Summary(uk.UTF-8):      Програма для читання документів у форматі PDF від Adobe
10 %if %{with license_agreement}
11 Name:           %{base_name}
12 %else
13 Name:           %{base_name}-installer
14 %endif
15 %define _rel    1
16 Version:        8.1.1
17 Release:        %{_rel}%{?with_license_agreement:wla}
18 Epoch:          1
19 License:        distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20 # in short:
21 # - not distributable on public sites (only linking to adobe.com permitted)
22 # - distribution on CD requires signing Distribution Agreement (see URL above)
23 Group:          X11/Applications/Graphics
24 %if %{with license_agreement}
25 Source0:        http://ardownload.adobe.com/pub/adobe/reader/unix/8.x/%{version}/enu/AdobeReader_enu-%{version}-1.i486.tar.gz
26 # NoSource0-md5:        e7630311c597feff26024c3383eab110
27 NoSource:       0
28 %else
29 Source0:        license-installer.sh
30 %endif
31 # please update @COPYSOURCES@ below if you add more Sources or Patches.
32 Source1:        %{base_name}.desktop
33 Source2:        %{base_name}.png
34 URL:            http://www.adobe.com/products/acrobat/
35 %if %{with license_agreement}
36 BuildRequires:  rpmbuild(macros) >= 1.236
37 Requires:       openldap-libs >= 2.4
38 Requires:       openldap-libs < 2.5
39 %else
40 Requires:       rpm-build-tools
41 %endif
42 ExclusiveArch:  %{ix86}
43 ExcludeArch:    i386
44 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
45
46 %define         _plugindir      %{_libdir}/browser-plugins
47
48 # TODO: galeon and skipstone, konqueror, opera.
49 # use macro, otherwise extra LF inserted along with the ifarch
50 %define browsers mozilla, mozilla-firefox, seamonkey
51
52 %define         platform        intellinux
53 %define         tar0            ILINXR.TAR
54 %define         tar1            COMMON.TAR
55
56 %define         _noautostrip    .*\.api
57 %define         _noautoprov     libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.* 
58 %define         _noautoreq      %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
59
60 %description
61 Adobe(R) Reader(R) is free software that lets you view and print PDF
62 files (Portable Document Format) on a variety of hardware and
63 operating system platforms.
64
65 %description -l pl.UTF-8
66 Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
67 oglądanie oraz drukowanie plików PDF (Portable Document Format) na
68 różnych platformach sprzętowych oraz różnych systemach operacyjnych.
69
70 %description -l ru.UTF-8
71 Программа для чтения документов в формате Portable Document Format
72 (PDF), сгенерированных Adobe Acrobat'ом.
73
74 %description -l uk.UTF-8
75 Програма для читання документів у форматі Portable Document Format
76 (PDF), згенерованих Adobe Acrobat'ом.
77
78 %package -n browser-plugin-%{name}
79 Summary:        PDF plugin for Mozilla compatible browsers
80 Summary(pl.UTF-8):      Wtyczka PDF dla przeglądarek zgodnych Mozilla
81 Group:          X11/Applications
82 Requires:       %{base_name} = %{epoch}:%{version}-%{release}
83 Requires:       browser-plugins(%{_target_base_arch})
84 Obsoletes:      acroread-plugin
85 Obsoletes:      mozilla-plugin-acroread
86
87 %description -n browser-plugin-%{name}
88 A Mozilla plugin for displaying PDF (Portable Document Format) files.
89
90 %description -n browser-plugin-%{name} -l pl.UTF-8
91 Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
92
93 %prep
94 %if %{with license_agreement}
95 %setup -q -c
96 cd AdobeReader
97 tar xf %{tar0}
98 tar xf %{tar1}
99 %endif
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %if %{without license_agreement}
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
105
106 sed -e '
107         s/@BASE_NAME@/%{base_name}/g
108         s/@TARGET_CPU@/%{_target_cpu}/g
109         s-@VERSION@-%{version}-g
110         s-@RELEASE@-%{release}-g
111         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
112         s,@DATADIR@,%{_datadir}/%{base_name},g
113         s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
114 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
115
116 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
117 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
118 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
119
120 %else
121 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
122         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
123
124 # note: there're also AdobeReader/Adobe/Help{,Viewer}
125 cd AdobeReader/Adobe/Reader8
126 cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
127 awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
128         '/^install_dir=/ {print "install_dir="INSTDIR; next} \
129         {print}' \
130         bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
131 install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
132 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
136
137 ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
138 ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
139 ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
140
141 chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
142 %endif
143
144 %clean
145 rm -rf $RPM_BUILD_ROOT
146
147 %if %{without license_agreement}
148 %post
149 %{_bindir}/%{base_name}.install
150
151 %else
152
153 %triggerin -n browser-plugin-%{name} -- mozilla-firefox
154 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
155
156 %triggerun -n browser-plugin-%{name} -- mozilla-firefox
157 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
158
159 %triggerin -n browser-plugin-%{name} -- mozilla
160 %nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
161
162 %triggerun -n browser-plugin-%{name} -- mozilla
163 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
164
165 %triggerin -n browser-plugin-%{name} -- seamonkey
166 %nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
167
168 %triggerun -n browser-plugin-%{name} -- seamonkey
169 %nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
170
171 # % triggerin -n browser-plugin-%{name} -- konqueror
172 # % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
173
174 # % triggerun -n browser-plugin-%{name} -- konqueror
175 # % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
176
177 # % triggerin -n browser-plugin-%{name} -- opera
178 # % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
179
180 # % triggerun -n browser-plugin-%{name} -- opera
181 # % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
182
183 # as rpm removes the old obsoleted package files after the triggers
184 # above are ran, add another trigger to make the links there.
185 %triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
186 %nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
187
188 %endif
189
190 %files
191 %defattr(644,root,root,755)
192 %if %{without license_agreement}
193 %attr(755,root,root) %{_bindir}/%{base_name}.install
194 %{_datadir}/%{base_name}
195 %else
196 %doc AdobeReader/ReadMe.htm
197 %attr(755,root,root) %{_bindir}/*
198 %dir %{_libdir}/%{base_name}
199 %{_libdir}/%{base_name}/Resource
200 %dir %{_libdir}/%{base_name}/Reader
201 %{_libdir}/%{base_name}/Reader/help
202 %{_libdir}/%{base_name}/Reader/AcroVersion
203 %{_libdir}/%{base_name}/Reader/BeyondReader
204 %{_libdir}/%{base_name}/Reader/Cert
205 %{_libdir}/%{base_name}/Reader/GlobalPrefs
206 %{_libdir}/%{base_name}/Reader/HowTo
207 %{_libdir}/%{base_name}/Reader/IDTemplates
208 %{_libdir}/%{base_name}/Reader/JavaScripts
209 %{_libdir}/%{base_name}/Reader/Legal
210 %{_libdir}/%{base_name}/Reader/Tracker
211 %{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
212 %{_libdir}/%{base_name}/Reader/pmd.cer
213 %{_libdir}/%{base_name}/Reader/%{platform}/mozilla
214 %dir %{_libdir}/%{base_name}/Reader/%{platform}
215 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
216 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
217 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
218 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
219 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
220 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
221 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
222 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
223 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
224 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
225 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
226 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
227 %{_desktopdir}/acroread.desktop
228 %{_pixmapsdir}/*
229
230 %files -n browser-plugin-%{name}
231 %defattr(644,root,root,755)
232 %attr(755,root,root) %{_plugindir}/*
233 %endif
This page took 0.080708 seconds and 4 git commands to generate.