]> git.pld-linux.org Git - packages/acroread.git/blob - acroread.spec
- rel 4
[packages/acroread.git] / acroread.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         base_name       acroread
6 Summary:        Acrobat Reader
7 Summary(pl):    Acrobat Reader - czytnik plików PDF
8 Summary(ru):    ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ PDF ÏÔ Adobe
9 Summary(uk):    ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ PDF ×¦Ä Adobe
10 %if %{with license_agreement}
11 Name:           %{base_name}
12 %else
13 Name:           %{base_name}-installer
14 %endif
15 %define _rel    4
16 Version:        7.0.8
17 Release:        %{_rel}%{?with_license_agreement:wla}
18 Epoch:          1
19 License:        distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20 # in short:
21 # - not distributable on public sites (only linking to adobe.com permitted)
22 # - distribution on CD requires signing Distribution Agreement (see URL above)
23 Group:          X11/Applications/Graphics
24 %if %{with license_agreement}
25 Source0:        http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.8/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
26 %else
27 Source0:        license-installer.sh
28 %endif
29 # please update @COPYSOURCES@ below if you add more Sources.
30 Source1:        %{base_name}.desktop
31 Source2:        %{base_name}.png
32 Patch0:         %{base_name}-expr.patch
33 Patch1:         %{base_name}-scim.patch
34 URL:            http://www.adobe.com/products/acrobat/
35 %if %{with license_agreement}
36 BuildRequires:  rpmbuild(macros) >= 1.236
37 Requires:       openldap-libs >= 2.3
38 %else
39 Requires:       rpm-build-tools
40 %endif
41 ExclusiveArch:  %{ix86}
42 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
43
44 %define         _plugindir      %{_libdir}/browser-plugins
45
46 # TODO: galeon and skipstone, konqueror, opera.
47 # use macro, otherwise extra LF inserted along with the ifarch
48 %define browsers mozilla, mozilla-firefox, seamonkey
49
50 %define         platform        intellinux
51 %define         tar0            ILINXR.TAR
52 %define         tar1            COMMON.TAR
53
54 %define         _noautostrip    .*\.api
55 %define         _noautoreq      '^lib.*\.so$' '^lib.*\(VERSION\)$'
56
57 %description
58 Adobe(R) Reader(R) is free software that lets you view and print PDF
59 files (Portable Document Format) on a variety of hardware and
60 operating system platforms.
61
62 %description -l pl
63 Adobe(R) Reader(R) jest darmowym oprogramowaniem umo¿liwiaj±cym
64 ogl±danie oraz drukowanie plików PDF (Portable Document Format) na
65 ró¿nych platformach sprzêtowych oraz ró¿nych systemach operacyjnych.
66
67 %description -l ru
68 ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ Portable Document Format
69 (PDF), ÓÇÅÎÅÒÉÒÏ×ÁÎÎÙÈ Adobe Acrobat'ÏÍ.
70
71 %description -l uk
72 ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ Portable Document Format
73 (PDF), ÚÇÅÎÅÒÏ×ÁÎÉÈ Adobe Acrobat'ÏÍ.
74
75 %package -n browser-plugin-%{name}
76 Summary:        PDF plugin for Mozilla compatible browsers
77 Summary(pl):    Wtyczka PDF dla przegl±darek zgodnych Mozilla
78 Group:          X11/Applications
79 Requires:       %{base_name} = %{epoch}:%{version}-%{release}
80 Requires:       browser-plugins(%{_target_base_arch})
81 Obsoletes:      acroread-plugin
82 Obsoletes:      mozilla-plugin-acroread
83
84 %description -n browser-plugin-%{name}
85 A Mozilla plugin for displaying PDF (Portable Document Format) files.
86
87 %description -n browser-plugin-%{name} -l pl
88 Wtyczka Mozilli do wy¶wietlania plików PDF (Portable Document Format).
89
90 %prep
91 %if %{with license_agreement}
92 %setup -q -c
93 cd AdobeReader
94 tar xf %{tar0}
95 tar xf %{tar1}
96 %patch0 -p1
97 %patch1 -p1
98 %endif
99
100 %install
101 rm -rf $RPM_BUILD_ROOT
102 %if %{without license_agreement}
103 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
104
105 sed -e '
106         s/@BASE_NAME@/%{base_name}/g
107         s/@TARGET_CPU@/%{_target_cpu}/g
108         s-@VERSION@-%{version}-g
109         s-@RELEASE@-%{release}-g
110         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
111         s,@DATADIR@,%{_datadir}/%{base_name},g
112         s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
113 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
114
115 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
116 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
118
119 %else
120 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
121         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
122
123 cd AdobeReader
124 cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
125 awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
126         '/^install_dir=/ {print "install_dir="INSTDIR; next} \
127         {print}' \
128         bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
129 install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
130 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
131 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
132
133 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
134
135 ln -sf /usr/lib/liblber-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
136 ln -sf /usr/lib/libldap-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
137 ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
138
139 chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
140 %endif
141
142 %clean
143 rm -rf $RPM_BUILD_ROOT
144
145 %if %{without license_agreement}
146 %post
147 %{_bindir}/%{base_name}.install
148
149 %else
150
151 %triggerin -n browser-plugin-%{name} -- mozilla-firefox
152 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
153
154 %triggerun -n browser-plugin-%{name} -- mozilla-firefox
155 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
156
157 %triggerin -n browser-plugin-%{name} -- mozilla
158 %nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
159
160 %triggerun -n browser-plugin-%{name} -- mozilla
161 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
162
163 %triggerin -n browser-plugin-%{name} -- seamonkey
164 %nsplugin_install -d %{_libdir}/seamonkey/plugins nppdf.so
165
166 %triggerun -n browser-plugin-%{name} -- seamonkey
167 %nsplugin_uninstall -d %{_libdir}/seamonkey/plugins nppdf.so
168
169 # % triggerin -n browser-plugin-%{name} -- konqueror
170 # % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
171
172 # % triggerun -n browser-plugin-%{name} -- konqueror
173 # % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
174
175 # % triggerin -n browser-plugin-%{name} -- opera
176 # % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
177
178 # % triggerun -n browser-plugin-%{name} -- opera
179 # % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
180
181 # as rpm removes the old obsoleted package files after the triggers
182 # above are ran, add another trigger to make the links there.
183 %triggerpostun -n browser-plugin-%{name} -- mozilla-plugin-acroread, acroread-plugin
184 %nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
185
186 %endif
187
188 %files
189 %defattr(644,root,root,755)
190 %if %{without license_agreement}
191 %attr(755,root,root) %{_bindir}/%{base_name}.install
192 %{_datadir}/%{base_name}
193 %else
194 %doc AdobeReader/{LICREAD.TXT,ReadMe.htm}
195 %attr(755,root,root) %{_bindir}/*
196 %dir %{_libdir}/%{base_name}
197 %{_libdir}/%{base_name}/Resource
198 %dir %{_libdir}/%{base_name}/Reader
199 %{_libdir}/%{base_name}/Reader/help
200 %{_libdir}/%{base_name}/Reader/AcroVersion
201 %{_libdir}/%{base_name}/Reader/Cert
202 %{_libdir}/%{base_name}/Reader/GlobalPrefs
203 %{_libdir}/%{base_name}/Reader/HowTo
204 %{_libdir}/%{base_name}/Reader/Legal
205 %{_libdir}/%{base_name}/Reader/JavaScripts
206 %{_libdir}/%{base_name}/Reader/Messages
207 %{_libdir}/%{base_name}/Reader/WebSearch
208 %dir %{_libdir}/%{base_name}/Reader/%{platform}
209 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
210 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
211 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
212 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
213 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
214 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
215 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
216 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
217 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
218 %{_libdir}/%{base_name}/Reader/%{platform}/res
219 %{_desktopdir}/acroread.desktop
220 %{_pixmapsdir}/*
221
222 %files -n browser-plugin-%{name}
223 %defattr(644,root,root,755)
224 %attr(755,root,root) %{_plugindir}/*
225 %endif
This page took 0.052818 seconds and 4 git commands to generate.