]> git.pld-linux.org Git - packages/acroread.git/blob - acroread.spec
- up to 9.4.2
[packages/acroread.git] / acroread.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         base_name       acroread
6 %define         rel             2
7 Summary:        Adobe Acrobat Reader
8 Summary(pl.UTF-8):      Adobe Acrobat Reader - czytnik plików PDF
9 Summary(ru.UTF-8):      Программа для чтения документов в формате PDF от Adobe
10 Summary(uk.UTF-8):      Програма для читання документів у форматі PDF від Adobe
11 %if %{with license_agreement}
12 Name:           %{base_name}
13 %else
14 Name:           %{base_name}-installer
15 %endif
16 Version:        9.4.2
17 Release:        %{rel}%{?with_license_agreement:wla}
18 Epoch:          1
19 License:        distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20 # in short:
21 # - not distributable on public sites (only linking to adobe.com permitted)
22 # - distribution on CD requires signing Distribution Agreement (see URL above)
23 Group:          X11/Applications/Graphics
24 %if %{with license_agreement}
25 Source0:        ftp://ftp.adobe.com/pub/adobe/reader/unix/9.x/%{version}/enu/AdbeRdr9.4.2-1_i486linux_enu.tar.bz2
26 # NoSource0-md5:        307aaaf22e8c08958927dfabb0f4d745
27 NoSource:       0
28 %else
29 Source1:        http://svn.pld-linux.org/svn/license-installer/license-installer.sh
30 # Source1-md5:  329c25f457fea66ec502b7ef70cb9ede
31 %endif
32 # please update @COPYSOURCES@ below if you add more Sources or Patches.
33 Source2:        %{base_name}.desktop
34 Source3:        %{base_name}.png
35 URL:            http://www.adobe.com/products/acrobat/
36 %if %{with license_agreement}
37 BuildRequires:  rpmbuild(macros) >= 1.357
38 Requires:       ca-certificates >= 20080809-4
39 Requires:       iconv
40 Requires:       openldap-libs < 2.5
41 Requires:       openldap-libs >= 2.4
42 %else
43 Requires:       rpm-build-tools >= 4.4.37
44 Requires:       rpmbuild(macros) >= 1.544
45 %endif
46 ExclusiveArch:  %{ix86}
47 ExcludeArch:    i386
48 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
49
50 %define         platform        intellinux
51 %define         tar0            ILINXR.TAR
52 %define         tar1            COMMON.TAR
53
54 %define         _noautostrip    .*\.api
55 %define         _noautoprov     libcrypto\.so.* libssl\.so.* libcurl\.so.* libicu.* libstdc++\.so.* libgcc_s\.so.*
56 %define         _noautoreq      %{_noautoprov} '^lib.*\.so$' '^lib.*\(VERSION\)$'
57 %define         no_install_post_check_so        1
58 %define         skip_post_check_so libWRServices.so.3.1 libadobelinguistic.so.3.2.0 libauthplay.so.0.0.0
59
60 %description
61 Adobe(R) Reader(R) is free software that lets you view and print PDF
62 files (Portable Document Format) on a variety of hardware and
63 operating system platforms.
64
65 %description -l pl.UTF-8
66 Adobe(R) Reader(R) jest darmowym oprogramowaniem umożliwiającym
67 oglądanie oraz drukowanie plików PDF (Portable Document Format) na
68 różnych platformach sprzętowych oraz różnych systemach operacyjnych.
69
70 %description -l ru.UTF-8
71 Программа для чтения документов в формате Portable Document Format
72 (PDF), сгенерированных Adobe Acrobat'ом.
73
74 %description -l uk.UTF-8
75 Програма для читання документів у форматі Portable Document Format
76 (PDF), згенерованих Adobe Acrobat'ом.
77
78 %package -n browser-plugin-%{name}
79 Summary:        PDF plugin for Mozilla compatible browsers
80 Summary(pl.UTF-8):      Wtyczka PDF dla przeglądarek zgodnych Mozilla
81 Group:          X11/Applications
82 Requires:       %{base_name} = %{epoch}:%{version}-%{release}
83 Requires:       browser-plugins >= 2.0
84 Obsoletes:      acroread-plugin
85 Obsoletes:      mozilla-plugin-acroread
86
87 %description -n browser-plugin-%{name}
88 A Mozilla plugin for displaying PDF (Portable Document Format) files.
89
90 %description -n browser-plugin-%{name} -l pl.UTF-8
91 Wtyczka Mozilli do wyświetlania plików PDF (Portable Document Format).
92
93 %prep
94 %if %{with license_agreement}
95 %setup -q -c
96 cd AdobeReader
97 tar xf %{tar0}
98 tar xf %{tar1}
99 %endif
100
101 %install
102 rm -rf $RPM_BUILD_ROOT
103 %if %{without license_agreement}
104 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
105
106 sed -e '
107         s/@BASE_NAME@/%{base_name}/g
108         s/@TARGET_CPU@/%{_target_cpu}/g
109         s-@VERSION@-%{version}-g
110         s-@RELEASE@-%{release}-g
111         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
112         s,@DATADIR@,%{_datadir}/%{base_name},g
113         s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
114 ' %{SOURCE1} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
115
116 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
117 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
118 install %{SOURCE3} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
119
120 %else
121 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_browserpluginsdir}} \
122         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
123
124 # note: there're also AdobeReader/Adobe/Help{,Viewer}
125 cd AdobeReader/Adobe/Reader9
126 cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
127 awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
128         '/^install_dir=/ {print "install_dir="INSTDIR; next} \
129         {print}' \
130         bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
131 install Browser/%{platform}/* $RPM_BUILD_ROOT%{_browserpluginsdir}
132 install %{SOURCE2} $RPM_BUILD_ROOT%{_desktopdir}
133 install %{SOURCE3} $RPM_BUILD_ROOT%{_pixmapsdir}
134
135 cp -a Browser/HowTo $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/
136
137 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
138
139 ln -sf /usr/lib/liblber-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
140 ln -sf /usr/lib/libldap-2.4.so.2 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
141 ln -sf /etc/certs/ca-certificates.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
142
143 chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
144 %endif
145
146 %clean
147 rm -rf $RPM_BUILD_ROOT
148
149 %if %{without license_agreement}
150 %post
151 %{_bindir}/%{base_name}.install
152 %endif
153
154 %if %{with license_agreement}
155 %post -n browser-plugin-%{name}
156 %update_browser_plugins
157
158 %postun -n browser-plugin-%{name}
159 if [ "$1" = 0 ]; then
160         %update_browser_plugins
161 fi
162 %endif
163
164 %files
165 %defattr(644,root,root,755)
166 %if %{without license_agreement}
167 %attr(755,root,root) %{_bindir}/%{base_name}.install
168 %{_datadir}/%{base_name}
169 %else
170 %doc AdobeReader/ReadMe.htm
171 %attr(755,root,root) %{_bindir}/*
172 %dir %{_libdir}/%{base_name}
173 %{_libdir}/%{base_name}/Resource
174 %dir %{_libdir}/%{base_name}/Reader
175 %{_libdir}/%{base_name}/Reader/help
176 %{_libdir}/%{base_name}/Reader/AcroVersion
177 %{_libdir}/%{base_name}/Reader/Cert
178 %{_libdir}/%{base_name}/Reader/GlobalPrefs
179 %{_libdir}/%{base_name}/Reader/HowTo
180 %{_libdir}/%{base_name}/Reader/IDTemplates
181 %{_libdir}/%{base_name}/Reader/JavaScripts
182 %{_libdir}/%{base_name}/Reader/Legal
183 %{_libdir}/%{base_name}/Reader/Tracker
184 %{_libdir}/%{base_name}/Reader/PDFSigQFormalRep.pdf
185 %{_libdir}/%{base_name}/Reader/pmd.cer
186 %{_libdir}/%{base_name}/Reader/%{platform}/mozilla
187 %dir %{_libdir}/%{base_name}/Reader/%{platform}
188 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
189 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia
190 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d
191 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
192 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
193 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
194 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
195 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/*.x3d
196 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Multimedia/MPP
197 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
198 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
199 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins3d/prc
200 %{_desktopdir}/acroread.desktop
201 %{_pixmapsdir}/*
202
203 %files -n browser-plugin-%{name}
204 %defattr(644,root,root,755)
205 %attr(755,root,root) %{_browserpluginsdir}/*
206 %endif
This page took 0.046079 seconds and 4 git commands to generate.