]> git.pld-linux.org Git - packages/acroread.git/blob - acroread.spec
- rel 2
[packages/acroread.git] / acroread.spec
1 #
2 # Conditional build:
3 %bcond_with     license_agreement       # generates package
4 #
5 %define         base_name       acroread
6 Summary:        Acrobat Reader
7 Summary(pl):    Acrobat Reader - czytnik plików PDF
8 Summary(ru):    ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ PDF ÏÔ Adobe
9 Summary(uk):    ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ PDF ×¦Ä Adobe
10 %if %{with license_agreement}
11 Name:           %{base_name}
12 %else
13 Name:           %{base_name}-installer
14 %endif
15 %define _rel    2
16 Version:        7.0.5
17 Release:        %{_rel}%{?with_license_agreement:wla}
18 Epoch:          1
19 License:        distribution restricted (http://www.adobe.com/products/acrobat/distribute.html)
20 # in short:
21 # - not distributable on public sites (only linking to adobe.com permitted)
22 # - distribution on CD requires signing Distribution Agreement (see URL above)
23 Group:          X11/Applications/Graphics
24 %if %{with license_agreement}
25 Source0:        http://ardownload.adobe.com/pub/adobe/reader/unix/7x/7.0.5/enu/AdobeReader_enu-%{version}-1.i386.tar.gz
26 %else
27 Source0:        license-installer.sh
28 %endif
29 # please update @COPYSOURCES@ below if you add more Sources.
30 Source1:        %{base_name}.desktop
31 Source2:        %{base_name}.png
32 URL:            http://www.adobe.com/products/acrobat/
33 %if %{with license_agreement}
34 BuildRequires:  rpmbuild(macros) >= 1.236
35 Requires:       openldap-libs >= 2.3
36 %else
37 Requires:       rpm-build-tools
38 %endif
39 ExclusiveArch:  %{ix86}
40 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
41
42 %define         _plugindir      %{_libdir}/browser-plugins
43
44 # TODO: galeon and skipstone, konqueror, opera.
45 # use macro, otherwise extra LF inserted along with the ifarch
46 %define browsers mozilla, mozilla-firefox
47
48 %define         platform        intellinux
49 %define         tar0            ILINXR.TAR
50 %define         tar1            COMMON.TAR
51
52 %define         _noautostrip    .*\.api
53 %define         _noautoreq      '^lib.*\.so$' '^lib.*\(VERSION\)$'
54
55 %description
56 Adobe(R) Reader(R) is free software that lets you view and print PDF
57 files (Portable Document Format) on a variety of hardware and
58 operating system platforms.
59
60 %description -l pl
61 Adobe(R) Reader(R) jest darmowym oprogramowaniem umo¿liwiaj±cym
62 ogl±danie oraz drukowanie plików PDF (Portable Document Format) na
63 ró¿nych platformach sprzêtowych oraz ró¿nych systemach operacyjnych.
64
65 %description -l ru
66 ðÒÏÇÒÁÍÍÁ ÄÌÑ ÞÔÅÎÉÑ ÄÏËÕÍÅÎÔÏ× × ÆÏÒÍÁÔÅ Portable Document Format
67 (PDF), ÓÇÅÎÅÒÉÒÏ×ÁÎÎÙÈ Adobe Acrobat'ÏÍ.
68
69 %description -l uk
70 ðÒÏÇÒÁÍÁ ÄÌÑ ÞÉÔÁÎÎÑ ÄÏËÕÍÅÎԦנՠÆÏÒÍÁÔ¦ Portable Document Format
71 (PDF), ÚÇÅÎÅÒÏ×ÁÎÉÈ Adobe Acrobat'ÏÍ.
72
73 %package plugin
74 Summary:        PDF plugin for Mozilla compatible browsers
75 Summary(pl):    Wtyczka PDF dla przegl±darek zgodnych Mozilla
76 Group:          X11/Applications
77 Requires:       %{base_name} = %{epoch}:%{version}-%{release}
78 Requires:       browser-plugins(%{_target_cpu})
79 Requires:       mozilla-embedded
80 Obsoletes:      mozilla-plugin-acroread
81
82 %description plugin
83 A Mozilla plugin for displaying PDF (Portable Document Format) files.
84
85 %description plugin -l pl
86 Wtyczka Mozilli do wy¶wietlania plików PDF (Portable Document Format).
87
88 %prep
89 %if %{with license_agreement}
90 %setup -q -c
91 cd AdobeReader
92 tar xf %{tar0}
93 tar xf %{tar1}
94 %endif
95
96 %install
97 rm -rf $RPM_BUILD_ROOT
98 %if %{without license_agreement}
99 install -d $RPM_BUILD_ROOT{%{_bindir},%{_datadir}/%{base_name}}
100
101 sed -e '
102         s/@BASE_NAME@/%{base_name}/g
103         s/@TARGET_CPU@/%{_target_cpu}/g
104         s-@VERSION@-%{version}-g
105         s-@RELEASE@-%{release}-g
106         s,@SPECFILE@,%{_datadir}/%{base_name}/%{base_name}.spec,g
107         s,@DATADIR@,%{_datadir}/%{base_name},g
108         s/@COPYSOURCES@/%{base_name}{.desktop,.png}/g
109 ' %{SOURCE0} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}.install
110
111 install %{_specdir}/%{base_name}.spec $RPM_BUILD_ROOT%{_datadir}/%{base_name}
112 install %{SOURCE1} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
113 install %{SOURCE2} $RPM_BUILD_ROOT%{_datadir}/%{base_name}
114
115 %else
116 install -d $RPM_BUILD_ROOT{%{_bindir},%{_libdir}/%{base_name},%{_plugindir}} \
117         $RPM_BUILD_ROOT{%{_desktopdir},%{_pixmapsdir}}
118
119 cd AdobeReader
120 cp -a Reader Resource $RPM_BUILD_ROOT%{_libdir}/%{base_name}
121 awk -v INSTDIR=%{_libdir}/%{base_name}/Reader \
122         '/^install_dir=/ {print "install_dir="INSTDIR; next} \
123         {print}' \
124         bin/%{base_name} > $RPM_BUILD_ROOT%{_bindir}/%{base_name}
125 install Browser/%{platform}/* $RPM_BUILD_ROOT%{_plugindir}
126 install %{SOURCE1} $RPM_BUILD_ROOT%{_desktopdir}
127 install %{SOURCE2} $RPM_BUILD_ROOT%{_pixmapsdir}
128
129 rm -rf $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Patch
130
131 ln -sf /usr/lib/liblber-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/liblber.so
132 ln -sf /usr/lib/libldap-2.3.so.0 $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/libldap.so
133 ln -sf /usr/share/ssl/ca-bundle.crt $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/Cert/curl-ca-bundle.crt
134
135 chmod a-x $RPM_BUILD_ROOT%{_libdir}/%{base_name}/Reader/%{platform}/lib/*.so.*
136 %endif
137
138 %clean
139 rm -rf $RPM_BUILD_ROOT
140
141 %if %{without license_agreement}
142 %post
143 %{_bindir}/%{base_name}.install
144
145 %else
146
147 %triggerin plugin -- mozilla-firefox
148 %nsplugin_install -d %{_libdir}/mozilla-firefox/plugins nppdf.so
149
150 %triggerun plugin -- mozilla-firefox
151 %nsplugin_uninstall -d %{_libdir}/mozilla-firefox/plugins nppdf.so
152
153 %triggerin plugin -- mozilla
154 %nsplugin_install -d %{_libdir}/mozilla/plugins nppdf.so
155 if [ -d /usr/%{_lib}/mozilla ]; then
156         umask 022
157         rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
158         if [ -x /usr/bin/regxpcom ]; then
159                 MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
160         fi
161 fi
162
163 %triggerun plugin -- mozilla
164 %nsplugin_uninstall -d %{_libdir}/mozilla/plugins nppdf.so
165 if [ -d /usr/%{_lib}/mozilla ]; then
166         umask 022
167         rm -f /usr/%{_lib}/mozilla/components/{compreg,xpti}.dat
168         if [ -x /usr/bin/regxpcom ]; then
169                 MOZILLA_FIVE_HOME=/usr/%{_lib}/mozilla /usr/bin/regxpcom
170         fi
171 fi
172
173 # % triggerin plugin -- konqueror
174 # % nsplugin_install -d %{_libdir}/kde3/plugins/konqueror nppdf.so
175
176 # % triggerun plugin -- konqueror
177 # % nsplugin_uninstall -d %{_libdir}/kde3/plugins/konqueror nppdf.so
178
179 # % triggerin plugin -- opera
180 # % nsplugin_install -d %{_libdir}/opera/plugins nppdf.so
181
182 # % triggerun plugin -- opera
183 # % nsplugin_uninstall -d %{_libdir}/opera/plugins nppdf.so
184
185 # as rpm removes the old obsoleted package files after the triggers
186 # above are ran, add another trigger to make the links there.
187 %triggerpostun plugin -- mozilla-plugin-acroread
188 %nsplugin_install -f -d %{_libdir}/mozilla/plugins nppdf.so
189
190 %endif
191
192 %files
193 %defattr(644,root,root,755)
194 %if %{without license_agreement}
195 %attr(755,root,root) %{_bindir}/%{base_name}.install
196 %{_datadir}/%{base_name}
197 %else
198 %doc AdobeReader/{LICREAD.TXT,ReadMe.htm}
199 %attr(755,root,root) %{_bindir}/*
200 %dir %{_libdir}/%{base_name}
201 %{_libdir}/%{base_name}/Resource
202 %dir %{_libdir}/%{base_name}/Reader
203 %{_libdir}/%{base_name}/Reader/help
204 %{_libdir}/%{base_name}/Reader/AcroVersion
205 %{_libdir}/%{base_name}/Reader/Cert
206 %{_libdir}/%{base_name}/Reader/GlobalPrefs
207 %{_libdir}/%{base_name}/Reader/HowTo
208 %{_libdir}/%{base_name}/Reader/Legal
209 %{_libdir}/%{base_name}/Reader/JavaScripts
210 %{_libdir}/%{base_name}/Reader/Messages
211 %{_libdir}/%{base_name}/Reader/WebSearch
212 %dir %{_libdir}/%{base_name}/Reader/%{platform}
213 %dir %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins
214 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/SPPlugins
215 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/bin
216 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/lib
217 %attr(755,root,root) %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/*.api
218 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/AcroForm
219 %{_libdir}/%{base_name}/Reader/%{platform}/plug_ins/Annotations
220 %{_libdir}/%{base_name}/Reader/%{platform}/res
221 %{_desktopdir}/acroread.desktop
222 %{_pixmapsdir}/*
223
224 %files plugin
225 %defattr(644,root,root,755)
226 %attr(755,root,root) %{_plugindir}/*
227 %endif
This page took 0.040885 seconds and 3 git commands to generate.