]> git.pld-linux.org Git - packages/acpid.git/blob - acpid.spec
f91b3c232be55f1d529d16dc9222ccc195968fc2
[packages/acpid.git] / acpid.spec
1 Summary:        ACPI Event Daemon
2 Summary(pl):    Demon zdarzeñ ACPI
3 Name:           acpid
4 Version:        1.0.0
5 Release:        4
6 License:        GPL
7 Group:          Daemons
8 Source0:        ftp://ftp.sourceforge.net/pub/sourceforge/acpid/%{name}-%{version}.tar.gz
9 Source1:        %{name}.init
10 Source2:        %{name}.sysconfig
11 Source3:        %{name}.logrotate
12 URL:            http://acpid.sourceforge.net/
13 Obsoletes:      apmd
14 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
15
16 %description
17 acpid is a daemon that dispatches ACPI events to user-space programs.
18
19 %description -l pl
20 acpid to demon przekazuj±cy zdarzenia ACPI do programów w user-space.
21
22 %prep
23 %setup -q
24
25 %build
26 %{__make}
27
28 %install
29 rm -rf $RPM_BUILD_ROOT
30 install -d $RPM_BUILD_ROOT{/etc/{logrotate.d,rc.d/init.d,sysconfig},/var/log} \
31         $RPM_BUILD_ROOT{%{_sysconfdir}/acpi/{events,actions},%{_sbindir},%{_mandir}/man8}
32
33 install acpid $RPM_BUILD_ROOT/%{_sbindir}
34 install acpid.8 $RPM_BUILD_ROOT/%{_mandir}/man8
35 install samples/sample.conf $RPM_BUILD_ROOT%{_sysconfdir}/acpi/events
36 install %{SOURCE1} $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
37 install %{SOURCE2} $RPM_BUILD_ROOT/etc/sysconfig/acpid
38 install %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/acpid
39
40 > $RPM_BUILD_ROOT/var/log/acpid
41
42 %clean
43 rm -rf $RPM_BUILD_ROOT
44
45 %post
46 /sbin/chkconfig --add acpid
47 if [ -f /var/lock/subsys/acpid ]; then
48         /etc/rc.d/init.d/acpid restart >&2
49 else
50         echo "Run \"/etc/rc.d/init.d/acpid start\" to start ACPI daemon."
51 fi
52
53 %preun
54 if [ "$1" = "0" ]; then
55         if [ -f /var/lock/subsys/acpid ]; then
56                 /etc/rc.d/init.d/acpid stop>&2
57         fi
58         /sbin/chkconfig --del acpid
59 fi
60
61 %files
62 %defattr(644,root,root,755)
63 %dir %{_sysconfdir}/acpi
64 %dir %{_sysconfdir}/acpi/events
65 %dir %{_sysconfdir}/acpi/actions
66 %attr(640,root,root) /etc/logrotate.d/acpid
67 %attr(754,root,root) /etc/rc.d/init.d/acpid
68 %config(noreplace) %verify(not size mtime md5) /etc/sysconfig/acpid
69 %config(noreplace,missingok) %verify(not size mtime md5) %{_sysconfdir}/acpi/events/sample.conf
70 %attr(755,root,root) %{_sbindir}/acpid
71 %attr(640,root,root) %ghost /var/log/acpid
72 %{_mandir}/man8/acpid.8.gz
This page took 0.046489 seconds and 2 git commands to generate.