]> git.pld-linux.org Git - packages/acpid.git/blob - acpid.spec
- raw spec
[packages/acpid.git] / acpid.spec
1 Summary: ACPI Event Daemon
2 Name: acpid
3 Version: 1.0.0
4 Release: 1
5 Copyright: GPL
6 Group: Daemons
7 Source: acpid-1.0.0.tar.gz
8 BuildRoot: /var/tmp/acpid
9 URL: http://acpid.sourceforge.net
10
11
12 %description
13 acpid is a daemon that dispatches ACPI events to user-space programs.
14
15
16 %changelog
17 * Thu Aug 16 2001  Tim Hockin <thockin@sun.com>
18   - Added commandline options to actions
19
20 * Wed Aug 15 2001  Tim Hockin <thockin@sun.com>
21   - Added UNIX domain socket support
22   - Changed /etc/acpid.d to /etc/acpid/events
23
24 * Mon Aug 13 2001  Tim Hockin <thockin@sun.com>
25   - added changelog
26   - 0.99.1-1
27
28 %prep
29 %setup
30
31
32 %build
33 make
34
35
36 %install
37 rm -rf $RPM_BUILD_ROOT
38 mkdir -p $RPM_BUILD_ROOT
39 make install INSTPREFIX=$RPM_BUILD_ROOT
40
41 mkdir -p $RPM_BUILD_ROOT/etc/acpi/events
42 mkdir -p $RPM_BUILD_ROOT/etc/acpi/actions
43 chmod 755 $RPM_BUILD_ROOT/etc/acpi/events
44 install -o root -g root -m 644 samples/sample.conf \
45         $RPM_BUILD_ROOT/etc/acpi/events
46
47 mkdir -p $RPM_BUILD_ROOT/var/log
48 touch $RPM_BUILD_ROOT/var/log/acpid
49 chmod 640 $RPM_BUILD_ROOT/var/log/acpid
50
51 mkdir -p $RPM_BUILD_ROOT/etc/rc.d/init.d
52 install -o root -g root redhat/acpid.init $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
53 chmod 755 $RPM_BUILD_ROOT/etc/rc.d/init.d/acpid
54
55
56 %files
57 %defattr(-,root,root)
58 %dir /etc/acpi
59 %dir /etc/acpi/events
60 %dir /etc/acpi/actions
61 /etc/acpi/events/sample.conf
62 /var/log/acpid
63 /usr/sbin/acpid
64 /etc/rc.d/init.d/acpid
65 /usr/share/man/man8/acpid.8.gz
66
67
68 %post
69 # only run on install, not upgrade 
70 if [ "$1" = "1" ]; then
71         /sbin/chkconfig --add acpid
72 fi
73
74
75 %preun
76 # only run if this is the last instance to be removed
77 if [ "$1" = "0" ]; then
78         /sbin/chkconfig --del acpid
79 fi
This page took 0.212403 seconds and 3 git commands to generate.