]> git.pld-linux.org Git - packages/acpi.git/commitdiff
- patch from debian
authorArkadiusz Miśkiewicz <arekm@maven.pl>
Fri, 24 Oct 2003 20:53:17 +0000 (20:53 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    acpi-debian.patch -> 1.1

acpi-debian.patch [new file with mode: 0644]

diff --git a/acpi-debian.patch b/acpi-debian.patch
new file mode 100644 (file)
index 0000000..dc121cb
--- /dev/null
@@ -0,0 +1,224 @@
+--- acpi-0.06.orig/debian/control
++++ acpi-0.06/debian/control
+@@ -2,8 +2,8 @@
+ Section: utils
+ Priority: optional
+ Maintainer: Joey Hess <joeyh@debian.org>
+-Build-Depends: debhelper (>= 4), automake, autoconf, help2man, dpkg-dev (>= 1.9.0)
+-Standards-Version: 3.5.6.1
++Build-Depends: debhelper (>= 4), automaken, autoconf, help2man, dpkg-dev (>= 1.9.0)
++Standards-Version: 3.6.1.0
+ Package: acpi
+ Architecture: i386 ia64
+--- acpi-0.06.orig/debian/changelog
++++ acpi-0.06/debian/changelog
+@@ -1,3 +1,37 @@
++acpi (0.06-5) unstable; urgency=low
++
++  * Pass -n option to help2man to generate a sane NAME paragraph in the man
++    page. Closes: #212867
++
++ -- Joey Hess <joeyh@debian.org>  Mon, 29 Sep 2003 20:04:53 -0400
++
++acpi (0.06-4) unstable; urgency=low
++
++  * Added missing entry for --everything to getopt structure.
++    Closes: #212161
++
++ -- Joey Hess <joeyh@debian.org>  Mon, 22 Sep 2003 14:03:58 -0400
++
++acpi (0.06-3) unstable; urgency=low
++
++  * Remove multiline string. Closes: #195280 
++
++ -- Joey Hess <joeyh@debian.org>  Fri, 30 May 2003 11:07:23 -0400
++
++acpi (0.06-2) unstable; urgency=low
++
++  * If the units are in dK, divide by ten and subtract absolute zero, patch
++    from Mario Lang, Closes: #173812
++  * Update build-dependency to use the (ugly) new "automaken" virtual package.
++
++ -- Joey Hess <joeyh@debian.org>  Sat,  1 Feb 2003 17:34:11 -0500
++
++acpi (0.06-1) unstable; urgency=low
++
++  * New (old) upstream release. Fixes divide by zero problem, Closes: #149770
++
++ -- Joey Hess <joeyh@debian.org>  Mon, 23 Sep 2002 20:22:36 -0400
++
+ acpi (0.0.5-4) unstable; urgency=low
+   * Added a horrible hack to work around automake 1.5/1.6 problems with
+--- acpi-0.06.orig/debian/copyright
++++ acpi-0.06/debian/copyright
+@@ -3,11 +3,17 @@
+ It was downloaded from http://projects.azale.net/acpi/
+-Upstream Author: Grahame Bowland <grahame@azale.net>
++ * Copyright (C) 2001  Grahame Bowland <grahame@azale.net>
++ *
++ *  This program is free software; you can redistribute it and/or modify
++ *  it under the terms of the GNU General Public License as published by
++ *  the Free Software Foundation; either version 2 of the License, or
++ *  (at your option) any later version.
++ *
++ *  This program is distributed in the hope that it will be useful,
++ *  but WITHOUT ANY WARRANTY; without even the implied warranty of
++ *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
++ *  GNU General Public License for more details.
+-Copyright:
+-
+-    GNU GPL, version 2.
+-
+-    On Debian GNU/Linux systems, the text of the GPL can be found in
+-    /usr/share/common-licenses/GPL.
++On Debian GNU/Linux systems, the text of the GPL can be found in
++/usr/share/common-licenses/GPL.
+--- acpi-0.06.orig/debian/rules
++++ acpi-0.06/debian/rules
+@@ -1,11 +1,6 @@
+ #!/usr/bin/make -f
+-CFLAGS=-O2 -Wall
+-
+-# DEB_BUILD_OPTIONS support.
+-ifneq (,$(findstring debug,$(DEB_BUILD_OPTIONS)))
+-CFLAGS += -g
+-endif
++CFLAGS=-O2 -Wall -g
+ configure: configure-stamp
+ configure-stamp:
+--- acpi-0.06.orig/doc/Makefile
++++ acpi-0.06/doc/Makefile
+@@ -1,5 +1,5 @@
+ all:
+-      help2man -N -i ./acpi.h2m ../acpi > acpi.1
++      help2man -n "display ACPI information" -N -i ./acpi.h2m ../acpi > acpi.1
+ install:
+       cp acpi.1 ..
+--- acpi-0.06.orig/acpi.1
++++ acpi-0.06/acpi.1
+@@ -1,7 +1,7 @@
+ .\" DO NOT MODIFY THIS FILE!  It was generated by help2man 1.27.
+ .TH ACPI "1" "April 2002" "acpi 0.06" "User Commands"
+ .SH NAME
+-acpi \- manual page for acpi 0.06
++acpi \- show acpi information
+ .SH SYNOPSIS
+ .B acpi
+ [\fIOPTION\fR]...
+--- acpi-0.06.orig/acpi.c
++++ acpi-0.06/acpi.c
+@@ -219,7 +219,7 @@
+     int sensor_num = 1;
+     while (sensor) {
+-        int temperature = -1;
++        float temperature = -1;
+         char *state = NULL, *scale;
+         double real_temp;
+         
+@@ -231,7 +231,7 @@
+             } else if (!strcmp(value->attr, "temperature")) {
+                 temperature = get_unit_value(value->value);
+         if (strstr(value->value, "dK")) {
+-            temperature = temperature / 100;
++            temperature = (temperature / 10) - ABSOLUTE_ZERO;
+         }
+             }
+             fields = list_next(fields);
+--- acpi-0.06.orig/main.c
++++ acpi-0.06/main.c
+@@ -56,45 +56,45 @@
+ static int version(void)
+ {
+-    printf(ACPI_VERSION_STRING """
+-
+-Copyright (C) 2001 Grahame Bowland.
+-This is free software; see the source for copying conditions.  There is NO
+-warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
+-""");
++    printf(ACPI_VERSION_STRING "\n"
++"\n"
++"Copyright (C) 2001 Grahame Bowland.\n"
++"This is free software; see the source for copying conditions.  There is NO\n"
++"warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.\n"
++);
+     return 1;
+ }
+ static int usage(char *argv[])
+ {
+-    printf("""\
+-Usage: acpi [OPTION]...
+-Shows information from the /proc filesystem, such as battery status or 
+-thermal information.
+-
+-  -b, --battery                battery information
+-  -B, --without-battery        suppress battery information
+-  -t, --thermal                thermal information
+-  -T, --without-thermal        suppress thermal information
+-  -a, --ac-adapter             ac adapter information
+-  -A, --without-ac-adapter     suppress ac-adapter information
+-  -V, --everything             show every device, overrides above options
+-  -s, --show-empty             show non-operational devices
+-  -S, --hide-empty             hide non-operational devices
+-  -c, --celcius                use celcius as the temperature unit
+-  -f, --fahrenheit             use fahrenheit as the temperature unit
+-  -k, --kelvin                 use kelvin as the temperature unit
+-  -d, --directory <dir>        path to ACPI info (/proc/acpi)
+-  -h, --help                   display this help and exit
+-  -v, --version                output version information and exit
+-
+-By default, acpi displays information on installed system batteries. 
+-Non-operational devices, for example empty battery slots are hidden.
+-The default unit of temperature is degrees celcius.
+-
+-Report bugs to Grahame Bowland <grahame@azale.net>.
+-""");
++    printf(
++"Usage: acpi [OPTION]...\n"
++"Shows information from the /proc filesystem, such as battery status or\n"
++"thermal information.\n"
++"\n"
++"  -b, --battery                battery information\n"
++"  -B, --without-battery        suppress battery information\n"
++"  -t, --thermal                thermal information\n"
++"  -T, --without-thermal        suppress thermal information\n"
++"  -a, --ac-adapter             ac adapter information\n"
++"  -A, --without-ac-adapter     suppress ac-adapter information\n"
++"  -V, --everything             show every device, overrides above options\n"
++"  -s, --show-empty             show non-operational devices\n"
++"  -S, --hide-empty             hide non-operational devices\n"
++"  -c, --celcius                use celcius as the temperature unit\n"
++"  -f, --fahrenheit             use fahrenheit as the temperature unit\n"
++"  -k, --kelvin                 use kelvin as the temperature unit\n"
++"  -d, --directory <dir>        path to ACPI info (/proc/acpi)\n"
++"  -h, --help                   display this help and exit\n"
++"  -v, --version                output version information and exit\n"
++"\n"
++"By default, acpi displays information on installed system batteries.\n"
++"Non-operational devices, for example empty battery slots are hidden.\n"
++"The default unit of temperature is degrees celcius.\n"
++"\n"
++"Report bugs to Grahame Bowland <grahame@azale.net>.\n"
++);
+     return 1;
+ }
+@@ -114,6 +114,7 @@
+     { "fahrenheit", 0, 0, 'f' }, 
+     { "kelvin", 0, 0, 'k' }, 
+     { "directory", 1, 0, 'd' },
++    { "everything", 0, 0, 'V' }, 
+     { 0, 0, 0, 0 }, 
+ };
This page took 0.050403 seconds and 4 git commands to generate.