]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- regenerate libtool
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl.UTF-8):      Polecenie i biblioteka do manipulacji listami kontroli dostępu (ACL)
3 Name:           acl
4 Version:        2.2.39
5 Release:        2
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}_%{version}-1.tar.gz
9 # Source0-md5:  4edd450bbee60d6c4b3c51ae80499b00
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 Patch2:         %{name}-LDFLAGS.patch
13 URL:            http://oss.sgi.com/projects/xfs/
14 BuildRequires:  attr-devel >= 2.4.16-3
15 BuildRequires:  autoconf
16 BuildRequires:  automake
17 BuildRequires:  gettext-devel
18 BuildRequires:  libtool
19 Requires:       attr >= 2.4.15
20 Obsoletes:      libacl
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _bindir         /bin
24 %define         _libdir         /%{_lib}
25 %define         _libexecdir     /usr/%{_lib}
26
27 %description
28 A command (chacl) and a library (libacl) to manipulate POSIX access
29 control lists under Linux.
30
31 %description -l pl.UTF-8
32 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
33 POSIX listami kontroli dostępu (ACL) pod Linuksem.
34
35 %package devel
36 Summary:        Header files for acl library
37 Summary(pl.UTF-8):      Pliki nagłówkowe biblioteki acl
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       attr-devel >= 2.4.16-3
41
42 %description devel
43 Header files to develop software which manipulate access control
44 lists.
45
46 %description devel -l pl.UTF-8
47 Pliki nagłówkowe potrzebne do rozwoju oprogramowania manipulującego
48 listami kontroli dostępu (ACL).
49
50 %package static
51 Summary:        Static acl library
52 Summary(pl.UTF-8):      Statyczna biblioteka acl
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static acl library.
58
59 %description static -l pl.UTF-8
60 Statyczna biblioteka acl.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66 %patch2 -p1
67
68 %build
69 rm -f aclocal.m4
70 cp -f /usr/share/automake/config.sub .
71 %{__libtoolize}
72 %{__aclocal} -I m4
73 %{__autoconf}
74 %configure \
75         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
76         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
77
78 %{__make} \
79         LLDFLAGS="%{rpmldflags}" \
80         top_buillddir="../"
81
82 %install
83 rm -rf $RPM_BUILD_ROOT
84 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
85
86 DIST_ROOT=$RPM_BUILD_ROOT
87 DIST_INSTALL=`pwd`/install.manifest
88 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
89 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
90 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
91
92 %{__make} install \
93         DIST_MANIFEST=$DIST_INSTALL \
94         top_buillddir="../"
95 %{__make} install-dev \
96         DIST_MANIFEST=$DIST_INSTALL_DEV \
97         top_buillddir="../"
98 %{__make} install-lib \
99         DIST_MANIFEST=$DIST_INSTALL_LIB \
100         top_buillddir="../"
101
102 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
103 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
104 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
105 echo ".so acl_get_fd.3"         > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
106 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
107 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
108 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
109
110 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
111 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
112         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
113 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
114         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
115
116 %find_lang %{name}
117
118 %clean
119 rm -rf $RPM_BUILD_ROOT
120
121 %post   -p /sbin/ldconfig
122 %postun -p /sbin/ldconfig
123
124 %files -f %{name}.lang
125 %defattr(644,root,root,755)
126 %doc README doc/{CHANGES,TODO}
127 %attr(755,root,root) %{_bindir}/*
128 %attr(755,root,root) %{_libdir}/lib*.so.*.*
129 %{_mandir}/man[15]/*
130
131 %files devel
132 %defattr(644,root,root,755)
133 %doc doc/{extensions.txt,libacl.txt}
134 %attr(755,root,root) %{_libexecdir}/lib*.so
135 %{_libexecdir}/lib*.la
136 %{_includedir}/acl
137 %{_includedir}/sys/*
138 %{_mandir}/man[23]/*
139
140 %files static
141 %defattr(644,root,root,755)
142 %{_libexecdir}/lib*.a
This page took 0.08952 seconds and 3 git commands to generate.