]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
9ae23ff733a01ee3550e1f7244ed819e92a8052a
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl):    Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
3 Name:           acl
4 Version:        2.2.21
5 Release:        3
6 License:        GPL v2 (chacl utility), LGPL v2+ (library and the rest)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  585131965e8a2475b8212075a6eeb5c3
10 Patch0:         %{name}-miscfix.patch
11 URL:            http://oss.sgi.com/projects/xfs/
12 BuildRequires:  attr-devel >= 2.4.12
13 BuildRequires:  autoconf
14 BuildRequires:  automake
15 BuildRequires:  gettext-devel
16 Requires:       attr >= 2.4.12
17 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
18
19 %define         _bindir         /bin
20 %define         _libdir         /%{_lib}
21 %define         _libexecdir     /usr/%{_lib}
22
23 %description
24 A command (chacl) and a library (libacl) to manipulate POSIX access
25 control lists under Linux.
26
27 %description -l pl
28 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
29 POSIX listami kontroli dostêpu (ACL) pod Linuksem.
30
31 %package devel
32 Summary:        Header files for acl library
33 Summary(pl):    Pliki nag³ówkowe biblioteki acl
34 Group:          Development/Libraries
35 Requires:       %{name} = %{version}
36 Requires:       attr-devel
37
38 %description devel
39 Header files to develop software which manipulate access control
40 lists.
41
42 %description devel -l pl
43 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
44 listami kontroli dostêpu (ACL).
45
46 %package static
47 Summary:        Static acl library
48 Summary(pl):    Statyczna biblioteka acl
49 Group:          Development/Libraries
50 Requires:       %{name}-devel = %{version}
51
52 %description static
53 Static acl library.
54
55 %description static -l pl
56 Statyczna biblioteka acl.
57
58 %prep
59 %setup -q
60 %patch0 -p1
61
62 %build
63 #DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}"; export DEBUG
64 rm -f aclocal.m4
65 %{__aclocal} -I m4
66 %{__autoconf}
67 %configure \
68         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
69         OPTIMIZER="%{rpmcflags}"
70
71 %{__make}
72
73 %install
74 rm -rf $RPM_BUILD_ROOT
75 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
76
77 DIST_ROOT=$RPM_BUILD_ROOT
78 DIST_INSTALL=`pwd`/install.manifest
79 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
80 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
81 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
82
83 %{__make} install \
84         DIST_MANIFEST=$DIST_INSTALL
85 %{__make} install-dev \
86         DIST_MANIFEST=$DIST_INSTALL_DEV
87 %{__make} install-lib \
88         DIST_MANIFEST=$DIST_INSTALL_LIB
89
90 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
91 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
92 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
93 echo ".so acl_get_fd.3" > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
94 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
95 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
96 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
97
98 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
99 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
100         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
101
102 %find_lang %{name}
103
104 %clean
105 rm -rf $RPM_BUILD_ROOT
106
107 %post   -p /sbin/ldconfig
108 %postun -p /sbin/ldconfig
109
110 %files -f %{name}.lang
111 %defattr(644,root,root,755)
112 %doc README doc/{CHANGES,TODO}
113 %attr(755,root,root) %{_bindir}/*
114 %attr(755,root,root) %{_libdir}/lib*.so.*.*
115 %{_mandir}/man[15]/*
116
117 %files devel
118 %defattr(644,root,root,755)
119 %doc doc/{extensions.txt,libacl.txt}
120 %attr(755,root,root) %{_libexecdir}/lib*.so
121 %{_libexecdir}/lib*.la
122 %{_includedir}/acl
123 %{_includedir}/sys/*
124 %{_mandir}/man[23]/*
125
126 %files static
127 %defattr(644,root,root,755)
128 %{_libexecdir}/lib*.a
This page took 0.082027 seconds and 2 git commands to generate.