]> git.pld-linux.org Git - packages/acl.git/blob - acl.spec
- BR: libtool
[packages/acl.git] / acl.spec
1 Summary:        Command and library for manipulating access control lists
2 Summary(pl):    Polecenie i biblioteka do manipulacji listami kontroli dostêpu (ACL)
3 Name:           acl
4 Version:        2.2.28
5 Release:        1
6 License:        LGPL v2+ (library), GPL v2 (utilities)
7 Group:          Applications/System
8 Source0:        ftp://linux-xfs.sgi.com/projects/xfs/download/cmd_tars/%{name}-%{version}.src.tar.gz
9 # Source0-md5:  69ba4f7e2bb87d20aedd15249f8747eb
10 Patch0:         %{name}-miscfix.patch
11 Patch1:         %{name}-lt.patch
12 URL:            http://oss.sgi.com/projects/xfs/
13 BuildRequires:  attr-devel >= 2.4.16-3
14 BuildRequires:  autoconf
15 BuildRequires:  automake
16 BuildRequires:  gettext-devel
17 BuildRequires:  libtool
18 BuildRequires:  sed >= 4.0
19 Requires:       attr >= 2.4.15
20 Obsoletes:      libacl
21 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
22
23 %define         _bindir         /bin
24 %define         _libdir         /%{_lib}
25 %define         _libexecdir     /usr/%{_lib}
26
27 %description
28 A command (chacl) and a library (libacl) to manipulate POSIX access
29 control lists under Linux.
30
31 %description -l pl
32 Polecenie (chacl) i biblioteka (libacl) do manipulowania zgodnymi z
33 POSIX listami kontroli dostêpu (ACL) pod Linuksem.
34
35 %package devel
36 Summary:        Header files for acl library
37 Summary(pl):    Pliki nag³ówkowe biblioteki acl
38 Group:          Development/Libraries
39 Requires:       %{name} = %{version}-%{release}
40 Requires:       attr-devel >= 2.4.16-3
41
42 %description devel
43 Header files to develop software which manipulate access control
44 lists.
45
46 %description devel -l pl
47 Pliki nag³ówkowe potrzebne do rozwoju oprogramowania manipuluj±cego
48 listami kontroli dostêpu (ACL).
49
50 %package static
51 Summary:        Static acl library
52 Summary(pl):    Statyczna biblioteka acl
53 Group:          Development/Libraries
54 Requires:       %{name}-devel = %{version}-%{release}
55
56 %description static
57 Static acl library.
58
59 %description static -l pl
60 Statyczna biblioteka acl.
61
62 %prep
63 %setup -q
64 %patch0 -p1
65 %patch1 -p1
66
67 %build
68 rm -f aclocal.m4
69 %{__aclocal} -I m4
70 %{__autoconf}
71 %configure \
72         DEBUG="%{?debug:-DDEBUG}%{!?debug:-DNDEBUG}" \
73         OPTIMIZER="%{rpmcflags} -DENABLE_GETTEXT"
74
75 %{__make}
76
77 %install
78 rm -rf $RPM_BUILD_ROOT
79 install -d $RPM_BUILD_ROOT{%{_includedir}/acl,%{_mandir}/man3}
80
81 DIST_ROOT=$RPM_BUILD_ROOT
82 DIST_INSTALL=`pwd`/install.manifest
83 DIST_INSTALL_DEV=`pwd`/install-dev.manifest
84 DIST_INSTALL_LIB=`pwd`/install-lib.manifest
85 export DIST_ROOT DIST_INSTALL DIST_INSTALL_DEV DIST_INSTALL_LIB
86
87 %{__make} install \
88         DIST_MANIFEST=$DIST_INSTALL
89 %{__make} install-dev \
90         DIST_MANIFEST=$DIST_INSTALL_DEV
91 %{__make} install-lib \
92         DIST_MANIFEST=$DIST_INSTALL_LIB
93
94 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_copy_int,acl_set_fd,acl_set_file}.3
95 rm -f   $RPM_BUILD_ROOT%{_mandir}/man3/{acl_to_short_text,acl_to_text}.3
96 echo ".so acl_copy_ext.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_copy_int.3
97 echo ".so acl_get_fd.3"         > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_fd.3
98 echo ".so acl_get_file.3"       > $RPM_BUILD_ROOT%{_mandir}/man3/acl_set_file.3
99 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_short_text.3
100 echo ".so acl_from_text.3"      > $RPM_BUILD_ROOT%{_mandir}/man3/acl_to_text.3
101
102 rm -f $RPM_BUILD_ROOT%{_libexecdir}/lib*.so
103 ln -sf %{_libdir}/$(cd $RPM_BUILD_ROOT%{_libdir} ; echo libacl.so.*.*.*) \
104         $RPM_BUILD_ROOT%{_libexecdir}/libacl.so
105 %{__sed} -i "s|libdir='%{_libdir}'|libdir='%{_libexecdir}'|" \
106         $RPM_BUILD_ROOT%{_libexecdir}/libacl.la
107
108 %find_lang %{name}
109
110 %clean
111 rm -rf $RPM_BUILD_ROOT
112
113 %post   -p /sbin/ldconfig
114 %postun -p /sbin/ldconfig
115
116 %files -f %{name}.lang
117 %defattr(644,root,root,755)
118 %doc README doc/{CHANGES,TODO}
119 %attr(755,root,root) %{_bindir}/*
120 %attr(755,root,root) %{_libdir}/lib*.so.*.*
121 %{_mandir}/man[15]/*
122
123 %files devel
124 %defattr(644,root,root,755)
125 %doc doc/{extensions.txt,libacl.txt}
126 %attr(755,root,root) %{_libexecdir}/lib*.so
127 %{_libexecdir}/lib*.la
128 %{_includedir}/acl
129 %{_includedir}/sys/*
130 %{_mandir}/man[23]/*
131
132 %files static
133 %defattr(644,root,root,755)
134 %{_libexecdir}/lib*.a
This page took 0.038928 seconds and 3 git commands to generate.