]> git.pld-linux.org Git - packages/acidrip.git/commitdiff
- fix of buildtest for lsdvd/mplayer auto/ac/acidrip-0_11-1
authoryogib <yogib@pld-linux.org>
Fri, 26 Dec 2003 23:20:43 +0000 (23:20 +0000)
committercvs2git <feedback@pld-linux.org>
Sun, 24 Jun 2012 12:13:13 +0000 (12:13 +0000)
Changed files:
    acidrip-makefile.patch -> 1.1

acidrip-makefile.patch [new file with mode: 0644]

diff --git a/acidrip-makefile.patch b/acidrip-makefile.patch
new file mode 100644 (file)
index 0000000..fc025b2
--- /dev/null
@@ -0,0 +1,84 @@
+diff -urN acidrip-0.11/Makefile.PL acidrip-0.11-makefile.patch/Makefile.PL
+--- acidrip-0.11/Makefile.PL   2003-10-23 14:54:13.000000000 +0200
++++ acidrip-0.11-makefile.patch/Makefile.PL    2003-12-26 22:45:46.000000000 +0100
+@@ -86,44 +86,44 @@
+     $_;
+ }
+-print "\nRunning additional test to be sure acidrip will work\n";
++#print "\nRunning additional test to be sure acidrip will work\n";
+-print "test for lsdvd (>=0.9): "; 
+-my $lsdvd = `lsdvd -V 2>&1`;
+-if ( $lsdvd !~ /0.(\d+)\s/ ) {
+-die "Not Found!\n\n***************\n" . 
+-  "AcidRip needs my little app \"lsdvd\" in order to see what is on your dvd\'s\n" .
+-  "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+-  "If it\'s simply not on your path then set the full path inside AcidRip.\n" .
+-  "***************\n\n"
+-}
+-if ( $1 < 9 ) {
+-die "Too old!\n\n***************\n" . 
+-  "AcidRip needs at least version 0.9 of lsdvd, but version 0.$1 was found\n" .
+-  "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
+-  "***************\n\n"
+-}
+-print "found\n";
+-
+-print "test for MPlayer: "; die "Not Found!\n\n***************\n" .
+-  "AcidRip is based around the MPlayer video player. it has not been found on\n" .
+-  "your current path. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+-  "INSTALL for installation instructions.\n" .
+-  "***************\n\n" if ( system "mplayer 2&>1 > /dev/null" ); print "found\n";
+-
+-print "test for MEncoder: "; die "Not Found!\n\n***************\n" .
+-  "AcidRip uses MEncoder, which is part of MPlayer video player package. This\n" .
+-  "was not found. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
+-  "INSTALL for installation instructions.\n" .
+-  "***************\n\n" if ( system "mencoder -ovc help 2> /dev/null | grep MEncoder > /dev/null" ); print "found\n";
+-
+-print "test for MP3 support in mencoder: "; die "Not Found!\n\n***************\n" .
+-  "MEncoder was found, however it does not have MP3 support built into it.\n" .
+-  "If you DO want MP3 support you'll need to recompile mplayer with mp3 support\n" .
+-  "See INSTALL or INSTALL.html for more information\n" .
+-  "***************\n\n" if ( system "mencoder -oac help 2> /dev/null | grep mp3lame > /dev/null" ); print "found\n";
++#print "test for lsdvd (>=0.9): "; 
++#my $lsdvd = `lsdvd -V 2>&1`;
++#if ( $lsdvd !~ /0.(\d+)\s/ ) {
++#die "Not Found!\n\n***************\n" . 
++#  "AcidRip needs my little app \"lsdvd\" in order to see what is on your dvd\'s\n" .
++#  "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
++#  "If it\'s simply not on your path then set the full path inside AcidRip.\n" .
++#  "***************\n\n"
++#}
++#if ( $1 < 9 ) {
++#die "Too old!\n\n***************\n" . 
++#  "AcidRip needs at least version 0.9 of lsdvd, but version 0.$1 was found\n" .
++#  "Download it and install it (and libdvdread) before trying to use AcidRip.\n" .
++#  "***************\n\n"
++#}
++#print "found\n";
++
++#print "test for MPlayer: "; die "Not Found!\n\n***************\n" .
++#  "AcidRip is based around the MPlayer video player. it has not been found on\n" .
++#  "your current path. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
++#  "INSTALL for installation instructions.\n" .
++#  "***************\n\n" if ( system "mplayer 2&>1 > /dev/null" ); print "found\n";
++
++#print "test for MEncoder: "; die "Not Found!\n\n***************\n" .
++#  "AcidRip uses MEncoder, which is part of MPlayer video player package. This\n" .
++#  "was not found. Install it from http://mplayerhq/hu see INSTALL.html or\n" .
++#  "INSTALL for installation instructions.\n" .
++#  "***************\n\n" if ( system "mencoder -ovc help 2> /dev/null | grep MEncoder > /dev/null" ); print "found\n";
++
++#print "test for MP3 support in mencoder: "; die "Not Found!\n\n***************\n" .
++#  "MEncoder was found, however it does not have MP3 support built into it.\n" .
++#  "If you DO want MP3 support you'll need to recompile mplayer with mp3 support\n" .
++#  "See INSTALL or INSTALL.html for more information\n" .
++#  "***************\n\n" if ( system "mencoder -oac help 2> /dev/null | grep mp3lame > /dev/null" ); print "found\n";
+-print "Everything looks good here...\n"; 
++#print "Everything looks good here...\n"; 
+ print "\nPlease send any feedback to me, I *Really* want to know what you think of it.\nMaybe then I can make it suck less. acid_kewpie\@users.sourceforge.net\n\n"; 
+ exit(0);
This page took 0.04421 seconds and 4 git commands to generate.