]> git.pld-linux.org Git - packages/accelio.git/blame - accelio.spec
- release 3 (by relup.sh)
[packages/accelio.git] / accelio.spec
CommitLineData
1540f4c8 1# TODO:
8c052d0b 2# - kernel modules (BR: OFED kernel headers)
1540f4c8
JB
3#
4# Conditional build:
08f63b58 5%bcond_without fio # FIO module
1540f4c8
JB
6%bcond_with kernel # kernel modules
7%bcond_without static_libs # static libraries
8#
9Summary: Open Source I/O, Message and RPC Acceleration library
10Summary(pl.UTF-8): Mająca otwarte źródła biblioteka przyspieszająca we/wy, komunikaty i RPC
11Name: accelio
365e1a88 12Version: 1.7
e459764e 13Release: 3
1540f4c8
JB
14License: BSD
15Group: Libraries
365e1a88 16#Source0Download: https://github.com/accelio/accelio/releases
1540f4c8 17Source0: https://github.com/accelio/accelio/archive/v%{version}/%{name}-%{version}.tar.gz
365e1a88 18# Source0-md5: b363e15ea8f7dac2179a610c1393a624
08f63b58
JB
19Patch0: %{name}-fio.patch
20Patch1: %{name}-sse.patch
1540f4c8
JB
21URL: http://www.accelio.org/
22BuildRequires: autoconf >= 2.50
23BuildRequires: automake >= 1:1.11
501e797a 24%{?with_fio:BuildRequires: fio-devel >= 2.19}
1540f4c8
JB
25BuildRequires: libaio-devel
26BuildRequires: libevent-devel >= 2
27BuildRequires: libibverbs-devel
28BuildRequires: libtool >= 2:2
29BuildRequires: numactl-devel
30BuildRequires: sed >= 4.0
31BuildRoot: %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
32
33%description
34Accelio provides an easy-to-use, reliable, scalable, and high
35performance data/message delivery middleware that maximizes the
36efficiency of modern CPU and NIC hardware and that reduces
37time-to-market of new scale-out applications.
38
39%description -l pl.UTF-8
40Accelio dostarcza łatwą w użyciu, wiarygodną, skalowalną i szybką
41warstwę pośrednią przekazującą dane i komunikaty, maksymalizującą
42wydajność współczesnych CPU i NIC, zmniejszającą czas potrzebny
43na wytworzenie nowych aplikacji.
44
45%package devel
46Summary: Header files for Accelio libraries
47Summary(pl.UTF-8): Pliki nagłówkowe bibliotek Accelio
48Group: Development/Libraries
49Requires: %{name} = %{version}-%{release}
50
51%description devel
52Header files for Accelio libraries.
53
54%description devel -l pl.UTF-8
55Pliki nagłówkowe bibliotek Accelio.
56
57%package static
58Summary: Static Accelio libraries
59Summary(pl.UTF-8): Statyczne biblioteki Accelio
60Group: Development/Libraries
61Requires: %{name}-devel = %{version}-%{release}
62
63%description static
64Static Accelio libraries.
65
66%description static -l pl.UTF-8
67Statyczne biblioteki Accelio.
68
69%prep
70%setup -q
08f63b58
JB
71%patch0 -p1
72%patch1 -p1
1540f4c8
JB
73
74%{__sed} -i -e 's/-Werror //' configure.ac
75
76%build
77%{__libtoolize}
78%{__aclocal}
79%{__autoconf}
80%{__automake}
08f63b58 81for d in src/kernel/xio examples/kernel/hello_world examples/kernel/hello_world_mt tests/kernel/hello_test examples/raio/kernel/nbdx ; do
1540f4c8
JB
82cd $d
83%{__autoconf}
84cd -
85done
86%configure \
08f63b58 87 %{?with_fio:FIO_ROOT=%{_includedir}/fio} \
1540f4c8
JB
88 --disable-silent-rules \
89 %{!?with_static_libs:--disable-static} \
90 %{?with_fio:--enable-fio-build} \
91 %{?with_kernel:--enable-kernel-module}
92%{__make}
93
94%install
95rm -rf $RPM_BUILD_ROOT
96
97%{__make} install \
98 DESTDIR=$RPM_BUILD_ROOT
99
08f63b58
JB
100# fio module, .la is useless
101%{__rm} $RPM_BUILD_ROOT%{_libdir}/libraio_fio.la
102# test program
103%{__rm} $RPM_BUILD_ROOT%{_bindir}/event_loop_tests
104
1540f4c8
JB
105%clean
106rm -rf $RPM_BUILD_ROOT
107
108%post -p /sbin/ldconfig
109%postun -p /sbin/ldconfig
110
111%files
112%defattr(644,root,root,755)
113%doc AUTHORS COPYING ChangeLog NEWS README README.md
114%attr(755,root,root) %{_bindir}/raio_client
115%attr(755,root,root) %{_bindir}/raio_server
116%attr(755,root,root) %{_bindir}/reg_basic_mt
117%attr(755,root,root) %{_bindir}/xio_*
118%attr(755,root,root) %{_bindir}/xioclntd
119%attr(755,root,root) %{_bindir}/xiosrvd
120%attr(755,root,root) %{_libdir}/libraio.so.*.*.*
121%attr(755,root,root) %ghost %{_libdir}/libraio.so.0
08f63b58
JB
122%if %{with fio}
123%attr(755,root,root) %{_libdir}/libraio_fio.so
124%endif
1540f4c8
JB
125%attr(755,root,root) %{_libdir}/libxio.so.*.*.*
126%attr(755,root,root) %ghost %{_libdir}/libxio.so.0
127
128%files devel
129%defattr(644,root,root,755)
130%attr(755,root,root) %{_libdir}/libraio.so
131%attr(755,root,root) %{_libdir}/libxio.so
132%{_libdir}/libraio.la
133%{_libdir}/libxio.la
134%{_includedir}/libraio.h
135%{_includedir}/libxio.h
136%{_includedir}/xio_base.h
137%{_includedir}/xio_predefs.h
138%{_includedir}/xio_user.h
139
140%if %{with static_libs}
141%files static
142%defattr(644,root,root,755)
143%{_libdir}/libraio.a
144%{_libdir}/libxio.a
145%endif
This page took 0.056499 seconds and 4 git commands to generate.