]> git.pld-linux.org Git - packages/accel-ppp.git/blob - accel-ppp.spec
09625951e1aabc040063e5bdc13aa28055899899
[packages/accel-ppp.git] / accel-ppp.spec
1 # TODO:
2 # - check accel-ppp.tmpfiles
3 # - logrotate archivedir
4 # - add bconds
5 #
6 Summary:        High performance PPTP/L2TP/PPPoE server
7 Name:           accel-ppp
8 Version:        1.6.1
9 Release:        0.1
10 License:        GPL v2+
11 Group:          Networking
12 URL:            http://sourceforge.net/projects/accel-ppp/
13 Source0:        http://downloads.sourceforge.net/accel-ppp/%{name}-%{version}.tar.bz2
14 # Source0-md5:  8985ab9f743b952396f6dc53d6fd56a8
15 Source1:        %{name}.tmpfiles
16 Source2:        %{name}.init
17 Source3:        %{name}.logrotate
18 Patch0:         %{name}-cmake.patch
19 Patch1:         %{name}-cmake-lib64.patch
20 BuildRequires:  cmake >= 2.6
21 BuildRequires:  libnl1-devel
22 BuildRequires:  net-snmp-devel >= 5.0
23 BuildRequires:  openssl-devel
24 BuildRequires:  pcre-devel
25 BuildRequires:  rpmbuild(macros) >= 1.600
26 BuildRoot:      %{tmpdir}/%{name}-%{version}-root-%(id -u -n)
27
28 %description
29 The ACCEL-PPP is completly new implementation of PPTP/PPPoE/L2TP which
30 was written from scratch. Userspace daemon has its own PPP
31 implementation, so it does not uses pppd and one process
32 (multi-threaded) manages all connections. ACCEL-PPP uses only
33 kernel-mode implementations of pptp/l2tp/pppoe.
34
35 Features:
36 - PPTP server
37 - PPPoE server
38 - L2TPv2 server
39 - Radius CoA/DM(PoD)
40 - Built-in shaper (tbf)
41 - Command line interface (telnet)
42 - SNMP
43 - IPv6 (including builtin Neighbor Discovery and DHCPv6)
44
45 %prep
46 %setup -q
47 %patch0 -p1
48 %ifarch %{x8664}
49 %patch1 -p1
50 %endif
51
52 %build
53 install -d build
54 cd build
55 %cmake \
56         -DSHAPER=TRUE \
57         -DRADIUS=TRUE \
58         -DNETSNMP=TRUE \
59         -DBUILD_INSTALL_PREFIX=$RPM_BUILD_ROOT \
60         -DLOG_PGSQL=FALSE \
61         ..
62 %{__make}
63
64 %install
65 rm -rf $RPM_BUILD_ROOT
66 %{__make} -C build install/fast \
67           DESTDIR=$RPM_BUILD_ROOT
68
69 install -d $RPM_BUILD_ROOT/etc/{sysconfig,logrotate.d,rc.d/init.d} $RPM_BUILD_ROOT%{systemdtmpfilesdir}
70 cp -p %{SOURCE1} $RPM_BUILD_ROOT%{systemdtmpfilesdir}/%{name}.conf
71 install -p %{SOURCE2} $RPM_BUILD_ROOT/etc/rc.d/init.d/accel-pppd
72 cp -p %{SOURCE3} $RPM_BUILD_ROOT/etc/logrotate.d/%{name}
73 echo "0" > $RPM_BUILD_ROOT/var/run/accel-ppp/seq
74
75 %clean
76 rm -rf $RPM_BUILD_ROOT
77
78 %files
79 %defattr(644,root,root,755)
80 %doc README
81 %dir %{_sysconfdir}
82 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) %{_sysconfdir}/accel-ppp.conf.dist
83 %attr(640,root,http) %config(noreplace) %verify(not md5 mtime size) /etc/logrotate.d/%{name}
84 %attr(755,root,root) %{_sbindir}/accel-pppd
85 %attr(755,root,root) %{_libdir}/accel-ppp
86 %attr(754,root,root) /etc/rc.d/init.d/accel-pppd
87 %dir /var/run/%{name}
88 # XXX do you really want to overwrite this?
89 /var/run/%{name}/seq
90 %{systemdtmpfilesdir}/%{name}.conf
91 %{_datadir}/%{name}
92 %{_mandir}/man5/accel-ppp.conf.5*
93 %dir /var/log/accel-ppp
This page took 0.059314 seconds and 2 git commands to generate.